locked
Sysprep error (SideShow) RRS feed

  • Question

  • I am using MDT 2013 to make a fresh image on a VM and am failing at syspreping it before capture.

    This is the error:

    SYSPRP WindowsSideShow: Failed to get task folder (0x80070002)
    SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\System32\AuxiliaryDisplayClassInstaller.dll,WindowsSideShow_Sysprep_Generalize', returned error code 31
    SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 31
    SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x8007001f

    I went as far as to just install Win7Enterprise with no apps and still failed. After reading some posts I tried by removing:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Sysprep\Generalize\{b636fa27-124f-6436-6a6f-2fe2739a2b89} per this post and this worked!

    I guess my question is should this just be a test or a workaround and should I just delete this key before syspreping every time? What am I losing by removing this key?

    Very new to sysprep so I am still learning.

    Thanks,

    Scott
    Wednesday, August 31, 2016 12:10 PM

All replies