none
Memory errors / crashes with Project 2007 on Windows 7 RRS feed

  • Question

  • I have both MSP 2007 sp3 and MSP 2010 sp1 (32 bit) running on Windows 7 (64 bit). It has been running happily for months, so I had to mess with it didnt I......  I installed the service pack for Windows 7 (sp1) since which time I am getting crashes when I use the organiser in Project 2007, the code is c0000005 offset 00fc742.

    If I boot the machine, dont connect to the network or load anything other than project 2007 and then go into tools / organiser and try and copy a customised field to the global template it crashes. The same happens if I try and copy between project files - files in 2007 format. I am using 2007 due to compatibility issues with other contributors. The organiser seems to be working in 2010.  I have no means of uninstalling the service pack.

    If anyone can shed some light on this it would be much appreciated as I really dont want to go to 2010 and end up with a mix of versions in play.

    Thanks

    Ian

    UPDATE:

    If I double click a task project blows up in the same way, same error, same offset. Yet all is fine under project 2010. I've tried saving out to xml and back incase is a bad set of  files but this hasn't helped. If I open a blank new project it seems ok, which makes me think its file corruption but then how to clear if xml export wont work? I have colleagues who also have Project 07 sp3 running on windows 7 sp1 and they are ok, but I dont want to pass a file over in case this is catching.... I am beginning to wonder if this is sensitive to the order things were built. I had project sp3 first and then, months later, applied the windows service pack, the other guys are on new kit built with win7 sp1 before project was loaded. I'm going to try taking project out completely and re-installing and see what happens.

    This is driving me mad.

    Ian

    Monday, October 29, 2012 5:26 PM

All replies

  • First run a repair on 2010, then run a repair on 2007. Does that help?

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Friday, November 2, 2012 2:10 PM
    Moderator
  • Thanks Gary.  I've decided to go at this on 2 fronts. I have 4 plans affected and all copies since I put the wondows sp on, so something not good is happening to the plans. I've run the repairs you suggested. It makes no difference to the way the affected plans behave, I've become pretty convinced I've got damaged files. I tool one over to an old machine running 2007 and the problems came with it.

    Tried to export to excel. Obviously cant take all the fields out so just taking chunks to see what I could read and write. Turns Out I couldnt touch the Enterprise text fields, dont know if its all or just one, dont really care. As I'm sitting on a stand alone desktop I dont need them. So I saved the files using 2007 into 2000 format (wont support the fields). Then using 2010 - which seemed to be more tolerant of the problems - opend them and saved as xml to try and clean up. Then went back to 2007 and opened the xml and saved as 2007. A bit of a saga but ..... the files look ok on my old machine and my current workhorse. Time will tell if the repairs have fixed the underlying problem. It took quite a while to run through 2010 but 2007 went quickly. A message box flashed up at the end of the 2007 run but it didnt persist long enough for me to read it, is there a log somewhere?

    Now continuing with fingers crossed (tricky!) and lots of backups. So far so good.

    Ian

    Monday, November 5, 2012 1:16 PM