locked
Communicator VoiceMail Configuration RRS feed

  • Question

  • Hi Everyone,

    I didn’t really know where best to post my question as it is probably equal parts of OCS, Exchange UM and Communicator, and it’s a bit involved but here goes...

    I currently have OCS 2007 R2 deployed and I'm attempting to integrate it with a Cisco CallManger Express 7.1 deployment. The Communicator users are configured as Enterprise Voice clients and that side of things works really well- MoC to MoC calls, MoC to Cisco IP phone (7960) and MoC to PSTN (both via an OCS mediation server) all work really well. My problems start with auto attendant calls and voicemail (I'm using Exchange UM for both).

    I have two dial plans on the Exchange box- "CiscoCME" and "UnifiedCommunications", the Cisco dial plan uses the router running CME as its IP gateway, the UC dial plan uses the OCS pool as its gateway. Each dial plan has an appropriate (to be honest, identical) mailbox policy and auto attendants setup. Depending on how I configure the Exchange mailboxes (i.e. which mailbox policy and EUM address I set as the reply address) the users experience differs in the following way.

    When the users are configured with the "UnifiedCommunications" mailbox policy as their default (through the enable unified messaging wizard in the EMC) and I add a secondary EUM address which is the users’ extension number in the "CiscoCME" dial plan the following happens:

    When I press the "messages" button on a 7960 phone (VM is configured in CME as extension 4200 and appropriate SIP trunks have been created) I go through to Exchange UM and get "Welcome you are connected to Microsoft Exchange Stephen Cooper, please enter your PIN then press #" and I also get the option in Communicator to call voicemail (which automatically logs me in, I don’t need to enter my PIN), change greeting and forward calls to voicemail. This is pretty cool, and would be great if it weren’t for the way the auto attendant behaves.

    If I dial the auto attendant from a 7960 (or the PSTN) I get the "Welcome to the Microsoft Exchange auto attendant..." prompt, but when I try and call someone it goes direct to their voicemail. I guess this has something to do with the reply EUM address bing set to the UC dial plan EUM address (<username.domain>;phone-context=UnifiedCommunications.<domain>).

    With the same configuration but the number in the CiscoCME dial plan as the reply EUM address the following happens:

    If I dial the auto attendant it correctly routes the call (i.e. it rings the phone, not divert to voicemail), but the voicemail features of Communicator disappear- I don’t have the menu items “call voicemail” and “change greeting”, nor can I forward calls there. I can however still call the voicemail by dialling 4200 in Communicator- I get "Welcome you are connected to Microsoft Exchange Stephen Cooper, please enter your PIN then press #" which I can live with to be honest- the problem is forwarding calls to voicemail. I thought I would be able to put “4200” in the “send unanswered calls to” setting in call forwarding options but when a call is forwarded in this manner the caller receives the generic “Welcome you are connected to Microsoft Exchange, to access you mailbox...” greeting from OVA, rather than ”Please leave a message for Stephen Cooper”.

    The problem is that it’s vital to the deployment to have both a correctly functioning auto attendant and the voicemail functionality in Communicator. Is there any way to configure the Communicator client to allow the VM access with the Cisco dial plan number as the default? I was thinking maybe through a GPO or something?

    I’d appreciate any help you can offer.

    Thanks

    Steve

     

    • Moved by Ben-Shun Zhu Tuesday, May 4, 2010 9:19 AM cross posting (From:Communicator Clients and Devices)
    Thursday, April 29, 2010 10:05 AM