locked
Question about publishing Calendar and URLs RRS feed

  • Question

  • Hi everyone, have a question that hopefully knows the answer too. I have been researching on how to publish individual user calendars to external users.

    I have seem to come across 2 different ways to do this

    1) is to right-click on my calendar in OWA, then I select the external recipient and it emails the recipient a long url similar to:

    http://webmail.mydomain.com/owa/calendar/dd990ebc859e47b3b3ab9e250ee126c2@MYDOMAIN.com/4d9f8b52769b4ddca3e51f6f82d01b6f1902995877095312719/S-1-8-2306188436-3125773453-2945785077-3615357645/reachcalendar.html

    2) Within Outlook 2013, I click on "publish calendar" and it takes me to an ECP url for my exchange server where I can select how many months I want to share, the permission they can see, etc... and then it provides me at the bottom with two links like:

    http://webmail.mydomain.com/owa/calendar/user@mydomain.com/Calendar/calendar.html

    My question is what are the differences between these two methods and also, both of these urls will NOT work unless I change them to HTTPS instead, how I can modify the links that get emailed out? I did see for the 2nd method above I can set it using the "PublishedCalendarUrl" in Powershell, but that is impractical for a lot of users.

    thanks!

    Tuesday, February 18, 2014 3:55 PM

Answers

  • Looks like this is by design and there is no way to specify this to be https instead of http, I just decided to stock with the http url
    • Marked as answer by BMIG Monday, February 24, 2014 12:42 PM
    Monday, February 24, 2014 12:42 PM

All replies

  • Hi BMIG,

    The second "publish calendar" url you get - is the proper one.

    You get the HTTP urls because the OWA Internal(/External) urls at your CAS server are set as HTTP. Once you change it to HTTPS - the calendar sharing urls will follow the server settings. Here is how to do it.


    ▲ Vote if Helpful / Mark if Answer

    MCSE: Messaging 2013 Charter / Private Cloud / Server Infrastructure
    MaximumExchange.ru

    Tuesday, February 18, 2014 4:57 PM
  • Thanks for that info, I ran a get-owaVirtualDirectory and my "InternalURL" and "ExternalURL" are both pointing to the HTTPS site, is there another parameter I should be changing in there instead of those 2?

    Tuesday, February 18, 2014 5:03 PM
  • Hi BMIG,

    Based on my knowledge, there is no another parameter should be changed.

    Please use HTTPS URL for testing.

     

    Feel free to contact me if there is any problem.

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    Friday, February 21, 2014 2:19 AM
  • Hi BMIG,

    Based on my knowledge, there is no another parameter should be changed.

    Please use HTTPS URL for testing.

     

    Feel free to contact me if there is any problem.

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    Yes thanks, I have modified the "ExternalUrl" and "internalUrl", I can change everything AFTER the http:// but it will not change to https://

    set-owavirtualDirectory -ExternalURL "https://something.domain.com/owa"

    will still bring up http://something.domain.com/owa when I go to publish my calendar. It's as if Exchange does not want me to publish via https, but only via http

    Friday, February 21, 2014 4:43 AM
  • Hi BMIG,

    Please re-start IIS for testing.

    If not working unfortunately, please use IIS Manager to simplify the OWA url and force redirection to SSL.

    Steps as below:

    1. Start IIS Manager.

    2. Expand the local computer, expand Sites, and then click Default Web Site.

    3. At the bottom of the Default Web Site Home pane, click Features View if this option isn't already selected.

    4. In the IIS section, double-click HTTP Redirect.

    5. Select the Redirect requests to this destination check box.

    6. Type the absolute path of the /owa virtual directory. For example, type https://mail.contoso.com/owa.

    7. Under Redirect Behavior, select the Only redirect requests to content in this directory (not subdirectories) check box.

    8. In the Status code list, click Found (302).

    9. In the Actions pane, click Apply.

    10. Click Default Web Site.

    11. In the Default Web Site Home pane, double-click SSL Settings.

    12. In SSL Settings, clear Require SSL.

    13. For the new settings to take effect, open a Command Prompt window, and then type iisreset /noforce to restart IIS.

    Details in the following article:

    Simplify the Outlook Web App URL

    http://technet.microsoft.com/en-us/library/aa998359(v=exchg.150).aspx

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    Friday, February 21, 2014 5:53 AM
  • Thanks, I guess I will also add this

    when a client goes to the HTTPS site, everything works, OWA and the Calendar link.

    The only issue I have is on the page where the user can retrieve his URL to give to external contacts, it doesn't  update correctly

    but if the user THEN copies the URL provided and changes the http to https it works. What I'm trying to change is the URL listed above so that the users do not need to remember to change the links from http to https

    Friday, February 21, 2014 12:41 PM
  • Looks like this is by design and there is no way to specify this to be https instead of http, I just decided to stock with the http url
    • Marked as answer by BMIG Monday, February 24, 2014 12:42 PM
    Monday, February 24, 2014 12:42 PM