none
DPM 2010 not backing up real user data. only admin profile. RRS feed

  • Question

  • Server and Clients are both running 3.0.7707.0. We are already backing up our server with DPM. 

    We are exploring to use DPM to backup our Windows desktop. I created a group to backup my documents, desktop, bookmarks, etc. The desktop is configured in the following way. There are 3 users:

    • user1 is a local account with admin rights to the desktop
    • user2 is a domain account with admin rights to the desktop. This is an account admin uses to configure desktop. 
    • user3 is a domain account with admin rights to the desktop. This is an actual user of the desktop whose data i want to backup.

    Both workstation and DPM server are joined to the same domain. Clients are windows 7. 

    I installed the agent manually on the client using "installer_file.exe DPM_Server_Name" command. I then attached it on the DPM server using user2 credential. I set it to backup every week with synchronizatoin happening every 24 hours. 

    Problem:

    backup runs fine, but i'm only seeing user1 and user2 under the recovery tab. No entry for user3. When the backup ran, user3 was currently logged on to her machine. why is user3 not getting backed up? do i need to get each user to enter their credential when i attach the client?

    anyone has a suggestion maybe? i'm stuck at this. i tried installing it on 3 windows 7 stations they all behave the same way, not backing up user3 data. when i spin up a fresh win 7 VM, it does backup user3 data. 


    Wednesday, April 11, 2012 12:20 PM

All replies

  • have you tried pushing the client to the machine vs manually installing it?

    also make sure the user logs on and saves some stuff.

    this might sound like a silly question but what do you have set to include?

    Saturday, April 14, 2012 12:08 AM
  • I tried automatic installation, but it did not work. Most likely firewall exception isn't setup on client computer, and it was blocking the connection. So, it tried manual install and supply DPM server name. the same way i did for my server.

    we are trying to switch from an older backup product(retrospect). So, several users I tried the agent with has well over 5GB worth of data in it. They were not previously backed up by DPM. For some reason DPM just doesn't backup the user's data.

    I tried backing up desktop, documents, favorites, and that didn't work. So,  i deleted the protection group, and created a new one and tried to backup just desktop. This also didn't work.


    Monday, April 16, 2012 12:28 PM
  • We are also using DPM 2010 for client backups. For a long time already (Since it got released), but we have the same problem as decribed by rickybud7. Strange thing is that it is not the case for all laptops.

    Looks like this thread describes the same issue, but no solution either.

    http://social.technet.microsoft.com/Forums/en-US/dpmlpprotection/thread/19c8ebcf-ade9-4268-ace7-56d93db53b94

    The PSDataSourceConfig.xml on our clients are also missing the configured folders other than for the local administrator


    • Edited by Mister Iks Wednesday, April 25, 2012 4:14 PM
    Wednesday, April 25, 2012 4:09 PM
  • Hi Rickbud7

    Thanks for your response, but your solution is not really a real solution.

    I can't go to every workstation to fix this issue.

    I would like to get a real solution from the DPM team on this issue cause it seems that more companies are affected.

    Friday, April 27, 2012 12:08 PM
  • I prematurely marked that as an answer. It worked for one day only. The next day all the profiles are being skipped again. so....... back to no solution again. Please MS..... help!!
    Friday, April 27, 2012 12:15 PM
  • I have a DPM 2010 setup running on my network. Laptop users are getting the agent pushed to their systems.  Just checked my protected systems, i have users with different permissions on their local machines.  Some have normal user rights, others have admin rights.  Looking at the recovery items i appear to have all users stuff getting grabbed.    I'm also testing DPM 2012, its okay.. some nice improvements some serious features lacking. (NO BUILT IN VTL!! Microsoft needs to get with the times and create long term archive to disk!) 

    You dont do any folder redirection or sync (offline folders) setup for these users do you?

    Friday, April 27, 2012 6:50 PM
  • I found out what was causing the issue for us.

    We are currently using DPM 2010 in production to back up our client computers  and servers.

    In DPM protection group for the clients we specified to include the folders “Desktop”, My Documents” and “Favorites”

    For about 50% of the clients the DPM client did not backup the data of the actual owner of the computer. But it did backup the specified folders for the local administrator and a domain administrator that also had a local profile on the computer.

    The file ClientProtectionDetails.xml also did not contain any entries for the user only for the local administrator.

    We reported a case at Microsoft to get this resolved because at this point we could not rely on DPM for the backup of data located on the laptops.

    We had several remote sessions with a few different MS support engineers but a cause of this issue was never found. In the end Microsoft suggested a workaround which basically meant we needed to manually select the folders on each client we wanted to have in the backup. Not a real solution of course, but knowing that we would migrate to DPM 2012 anyway and expected that that would solve the issue we accepted to close the ticked.

    Last week I did a fresh installation of a DPM 2012 server (New server, new database). I created a client protection group with the same folders and then deployed the new DPM agent to my own laptop which was one of the laptops that experienced the issue with DPM 2010.

    To my surprise my own folders were still not automatically selected in the DPM 2012 client!

    So, back to troubleshooting!  I launched procmon to monitor the DPM client service executable (DPMClientService.exe). I watched when ClientProtectionDetails.xml got updated. Stopped the monitor and then scrolled back and then saw this

    I Jumped to the registry and indeed, no values except for one called “!Do not use this registry key”. For local administrator that did get his folders in the backup these values did exist.

    I then created all values (export > import from a working laptop and changed username) and again monitored with procmon. Of course this time the values did get found and voila!! The ClientProtectionDetails.xml file got filled with folders to backup for my own user and the DPM client started syncing these folders. J

    So apparently the DPM 2010 and 2012 clients both still rely on the legacy key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

    I wonder why this is. I also wonder why the values in this key got removed on many of our laptops. It could be that we messed up this key ourselves at some point, but still… this should not have impacted the DPM client if it did not rely on the old legacy shell folders key.

    http://technet.microsoft.com/en-us/magazine/2005.11.windowsconfidential.aspx

    As a solution we are going to make sure the old legacy shell folders key registry values will be created in the user profile.

    This will be done with RES Workspace Manager.

    • Proposed as answer by Mister Iks Thursday, November 15, 2012 2:47 PM
    Thursday, November 15, 2012 2:47 PM