none
Unable to Share Calendars Externally RRS feed

  • Question

  • Hi,

    I'm trying to set up a calendar so that it's shared externally. I've set the default settings for ALL users in the organization to allow sharing with ANY domain - just to make certain that I should be able to do this. I waited 30 minutes and came back, and the "switch" for external sharing in the Admin panel on OWA is set to ON. Should be all good to go. 

    However, when I attempt to share the calendar as per the instructions here: https://www.youtube.com/watch?v=YCNfJuFymQU

    I still get the message "You don't have permission to share information with the following email address: [insert email address here]"

    What gives? Is there a step I don't know about? Is this feature broken? How do I contact Microsoft and address this issue? I need this fixed by tomorrow. 

    Thanks,

    Jacob

    Monday, February 2, 2015 4:14 AM

All replies

  • Hi

    As per the information and details provided by you, to share a calendars externally, please follow these steps: -

    Step 1: - To enable Anonymous Calendar Sharing, open the Exchange Administration Center and navigate to Organization > Sharing. In the Individual Sharing section, edit the Default Sharing Ploicy.

    Step 2: - Choose Add to add a new domain to the Default Sharing Policy.

    Step 3: - After doing so, the Sharing Rule window will open. You might want to choose the Sharing with all domain options, which incidentally is selected by default, but choosing this option will have no effect, as it relates to other domains that use the Exchange Federated Sharing feature. Instead, choose Sharing with a specific domain and enter Anonymous.

    Step 4: - We will also choose the maximum level of detail that all users will be able to share with external users to include All calendar appointment information.

    Step 5: - After choosing to save the new rule, verify that the additional Anonymous domain is listed within the Default Sharing Policy and save the changes.

    Note: - Our next step within Exchange server is to ensure that Anonymous Calendar sharing features are ready for use in Exchange Itself. We will use the Exchange Management Shell to configure this setting against each Exchange 2013 Mailbox Server, using the following command: -

    Get-OWAVirtualDirectory -Server <ServerName> | Set-OWAVirtualDirectory -AnonymousFeaturesEnabled:$True

    I hope this information will be helpful for you.

    Thanks and regards

    Shweta@G

    • Proposed as answer by MattGrimley Friday, May 6, 2016 1:38 PM
    Monday, February 2, 2015 6:26 AM
  • Thanks for the help. We have an office 365 / hosted exchange account and i have no idea how to access the exchange management shell. I've looked for a way to download this program previously but haven't found any ways to do this.

    There appear to be controls both in the office 365 settings that need to be set (to allow sharing with anonymous domains) as well as the exchange settings... I wasn't aware of the need for sharing with anonymous domains and did have the "all domains" setting instead. I've changed. Hopefully it's not required that I use the management shell because i'm not sure how to get there. 

    Thursday, February 5, 2015 3:52 PM
  • It worked! Thanks. I'll have to make sure she can see the calendar but I was able to share from OWA without an issue. 
    Thursday, February 5, 2015 3:54 PM
  • I'm here from the future. Banged my head on the wall for a couple of hours over this before finding your post. I was confused because the default policy is set to share with all domains, but apparently that doesn't actually mean share with all domains. Your fix worked perfectly. Thank you very much!
    Tuesday, October 15, 2019 12:23 AM