Can't register OCX in Windown 7 RRS feed

  • Question

  • Win 7 Home Premium (32bit). Tried to register OCX  with regsvr32 running as Admin several ways with no success.

    Error: " ... module failed to load ...  The specified module could not be found".

    Tried from home directory of the OCX and from Windows\System32 directory after copying the OCX there. Tried from icon, batch file and directly in a command window. Each time the OCX is clearly in the run directory.  Have sucessfully registered under Win 7 Ultimate (64bit), XP Professional and 2000 server.

    Need your help.


    Friday, September 23, 2011 11:06 PM


  • Problem resolved by running in System32 directory and specifying the full home path of the OCX. Perhaps other DLL's called by the OCX were causing the problem.

    Sorry about that .... but, now another problem: The application that uses the OCX starts and immediately terminates .... the same problem I experienced under 64 bit Win 7.

    Hope I don't have to purchase a newer version of the application to make this work.

    • Marked as answer by Windows Junkie Friday, September 23, 2011 11:38 PM
    Friday, September 23, 2011 11:36 PM