locked
Login failed for user when connecting to custom database RRS feed

  • Question

  • I have a sharepoint site which contacts the content database through a domain\user account. The same site needs to connect to a custom database located in the same server as the content datdbase through the same user account. Strangely am not able to connect to the custom adtabase through windows accounts, it always says " Login failed for user domain\user" in the ULS logs.

    But am able to connect successfully through "sa" login that I created in the database server
    Any idea?

    • Moved by Mike Walsh FIN Wednesday, June 15, 2011 10:01 AM Hardly a programming question - moving to admin (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Wednesday, June 15, 2011 8:21 AM

Answers

  • Hi

    Check if the App Pool account which your sharepoint site is running has access to your Custom Database.

    Regards

    Ranga

    • Marked as answer by David HM Thursday, June 23, 2011 1:33 AM
    Wednesday, June 15, 2011 8:52 AM

All replies

  • Hi

    Check if the App Pool account which your sharepoint site is running has access to your Custom Database.

    Regards

    Ranga

    • Marked as answer by David HM Thursday, June 23, 2011 1:33 AM
    Wednesday, June 15, 2011 8:52 AM
  • The app pool account is infact the system administrator of the database server. I have also tried to login to sql mgr studio using this accounut from another server, it worked.
    Wednesday, June 15, 2011 9:08 AM