locked
Hard to create shortcuts in Users\Public\Desktop RRS feed

  • Question

  • Hi all,

    I can't find this documented anywhere...

    When I browse to %SystemDrive%\Users\Public\Desktop in Windows Explorer, the right-click "Paste shortcut" command generates the following error message:

    Windows can't create a shortcut here.
    Do you want the shortcut to be placed on the desktop instead?

    In addition, the "Create shortcut" menu item is missing when I right-click -> New.

    To put shortcuts in that folder like I want, I have to create the shortcuts elsewhere and copy them over, or create the shortcuts programmatically (e.g., WshShell.CreateShortcut).

    Can anyone provide any details on this behavior?

    Thanks!

    Bill

    Sunday, January 24, 2010 2:23 AM

Answers

  • The answer is that Explorer always runs non-elevated, despite attempts to run it elevated. If you run an elevated instance of another file manager (e.g., Explorer++), it's possible to create shortcuts in Users\Public\Desktop.

    Bill

    • Marked as answer by Bill_Stewart Friday, May 28, 2010 10:33 PM
    Friday, May 28, 2010 10:33 PM

All replies

  • Hi Bill

    The Public\Desktop folder is the location for All Users in Windows 7.

    Since anything performed in that folder affects all users on the system, it is heavily restricted.

    You have already found the best way to add shortcuts there, by creating them in another folder and moving them to the public desktop folder using an Administrator account.

    The only other way to do this is to take ownership of that folder and change the permissions. This is definitely not recommended since it reveals and opens a well known path for malicious infections.

    Hope this helps.

    Thank You for using Windows 7


    Ronnie Vernon MVP

    • Proposed as answer by Ronnie VernonMVP Sunday, January 24, 2010 4:02 AM
    • Unproposed as answer by Bill_Stewart Sunday, January 24, 2010 5:26 AM
    • Proposed as answer by chmarroc Friday, September 14, 2018 7:51 AM
    Sunday, January 24, 2010 3:54 AM
  • Hi Ronnie,

    Thanks for the reply, but I think you're misunderstanding...

    It's not a permissions problem -- I'm running an elevated Explorer window. As I said, I can copy shortcut files there (and copy and delete any other files there as well). Also, note that the following script works as well:

    var fso = new ActiveXObject("Scripting.FileSystemObject");
    var wshShell = new ActiveXObject("WScript.shell");
    var allUsersDesktop = wshShell.SpecialFolders.Item("AllUsersDesktop");
    var shortcutName = "Command Prompt.lnk";
    var shortcutPath = fso.BuildPath(allUsersDesktop, shortcutName);
    var wshShortcut = wshShell.CreateShortcut(shortcutPath);
    wshShortcut.TargetPath = fso.BuildPath(fso.GetSpecialFolder(1), "cmd.exe");
    wshShortcut.Save();

    The above script (save it in notepad and name 'createCmdShortcut.js') programmatically creates the shortcut without problems (of course, you have to run it from an elevated command prompt window), so as I said, it's not a permissions problem -- if it were a permissions problem, the above script would fail (and it does, if you don't run it elevated).

    The problem I'm highlighting is that the "Create shortcut" menu item doesn't work (it generates the "Windows can't create a shortcut here" message), and the right-click -> New -> Shortcut menu item is missing when you target your Windows Explorer window on the Users\Public\Desktop folder. These things work fine when I change my Explorer view to some other folder. I can't find any documented reason for this behavior.

    Regards,

    Bill
    Sunday, January 24, 2010 5:26 AM
  • Sorry -- my comment earlier about running an elevated Explorer window was incorrect -- PrivBar proves that it is not currently possible to open an an elevated Windows Explorer window in Windows 7 with UAC enabled, even with the "Launch folder windows in a separate process" check box enabled.

    However -- even though the above is the case, it still doesn't explain why the Windows 7 UI prevents creation of shortcuts directly in \Users\Public\Desktop. You're forced to create a shortcut in some other location, and then copy and paste it to \Users\Public\Desktop. This UI decision forces knowledgeable users to go through extra steps and I can't find any justification for it.

    Does anyone know why Windows 7 doesn't want us to create desktop shortcuts?

    (As an aside, does anyone know why you can't run an elevated Windows Explorer window in Windows 7? It worked in Vista. I'll guess I'll start a separate thread for that one.)

    Bill
    Monday, February 1, 2010 6:54 PM
  • The answer is that Explorer always runs non-elevated, despite attempts to run it elevated. If you run an elevated instance of another file manager (e.g., Explorer++), it's possible to create shortcuts in Users\Public\Desktop.

    Bill

    • Marked as answer by Bill_Stewart Friday, May 28, 2010 10:33 PM
    Friday, May 28, 2010 10:33 PM
  • Hi,

    just for the case you´re still seaching for a easy way to solve your problem.

    When you deactivate UAC u can access "C:\Benutzer\Öffentlich" translated to your language it schould be "C:\User\Public". Here u can find the desktop folder where you can cerate copy and delete any shortcut you want.

    Hopefully it helps wasn´t able to start a test in a englisch environment.

    Matthias

    Sunday, June 13, 2010 6:43 PM
  • I am trying to change the icon on a shortcut I put in users/public/desktop and I get the error: Cannot apply changes to this internet shortcut.  I am going to the properties of the shortcut, click on 'change icon,' and pick an icon from the Windows list.  It looks like it will work until I click on ok.  I have also tried to copy the shortcut with the icon I want from my desktop into the public desktop, but it removed my special icon.

    Connie

    • Proposed as answer by BrewerDave Sunday, March 22, 2015 2:11 PM
    Thursday, August 5, 2010 6:15 PM
  • Here's an example of a method that worked for me in Windows 7. I wanted a public shortcut to the Major League Baseball streaming site "www.mlb.com/mediacenter". I created the shortcut on my desktop and changed the icon to the MLB "batter" logo. My username is "David". So I opened an administrator command prompt and issued the command   copy "c:\users\david\desktop\ml baseball.url"   "c:\users\public\desktop". That worked, including the icon change.
    Sunday, March 22, 2015 2:30 PM
  • The correct Path Address is %SystemDrive%\Users\Public\Public Desktop
    Wednesday, August 19, 2015 10:50 PM