none
Error code 0x80070005 during manual agent install. RRS feed

  • Question

  • Hi, 

    I'm implementing some DPM functionalities on my program.

    I was trying to install DPM 2010 agent on a desired server using WMI and following below steps in remote manner.

      (1) Copy installation file to a remote host. (Fine)

      (2) Execute AgentInstaller_x64.exe DPM (Error)

      (3) Execute powershell a script named Attach.....ps1 

    However, it failed in the second step.

    It failed when I typed with parameter; AgentInstaller_x64.exe  DPM

    So I tried workaround: I did Installation with no option(It worked fine), then execute SetDPMServer.exe.

    This time, I got an same error with SetDPMServer.exe 

     

    Looking at the log file, recorded errors.

    ----------------------------------------------------------

     

    0DA0 1674 .... 06 installagent.cpp(156)      NORMAL Agent installation started

    0DA0 1674 .... 06 installagent.cpp(163)      NORMAL Agent installation started for dpmserver [DPM.domain.com]

    0DA0 1674 .... 03 machinename.cpp(472)   WARNING Failed: Hr: = [0x80070005] : F: lVal :(UINT)DsRoleGetPrimaryDomainInformation(ssFqdn.PeekStr(), DsRolePrimaryDomainInfoBasic, (LPBYTE *)(&domainInfo))

    0DA0 1674 .... 03 machinename.cpp(480)   WARNING Failed: Hr: = [0x80070005] GetMachineNameInDomainFormat returned

    0DA0 1674 .... 06 installagent.cpp(164)     WARNING Failed: Hr: = [0x80070005] : F: lVal : CMachineName::GetMachineNameInDomainFormat(dpmserverNameInFqdn, dpmserverNameInDomainFormat)

    -------------------------------------------------------------------

     

    The server on what I want to install Agent has joined the same domain.

    Between two servers, there are no firewalls.(I turned them off)

    I also checked DCOM service. (no problem)

     

    How can I do to solve this problem?

     

    Best regards,

    Yeonki.

     

     

    Tuesday, March 15, 2011 6:50 AM

All replies

  • Hi,

    did you use your DPM server name with the DPMAgentInstall_x64.exe ?

    Like if your DPM server is name <DPM-Serv> you should use DPMAgentInstall_x64.exe <DPM-Serv>

     

    Same thing for SetDpmServer.exe that should be used with the -dpmservername switch.

    SetDpmServer.exe -dpmservername <DPM-Serv>

    Tuesday, March 15, 2011 1:36 PM
  • Thank Jeremy for reply.

     

    1. did you use your DPM server name with the DPMAgentInstall_x64.exe ?

     Yes, I did, but it failed to install. 

     I'd like to summarize my works:

          First, I tried to run  "DPMAgentInstall_x64.exe" with DPM server name, It failed.

         Second, I tried in a bit diffent way from the first.

                   1) Run "DPMAgentInstall_x64.exe"  with no parameter.

                       2) Run SetDpmServer.exe -dpmservername <DPM-Serv>

                   This time, I failed in 2) . same error with the first.

     

    What else I have to check in this matter? (except for firewall issue)

     

    Best regards,

    Yeonki.

     


     




     

     

    Wednesday, March 16, 2011 1:01 AM