locked
MP (SCCM2012SP1) mplist generate error 500. mpcert is working RRS feed

  • Question

  • On my replica server the MP generates Http 500 error whentest with mplist (mpcert is succesfull).

    In IIS windows Authentication is activated. And .net is installed

    The local IIS log says things like belov. Do not see the 500 error here:
    2013-06-18 09:59:11 10.45.21.144 GET /sms_mp/.sms_aut mplist 80 - 10.45.2.208 Mozilla/5.0+(compatible;+MSIE+9.0;+Windows+NT+6.1;+WOW64;+Trident/5.0) - 200 0 0 31
    2013-06-18 09:59:11 10.45.21.144 GET /sms_mp/.sms_aut mplist 80 - 10.45.2.208 Mozilla/5.0+(compatible;+MSIE+9.0;+Windows+NT+6.1;+WOW64;+Trident/5.0) - 200 0 0 31
    2013-06-18 10:10:13 fe80::5dc0:3426:3108:1794%12 GET /SMS_MP/.sms_aut MPLIST 80 - fe80::5dc0:3426:3108:1794%12 SMS_MP_CONTROL_MANAGER - 200 0 0 29

    Anybody have an Idea?

    SQL connection is valid. Have both tried to connect via local machine account, and by a desinated SQL account (no difference).
    Can it be an SPN issue?

    Hope someone can help.
    Claus

    Tuesday, June 18, 2013 12:33 PM

Answers

  • Hi

    And thank you for all the hints.

    To get it working I did the following:

    1) Changed the sqlseragent service to a domain account
    2) In AD on the machine accounts enabled "Trust this computer for delegating any service"
    3) Added the domain account for the SQL serveragent to the SysAdmin on both SQL's

    Regards

    Claus

    • Marked as answer by Claus Brandal Friday, June 21, 2013 9:38 AM
    Friday, June 21, 2013 9:19 AM

All replies

  • If you're getting 500 errors that aren't being reported by the IIS log, it's probably coming from the MP itself. Checking MP_Framework.log for errors would be a good start here.

    Edit: MP_GetAuth.log may be another good log to check as well.


    Check out my Configuration Manager blog at http://aka.ms/ameltzer


    Tuesday, June 18, 2013 5:51 PM
  • Hi Do you observe this behaviour after a reboot of the server ? Check ccmeval.log and mpcontrol.log

    _________________________________ Regards, Manohar Pusala

    Thursday, June 20, 2013 9:59 PM
  • Hi

    And thank you for all the hints.

    To get it working I did the following:

    1) Changed the sqlseragent service to a domain account
    2) In AD on the machine accounts enabled "Trust this computer for delegating any service"
    3) Added the domain account for the SQL serveragent to the SysAdmin on both SQL's

    Regards

    Claus

    • Marked as answer by Claus Brandal Friday, June 21, 2013 9:38 AM
    Friday, June 21, 2013 9:19 AM