none
Not seeing all languages when deploying Windows 7 RRS feed

  • Question

  • I have a captured Windows 7 WIM file that I am deploying via MDT 2013 Update 2. After capturing it, I mounted the WIM file, applied a language pack, and committed the changes. Remounting the WIM file and running

    dism /image:C:\mount /Get-Intl 

    confirms the presence of the language packs. I am not picking locale info via an unattend file but via the GUI. When I get to the locale part of the GUI, I only see the original language pack. I modified the lang.ini file in the WIM's folder to look like this:

    [Available UI Languages]
    en-us = 3
    fr-fr = 2
    
    [Fallback Languages]
    fr-fr = en-us

    How do I get MDT to present me a list to pick the other language pack?

    Thursday, February 25, 2016 8:49 PM

Answers

  • If you want the language packs to show up in the wizard they have to me imported into MDT and not part of the image.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    • Marked as answer by EntegyMVP Friday, February 26, 2016 2:12 PM
    Thursday, February 25, 2016 10:11 PM
    Moderator

All replies

  • If you want the language packs to show up in the wizard they have to me imported into MDT and not part of the image.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    • Marked as answer by EntegyMVP Friday, February 26, 2016 2:12 PM
    Thursday, February 25, 2016 10:11 PM
    Moderator
  • That's not how my Windows 10 image works though... Windows 10 the language packs are part of what I captured and when going through a deployment, the locale section offers all the language packs I added to Windows 10.

    I know that for 7 Pro I can't add language packs while it's running, so I added LPs after capturing knowing that the non-selected languages will be removed during install. In this scenario, the only way is to add the language pack to the Packages list and include it in the task sequence?


    • Edited by EntegyMVP Thursday, February 25, 2016 10:24 PM
    Thursday, February 25, 2016 10:24 PM
  • Yup, you were 100% right. The only easy way to do this is to import the LP into MDT and let it take care of adding LPs. Thanks!
    Friday, February 26, 2016 2:13 PM