none
Cannot create FIM Service MA - Failure to retrieve schema error keeps popping up RRS feed

  • Question

  • Hi,

    I am trying to create the FIM Service Management Agent and its failing every time. The message: Failed to retrieve schema keeps popping up. The error I get is as follows:

    mscorlib: System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at http://fim01:5725/ResourceManagementService/MEX that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond fim01:5725

       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

       at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

       --- End of inner exception stack trace ---

       at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)

       at System.Net.HttpWebRequest.GetRequestStream()

       at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStream()

       --- End of inner exception stack trace ---

    Server stack trace:

       at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStream()

       at System.ServiceModel.Channels.HttpOutput.Send(TimeSpan timeout)

       at System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.SendRequest(Message message, TimeSpan timeout)

       at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)

       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

    Exception rethrown at [0]:

       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

       at System.ServiceModel.Description.IMetadataExchange.Get(Message request)

       at Microsoft.ResourceManagement.WebServices.MetadataClient.Get(String dialect, String identifier)

       at Microsoft.ResourceManagement.WebServices.Client.ResourceManagementClient.SchemaManagerImplementation.RefreshSchema()

       at Microsoft.ResourceManagement.WebServices.Client.ResourceManagementClient.SchemaManagerImplementation.get_Instance()

       at Microsoft.ResourceManagement.WebServices.Client.ResourceManagementClient.get_SchemaManager()

       at MIIS.ManagementAgent.RavenMA.DoGetColumnInformation()

    Please assist on how to get past this error.

    With thanks.

    Wednesday, May 14, 2014 7:11 AM

Answers

  • Finally, I was able to create the FIM Service Management Agent only after applying the Hotfix KB2913228 on both the FIM Service server and the FIM Synchronization service server. I hope this helps someone else with a similar problem.

    Thanks to you all for your input and for trying to assist me with the issue.

    Regards.

    • Marked as answer by Josephine254 Friday, May 16, 2014 2:47 AM
    Friday, May 16, 2014 2:47 AM

All replies

  • Hello,

    anything specific about your FIM install or is it just a simple 1 server deployment ?

    this looks like its related to IIS...


    Hitch Bardawil

    Wednesday, May 14, 2014 10:11 AM
  • Seems like the FIM Service MA is unable to connect to the FIM web service. Is FIM Service running on another server? if so check your firewall. Make sure you can telnet on 5725 to the server running FIM Service. If it's running locally do a netstat -a and see if the local server is listening on 5725.  
    Wednesday, May 14, 2014 12:29 PM
  • Hi Hitch,

    The FIM Service and Portal are installed on one server, FIM01 and FIM Synchronization service on another server, FIM02. The database also recides on a different server, SQLCL1

    Thursday, May 15, 2014 3:37 AM
  • Yes, FIM Service is running on another server and cannot Telnet on 5725 to the FIM Service server. Thanks, I do hope that sorting the telnet issue will resolve the problem.
    Thursday, May 15, 2014 3:44 AM
  • Make sure FIMService is up and running on the FIM01, it so, please check your network/windows firewall settings. 
    Thursday, May 15, 2014 7:14 AM
  • Windows firewall is turned off (domain, public, and private) and the ports are open and listening and can now telnet to the FIM Service server
    Thursday, May 15, 2014 10:06 AM
  • I am now able to telnet through port 5725, but still not able to create the FIM Service Management agent. The port is listening as well. What could be wrong?
    Thursday, May 15, 2014 10:23 AM
  • Hello,


    During the installation (ofthe FIM Service and Portal), which account do you specify for the sync engine?

    Ensure that is the right one!

    Regards,


    Sylvain

    Thursday, May 15, 2014 11:36 AM
  • Finally, I was able to create the FIM Service Management Agent only after applying the Hotfix KB2913228 on both the FIM Service server and the FIM Synchronization service server. I hope this helps someone else with a similar problem.

    Thanks to you all for your input and for trying to assist me with the issue.

    Regards.

    • Marked as answer by Josephine254 Friday, May 16, 2014 2:47 AM
    Friday, May 16, 2014 2:47 AM