none
Rename Server 2008 domain name strange DNS issue RRS feed

  • Question

  • Hey guys, first post here and hoping someone may be able to help me resolve this. I have also included some pictures to give you a better idea. So I tackled the renaming of a server 2008 domain last night. Forrest level @ 2003. Everything on the rendom went very smoothly. I also created the newdomain.local DNS Zone before the rename or running any of the rendom commands. There was no errors or problems at all. The domain renaming "controller" member server was the only one to pop into the new DNS after 2 x reboots. I followed the below link to a tee. The Forrest is unfrozen. Today all clients are able to log in using their NEWDOMAIN\username there is no interruptions to their working day. As far as the client is concerned it all went well. However I can see in AD and DNS that the clients when being restarted twice are not automatically mapping to the new DNS Zone. Also i cant run gpfixup as I get an error "Could not get the domain controller name: 800705b" see the attached picture for the full error. I cant ping newdomain.local i can still ping olddomain.local - Also the dns suffix for all PC's is still olddomain.local - It is almost like we are running fine on a mixture of olddomain.local and the new netbios NEWDOMAIN\username .I wouldn't want to run the final rendom /cleanup command as it will remove olddomain.local zone and nothing will work. I manually added the A records on the newdomain.local zone for the new member servers. Sure i can also add the workstations - however this part was suppose to be automatic after the 2 x reboots. On closer inspection it is looking like the rendom /upload hasn't created the _msdc portions of the new zone file. The DC,GC,PDC etc portions in DNS are also sitting under the olddomain.local

    After a lot of reading This was the guide I used for the above rename. (If you google vkernel rename domain) Its the first link. Adrian Costea's blog - This wont let me post the link until verifying my account. 

    I must also point out that i attempted this first to fine tune in a test environment. Everything worked. gpfixup also worked. However on the live environment I am now stuck with this DNS issue. Really hoping someone can help! :) We have come to far to go back. 


    So in short
    1. Cant ping newdomain.local
    2. I can join new machines to the NEWDOMAIN\ network

    (Users also can and need to use the new netbios name to logon NEWDOMAIN\user)3. I cant run gpfixup as it cant resolve newdomain.local

    4. Existing client PC's after reboot are not automatically updating their DNS records and falling into the newdomain.local zone. They are remaining in the olddomain.local. 
    5. I have scoured the internet for hours and hours trying to find a solution.

    I have 2 images to upload however it wont let me until I verify my account.  


    Wednesday, July 27, 2016 2:08 PM

Answers

All replies