none
Error ID: 4387 during install of DPM 2010 RRS feed

  • Question

  • Fresh install of server 2008 R2 Ent. fully patched prior to DPM2010 install. SQL is being installed locally during the DPM install. DPM install fails at creating database with An Unexpected error occurred during installation ID: 4387.

     

    The DPM logs reads:

     

    [10/6/2010 8:33:11 PM] Information : MsiInstallProduct returned 0.
    [10/6/2010 8:33:11 PM] Information : End install.
    [10/6/2010 8:33:11 PM] Information : **************************************************************************************
    [10/6/2010 8:33:11 PM] Information : **************************************************************************************
    [10/6/2010 8:33:11 PM] Information : Start configuration.
    [10/6/2010 8:33:12 PM] Information : Query WMI provider for path of configuration file for SQL Server 2008 Reporting Services. (Namespace : \\localhost\root\Microsoft\SqlServer\ReportServer\RS_MSDPM2010\v10\admin).
    [10/6/2010 8:33:12 PM] Information : Query for WMI class. (Query : SELECT * FROM MSReportServer_ConfigurationSetting WHERE InstanceName='MSDPM2010').
    [10/6/2010 8:33:12 PM] Data : Path of configuration file for SQL Server 2008 Reporting Services = C:\Program Files\Microsoft DPM\SQL\MSRS10.MSDPM2010\Reporting Services\ReportServer\RSReportServer.config
    [10/6/2010 8:33:12 PM] Information : Starting Service:MSSQL$MSDPM2010 on machine:BWNDPM2010 flag restart:False
    [10/6/2010 8:33:12 PM] Information : Starting Service:SQLAgent$MSDPM2010 on machine:BWNDPM2010 flag restart:False
    [10/6/2010 8:34:15 PM] Data : dbScriptsPath = C:\Program Files\Microsoft DPM\DPM\Setup\DB
    [10/6/2010 8:34:15 PM] Data : sqlcmdPath = "C:\Program Files\Microsoft DPM\SQL\100\Tools\Binn\SQLCMD.EXE"
    [10/6/2010 8:34:15 PM] Data : instanceName = BWNDPM2010\MSDPM2010
    [10/6/2010 8:34:15 PM] Information : Deleting schedules
    [10/6/2010 8:34:15 PM] * Exception :  => System.Data.SqlClient.SqlException: The specified @category_name ('DPM') does not exist.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
       at System.Data.SqlClient.SqlDataReader.ConsumeMetaData()
       at System.Data.SqlClient.SqlDataReader.get_MetaData()
       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)
       at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)
       at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior)
       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlRetryCommand.InternalExecuteReader()
       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlRetryCommand.ExecuteReader()
       at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Configuration.DBConfigurator.DeleteSchedules(Boolean isRemoteDb)
    [10/6/2010 8:34:15 PM] Information : Creating folder to store database files
    [10/6/2010 8:34:15 PM] Information : Creating database
    [10/6/2010 8:44:17 PM] *** Error : CurrentDomain_UnhandledException

     

    Anyone have any ideas?

    • Moved by Praveen D [MSFT] Wednesday, October 20, 2010 5:31 AM Moving to DPM Setup Forum (From:Data Protection Manager)
    Thursday, October 7, 2010 4:04 AM

All replies

  • Hi

    When you ran the installation binaries did you run it as an administrator?

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Thursday, October 7, 2010 11:26 AM
    Moderator
  • The account I was logged in with is an admin on the server. I did not right click and choose run as administrator.

     

    Thanks,

     

    Gordon

    Thursday, October 7, 2010 2:40 PM
  • So I just wiped the box and did a reinstall of both the OS and DPM2010. Exact same error message. I must be missing something.

     

    Thanks,

     

    Gordon

    Thursday, October 7, 2010 6:12 PM
  • Could you please post some information regardign your domain since the last row is:

    "10/6/2010 8:44:17 PM] *** Error : CurrentDomain_UnhandledException"

    Is it a single domain, do you ahve trusts, transitive trusts, domain functinoal level etc etc etc

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Thursday, October 7, 2010 8:24 PM
    Moderator
  • It's a pretty simple domain. SBS 2008 server which house all the FSMO roles. No trusts with other domains. Functional level is Windows Server 2003. All servers are in the same office on the same IP subnet.


    Here are the sequence of the build.

    1. Build Server 2008 R2 Enterprise.

    2. Patch server fully. (on second rebuild I did not do this)

    3. Join server to domain

    4. Disable Firewall (on the first install I tried it with firewall on)

    5. Login with domain admin user

    6. Install DPM (prereqs & SQL seem to install fine)

    Error occurs during the actual DPM phase of the install when the installer is saying "Configuring Database"

     

    Given that this is a fresh build I'm at a loss. There are no errors in the event log that I can see.

    Thursday, October 7, 2010 9:41 PM
  • So does MSFT not monitor these forums? MSFT does not offer a forum on the partner site for DPM. Partners are directed here. I'm not thrilled with the prospect of having to open a paid support call just to demo DPM...

     

    Does anyone have any ideas on this issue?

     

    Thanks,

     

    Gordon

    Wednesday, October 13, 2010 4:18 PM
  • Hi Gordon,

     

    I have used DPM 2007 on SBS 2008 using a WIn 2008 Std box.   There is a DPM 2007 Whitepaper for SBS 2008.  Did you move the computer account to some other location.  I know this has caused issues with other servers in the past with member servers on SBS 2008.  I put mine in My Business -> Computers --> SBS Servers.   Just a hunch....

     

    Wednesday, October 13, 2010 8:14 PM
  • Don,

     

    I move the DPM server into the SBS Servers OU, but still have have the same issue. Thanks for the idea.

     

    Gordon

    Thursday, October 14, 2010 3:49 PM
  • did you gpupdate?

     

    Thursday, October 14, 2010 6:45 PM
  • I tried this, but it made no difference. I think I am going to try rebuilding the server with Sever 2008 and see if it's an R2 issue.

     

    Thanks,

     

    Gordon

    Tuesday, October 19, 2010 5:49 PM
  • the installation is failing at the time of creating a folder for the database files. Can you try the installation with new location for database files.

    Also can you please mail the DPMSetup.log located at <windowsdrive>\DPMLogs\ to chanchak[at]microsoft[dot]com


    -- Thanks Chandraneel Chakka[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, October 20, 2010 6:23 AM
  • Chandraneel,

    I changed the install folder to c:\dpm, bet still received the same error. Please check your email for the log file.

     

    Thanks,

     

    Gordon

     

    Wednesday, October 20, 2010 10:56 PM
  • Hi

    Place the installationfiles locally on the DPM server and run the installation again. I ran into a similar problem and copying the binaries to the DPM server and run the setup file did the trick in my case.

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Tuesday, November 2, 2010 8:47 PM
    Moderator
  • not sure what the official answer is but .... this worked for me

    make sure the DPMR$Servername account has proper rights to start the service.

     

    • Proposed as answer by z_lives Wednesday, February 16, 2011 5:11 PM
    Wednesday, February 16, 2011 5:11 PM
  • This is what worked for me:

    You will need to rebuild your wmi repository and re-run the setup.


    Follow these steps:
    1. Go to elevated command prompt.
    2. Stop the Windows Management service using "net stop winmgmt".
    3. Using Windows Explorer, rename the folder
    %windir%\System32\Wbem\Repository. (For example,
    %windir%\System32\Wbem\Repository_bad). %windir% represents the path to the
    Windows directory, which is typically C:\Windows.
    4. Start the windows management service using "net start winmgmt".
    5. rebuild the repository using "winmgmt /salvagerepository".

    Monday, April 25, 2011 8:14 PM
  • I have the same error, so I tried to do the steps suggested by KAKent.  But even after winmgmt apparently stopped, the Repository folder stayed locked.    I am not sure winmgmt really stopped because
              net start winmgmt
    reports "requested service has already been started."

    How can I find out what service is locking the Repository ?

    I happen to be installing DPM on a server that is also running Hyper-V and is a cluster node, so the install effort may be doomed in the long run anyway... I am only doing this because I need to test and understand DPM while waiting for a dedicated server. 

    So is a Dedicated Server an absolute requirement?

    Thanks, David

    Saturday, April 21, 2012 12:19 AM
  • I never got past  "Unexpected error occurred during installation ID: 4387"  but I have moved on and am having better luck using a Hyper-V virtual server to host the DPM.

    It does a fine job of replicating virtual hosts, so to a certain extent it must be satisfying the "Dedicated Server" requirement.

    But in order to back up the VM's I need to have DPM agent on the physical node/server.  So far no luck on getting the agent to install on the physical... I get error "Protection Agent cannot be Installed on machine where DPM is installed"

    This is not too surprising, since it is true.     The virtual DPM would need to communicate to an agent on its own host node server. 

    Does anybody know if this is possible?

    Thanks.

    Tuesday, May 1, 2012 5:18 PM
  • I have received this error on two separate site installs when I explode the ISO using WinRAR. Mounting the ISO to the VM's DVD solves it for me. Worth trying~
    Friday, January 3, 2014 3:02 PM
  • Thank You Eric many times. You saves big part of my night!

    Strange thing, but it is solution. Virtual CloneDrive, mount ISO and problem is gone.

    I always unpacking ISO and installing from files, but DPM 2012 R2 is unique :-))

    You have my vote.


    • Edited by Petr Kasl Tuesday, December 16, 2014 10:15 PM
    Tuesday, December 16, 2014 10:11 PM