none
Office XP unable to save file to My Documents or Desktop RRS feed

  • Question

  • I just rolled out WSS on two computers having the same restricted username and same restrictions. One of them has Office 2000 which I configure to save files to Desktop. No problem with that.

    I export this user and import to the second computer which has Office XP. I cannot save file to Desktop or My Documents. It says something like "Your action is restricted by the administrator, ..." - a typical windows permission message. However, I can use Wordpad to save file to the desktop or My Doc. Also I can use IE to dowload files to it so it is not NT permission.

    If I unhide the C:, I can then save it to any of those locations and other places on C: That beats the purpose of wiping out changes made by users upon log off since it is outside the profile. Also, I don't want to show what folders I have on C: I gave username.orig full control to that user but still no good.

    My restrictions are set to medium on both Windows restriction and Features restriction. Also, regardless the profile is locked or not, the same error message pops up, and I allow user to save files to Desktop,

    I see this behavior on other workstations with OfficeXP

    Any idea why?

    Thanks!


    Saturday, February 9, 2008 5:35 AM

Answers

  • Hi Jeanne,

     

    What they can modify is their user profile. Such as IE temp files, Desktop etc.,  files can be saved to Desktop, isn't it? The user profile also locates on drive C. That's why we cannot say it will deny all modifications. Actually, changes to system files & folders will not be allowed if you have "Prevent users from creating folders and files on drive C:\" selected.

     

    On the other hand, if you have user profile locked, profile changes will be cleared at log off. If you have WDP enabled and configured to "Remove all changes at restart", all changes will be deleted at restart/shutdown. So, unless users change the mode of WDP, there will be no modifications to the system.

     

    Regards,

     

    Friday, February 15, 2008 8:32 AM

All replies

  •  

    Hi,

     

    Thanks for posting here.

     

    If this issue only occurs after hiding drive C, how about enable the following restriction instead of hide drive C:

     

    Set Computer Restrictions -> Prevent users from creating folders and files on drive C:\

     

    This options can also limit the modification to drive C. In addition, you can also enabled Windows Disk Protection (WDP) and configure it to "Remove all changes at restart". It will restore all changes at restart.

     

    I haven't tested this with Office XP, if there is any update, I will post back soon.

     

    Best Regards,

    Wednesday, February 13, 2008 8:12 AM
  • Hello Shawn,

    I saw this post- a similar problem as to what I am experiencing- not being able to save from WORD to the desktop.  I did what you advised, plus removed "MY COMPUTER" from the public profile, to hopefully hide C drive from the public. I was able to save to desktop from WORD. We allow USB's and CD/DVD's so I would like people to have access to the content of their USB's and CD/DVD's from the desktop somewhere.  I went to START and SEARCH, FOR FILES AND FOLDERS, ALL FILES AND FOLDERS and see that people can look at the content of  USB there, but you can also look at the content of the C drive.  Can they alter the C drive if they have access to its contents?  You said limit the modifications, what could they modify? I would lock the public profile as well as put on Windows Disk Protection.

    I have tried so many different scenarios it just seems that I am doing something wrong.

    Thanks for your help,

    Jeanne

     

    Thursday, February 14, 2008 9:52 PM
  • Hi Jeanne,

     

    What they can modify is their user profile. Such as IE temp files, Desktop etc.,  files can be saved to Desktop, isn't it? The user profile also locates on drive C. That's why we cannot say it will deny all modifications. Actually, changes to system files & folders will not be allowed if you have "Prevent users from creating folders and files on drive C:\" selected.

     

    On the other hand, if you have user profile locked, profile changes will be cleared at log off. If you have WDP enabled and configured to "Remove all changes at restart", all changes will be deleted at restart/shutdown. So, unless users change the mode of WDP, there will be no modifications to the system.

     

    Regards,

     

    Friday, February 15, 2008 8:32 AM
  • Hi,

     

    I just made a local test on a Windows XP computer which has Office XP & SteadyState installed. I have the allow user save to Desktop option unchecked. There is no problem when saving files from Office XP.  I also tested this with Office 2003, also no problem.

     

    Regards,

    Wednesday, March 5, 2008 12:50 PM
  • This is all true, but what I really want to do is to hide the C: drive from the user while allowing both saving from either Office 2003 or 2007 and downloading from the web to either the desktop or My Documents. The files will then be deleted either during logout/login (with a locked profile) or on reboot (with WDP). The objective is to help our library patrons to attach a file to an email without purchasing a floppy, CDRW or flash drive. At the same time I don’t want them to view or open any files on the C: drive.

     

    Thorough testing has proven that neither “Prevent users from creating files and folders on Drive C:,” “Hide Drives: C:” nor “Prevent users from saving files to the desktop” will do exactly what I’m trying to achieve while hiding the C: drive.

     

    For the time being I’m hiding the C: drive from both the patron (and myself) using Group Policy. As seldom as I need to make changes, it’s less of a hassle for me to change it when I need to than this problem is for our patrons and librarians. For anyone interested, the setting is located in Local Computer Policy | User Configuration | Administrative Templates | Windows Components | Windows Explorer. Select Hide these specified drives in My Computer, and enable the setting. I also enable No “Entire Network” in My Network Places. Doing this allows saves and downloads to either the desktop or My Documents.

     

    Hope that helps at least one of you out there,

     

    ccchris

     

    Wednesday, April 30, 2008 10:05 PM
  •  ccchris wrote:

    This is all true, but what I really want to do is to hide the C: drive from the user while allowing both saving from either Office 2003 or 2007 and downloading from the web to either the desktop or My Documents. The files will then be deleted either during logout/login (with a locked profile) or on reboot (with WDP). The objective is to help our library patrons to attach a file to an email without purchasing a floppy, CDRW or flash drive. At the same time I don’t want them to view or open any files on the C: drive.

     

    Thorough testing has proven that neither “Prevent users from creating files and folders on Drive C:,” “Hide Drives: C:” nor “Prevent users from saving files to the desktop” will do exactly what I’m trying to achieve while hiding the C: drive.

     

    For the time being I’m hiding the C: drive from both the patron (and myself) using Group Policy. As seldom as I need to make changes, it’s less of a hassle for me to change it when I need to than this problem is for our patrons and librarians. For anyone interested, the setting is located in Local Computer Policy | User Configuration | Administrative Templates | Windows Components | Windows Explorer. Select Hide these specified drives in My Computer, and enable the setting. I also enable No “Entire Network” in My Network Places. Doing this allows saves and downloads to either the desktop or My Documents.

     

    Hope that helps at least one of you out there,

     

    ccchris

     

     

    Chris,

         I want to do the same thing with my machines, but I have a couple of questions. Which drives did you hide in GP and with that and the Network setting enabled do you still have the SS settings you listed above enabled?

     

    Sorry to be confused...

     

    Philip

     

    Tried to email you at the email you had listed under your profile but it bounced back..

    Monday, September 29, 2008 2:17 PM
  • Sorry so long in replying. I forgot to subscribe to alerts on this item.

    I only hide the C: drive. With drives and network hidden in group policy I do not enable items listed above in SteadyState. I put a shortcut to group policy on the desktop so I can enable/disable quickly.



    PCC
    • Edited by PC Chris Friday, May 8, 2009 6:13 PM
    Friday, May 8, 2009 6:10 PM
  • Chris.  Hello.  I have the exact same scenario as you.  My problem is I cannot see the Windows Explorer option once I click on Windows Components.  I only have Search / Windows Media Player / and Windows Updates as options.  Any help will be greatly appreciated.
    Tuesday, August 25, 2009 4:11 PM
  • I'm sorry but I can't seem to recreate your view. I am assuming you are logged in as admin because you can only open group policy as admin, not a power user or a user. (How about on another computer?) You should see NetMeeting, RSS Feeds, IE, application compatibility, attachment manager, windows explorer, microsoft management console, task scheduler, terminal services, windows installer, windows messenger, windows update, windows movie maker, windows media player.

    Can anyone else help Lucy?

    PCC
    PCC
    Tuesday, August 25, 2009 6:59 PM