none
Cannot add new user - Method not found: 'Microsoft.Exchange.VariantConfiguration.IFeature ADSettingsIni.get_DisplayNameMustContainReadableCharacter()'. RRS feed

  • Question

  • I recently updated to the CU 23 update, and mail is flowing correctly, but users cannot update their out of office from Outlook 2013 internally, and you see a Mailtips error when sending a new message.

    When I connect to my ECP, browse to recipients, mailboxes, and try to add a new user I see the following in a yellow bar to the right side of any highlighted user:

    Method not found: 'Microsoft.Exchange.VariantConfiguration.IFeature ADSettingsIni.get_DisplayNameMustContainReadableCharacter()'.

    If I click the +, User Mailbox, and browse I get the same error.

    Several commands in Exchange Console give the following error (including trying to add a user in the console)

    VERBOSE: Connecting to EMAIL.SERVER.local.
    VERBOSE: Connected to EMAIL.SERVER.local.
    [PS] C:\Windows\system32>get-mailbox -arbitration
    WARNING: An unexpected error has occurred and a Watson dump is being generated: Method not found:
    'Microsoft.Exchange.VariantConfiguration.IFeature ADSettingsIni.get_DisplayNameMustContainReadableCharacter()'.
    Method not found: 'Microsoft.Exchange.VariantConfiguration.IFeature
    ADSettingsIni.get_DisplayNameMustContainReadableCharacter()'.
        + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], MissingMethodException
        + FullyQualifiedErrorId : System.MissingMethodException,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
        + PSComputerName        : email.SERVER.local

    [PS] C:\Windows\system32>

    Tuesday, December 3, 2019 4:09 AM

All replies

  • Tuesday, December 3, 2019 7:55 AM
  • Do you download the CU23 from official Microsoft website?

    Agree with Udara, please first restart server to test the results.

    Please check if the Status, Identity and .Net CLR Version of the Application Pools are in a correct configuration:

    In IIS, make sure the back-end website has the Exchange self-signed certificate bound to it.

    If possible, in the path "C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess", rename the file SharedWebConfig.config to SharedWebConfig.config.old, then copy the file SharedWebConfig.config from a worked Exchange 2013 CU23 server.

    Please also have a look at Event Viewer when the issue occurs and see if any fault module will be recorded there so that we can do more research.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 4, 2019 4:43 AM
  • Just check how is everything going on with this issue.


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, December 6, 2019 8:19 AM
  • Here I will provide a brief summary of this post for your information.

      

    [Issue Symptom:]

    ====================

    After installing CU 23, cannot add new user. Users see Mailtip error when sending emails. 

    Error: WARNING: An unexpected error has occurred and a Watson dump is being generated: Method not found:
    'Microsoft.Exchange.VariantConfiguration.IFeature

        

    [Troubleshooting Steps so far:]

    ====================

    1. Restart server

    2.  check if the Status, Identity and .Net CLR Version of the Application Pools are in a correct configuration

    3. In IIS, make sure the back-end website has the Exchange self-signed certificate bound to it.

    4.  rename the file SharedWebConfig.config to SharedWebConfig.config.old, then copy the file SharedWebConfig.config from a worked Exchange 2013 CU23 server.

    Monday, December 9, 2019 7:05 AM