locked
Speakers not plugged in RRS feed

  • Question

  • I recently installed Windows 7 RC1, but I haven't been able to get any audio to work. I have tried installing the latest chipset drivers (for on-board sound) and GPU drivers (if that may help). I have also tried installing Realtek AC97 and Realtek HD audio drivers, with no affect. When I go into audio devices it says "Speakers, High Definition Audio Device, Not Plugged In"



    Any Ideas?

    Craig
    Friday, May 8, 2009 5:39 PM

Answers

  • Sorry guys,

    Yes I was able to fix the problem. It was a simple fix I am embarrased to say... In the Realtek HD audio software, I checked disable front panel detection, then audio sprung to life :)

    Thanks Anyways!

    Craig

    • Marked as answer by craig1231 Monday, June 1, 2009 6:13 PM
    Monday, June 1, 2009 6:13 PM

All replies

  • Craig:
    Have you had any luck getting this to work yet?
    -Nick
    Monday, June 1, 2009 3:34 PM
  • I had the identical symptoms you describe as ‘speakers not plugged in’ when I changed my video card from a Nvidia 9600 [using the Realtech on board SPIDF for sound to a Sony Audio/Video Receiver at the SPIDF input jack] to an ATI 4850 [using the ATI High Definition Audio through a DVI  / HDMI cable plugged into a Sony Audio/Video Receiver at the HDMI input jack]. I had wanted to have just one cable [DVI/HDMI] from my Windows 7 Media Center & to eliminate the second SPIDF cable. That would eliminate one cable & decrease the complexity of the setup & user friendliness on the Sony A/V Receiver for my family to get the programming they want with sound (a shortcoming of the inputs on the Sony STR-DG1000 receiver).

     

    What I found out is that the DVI / HDMI cable that I was using didn’t have the Audio conductors {on the DVI end of the cable it was a Dual Link cable which has a lot of pins, but not the audio pins connected thru the cable} – what I needed was a cable that had the audio & video conductors & pins working properly. I found that the ATI 4850 card from Gigabyte did have a DVI/HDMI adapter in the box. I used that adapter & obtained an HDMI 1.3a cable that I plugged into the Sony receiver & it all works just fine. Audio 5.1 Dolby & video together on one cable from my computer to the Sony AV receiver & then on up to a Samsung 46UB-7100 LED LCD display. I’m not sure if 7.1 is supported & even though the Sony receiver supports that format I only have a 5.1 speaker setup at this time. When I restarted my Win 7 RC computer – the ‘speakers not plugged in’ was gone & it reconfigured itself on the reboot to enable the ATI HD Audio as the ‘Default Device’. I hope this helps you & others.

     

    The only special note that I should make is that when I was using the Nvidia 9600 video card & the SPIDF connection inquires to Win 7 RC shows that it was ‘ High Definition Content Protected or HDCP qualified’. Now, using the ATI 4850 via the HDMI connection & having no separate audio cable Win 7 RC reports that the connection is ‘not HDCP qualified’. I’m stumped why the dual cable [DVI to HDMI & SPIDF] is HDCP qualified & the single cable with the dongle [DVI to HDMI] is not HDCP qualified. I can play Blu-Ray movies on this system just fine, so I don’t know if I have just been lucky picking out movies that aren’t HDCP locked or if the report from Win 7 RC is erroneous.  But that is another question for the folks at Microsoft & ATI to sort through before the Public Release is granted to the masses around the end of September.

    Doug

    Monday, June 1, 2009 6:05 PM
  • What kind of motherboard do you have?

    You may not even need to update the Chipset drivers.  In fact, it may even be detrimental with Windows 7.  Windows 7 installation already includes a vast number of chipset drivers for numerous Intel Chipsets that have been out there for several years.

    These audio drivers that you installed:  did they also include the Microsoft UAA HD Audio hotfix?


    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Monday, June 1, 2009 6:10 PM
  • Also, go check the Device Manager and see if the Audio drivers are installed and the device itself is actually working properly.
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Monday, June 1, 2009 6:11 PM
  • Sorry guys,

    Yes I was able to fix the problem. It was a simple fix I am embarrased to say... In the Realtek HD audio software, I checked disable front panel detection, then audio sprung to life :)

    Thanks Anyways!

    Craig

    • Marked as answer by craig1231 Monday, June 1, 2009 6:13 PM
    Monday, June 1, 2009 6:13 PM
  • Are you sure that your speakers are plugged into the correct (green) jack in the back of the system?

    Could there be a short in the speaker wire itself?
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Monday, June 1, 2009 6:13 PM
  • Oh my god I am so glad i found this post I've tried everything under the sun to get my sound working but never would have thought of doing this. As soon as i clicked it my sound sprung to life like you said. Thank you Craig Xxxxxx
    Monday, January 25, 2010 10:31 PM
  • Excuse me I have the same problem and as you said I also checked Realtek HD Audio Manager but this is all m y manager looks like:

     

    http://i173.photobucket.com/albums/w69/edreil143/Untitled-4.jpg

     

    There is no Connector Settings to disable front panel detection.

    I have Realtek AC'97 and R2.45(also tried R2.36,R2.38,R2.42,R2.43,R2.46 but still no good)

    Anyone knows how to solve this?

    Wednesday, April 7, 2010 6:28 AM
  • i have the same problem as you
    Tuesday, April 20, 2010 11:24 PM
  • hey, im sorry to bother! but how do you get into the "disable front panel conection"?? Well, first how do you get into the Realtelk window?? I know I have Realtek installed but i dont know how to get there!! I only went to control panel, sound, and then I wanted to change to Speakers default but i wont let me click on it! so i dont know what to do to get my sound back! Please help me if you resolved yours!! Thanks!
    Wednesday, June 2, 2010 3:51 AM
  • Wow! Thank you so much! I've been having the same problem and have spent so much time on trying to get my sound to work and the whole time I had the green plug one slot over from where it should have been! >.< Thanks!! :D
    Tuesday, November 30, 2010 7:23 AM
  • Kudos to Craig1231!  I had the same problem on a,

     

    • Windows7 Professional N
    • evga Mobo nForce 680i SLI
    • Intel DuoCore processor, 6 GB
    • 8600 GE Force video card

     

    Anyway, such as simple solution solved my problem after I worked on it for three hours or so.  I had a tough time finding the "Disable Front Panel Selection" check box.  I kept looking through the driver switches and it wasn't there.  If the Realtek HD Audio Manager is installed properly it is in the

    Control Panel » Hardware and Sound » Realtek HD Audio Manager

    This is only shown after you install the Realtek drivers.  Upon opening the Audio Manager, there is a yellow folder icon in the top right hand corner.  Click it and it will open the check box selection for disable front panel selection.  As soon as I clicked it and closed the form, the sound fired right up!  :-)  I hope this helps.

     

    John Coffey

     

     

     

    • Proposed as answer by pro-files Monday, July 18, 2011 5:27 PM
    Monday, December 6, 2010 5:16 PM
  • Sorry guys,

    Yes I was able to fix the problem. It was a simple fix I am embarrased to say... In the Realtek HD audio software, I checked disable front panel detection, then audio sprung to life :)

    Thanks Anyways!

    Craig

    please, can you help me can you tell me what to go on?
    Sunday, February 13, 2011 1:39 PM
  • HI Guys,

    I have a same problem with my High definition Audio Controller. My problem is a bit different and that is I have a clicking sound in my Headphone, speaker and Microphone. My Realtek HD audio software cannot detect any thing all. I have done what Craig suggested but I cannot get  rid of the Clicking sound. 

    Computer specs

     


    -------------

    Sound Devices

    -------------

                Description: Realtek Digital Output(Optical) (Realtek High Definition Audio)

     Default Sound Playback: Yes

     Default Voice Playback: No

                Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS_104383C0&REV_1000

            Manufacturer ID: 1

                 Product ID: 100

                       Type: WDM

                Driver Name: RTKVHD64.sys

             Driver Version: 6.00.0001.6037 (English)

          Driver Attributes: Final Retail

                WHQL Logo'd: Yes

              Date and Size: 1/29/2010 14:48:44, 2260256 bytes

                Other Files: 

            Driver Provider: Realtek Semiconductor Corp.

             HW Accel Level: Basic

                  Cap Flags: 0xF1F

        Min/Max Sample Rate: 100, 200000

    Static/Strm HW Mix Bufs: 1, 0

     Static/Strm HW 3D Bufs: 0, 0

                  HW Memory: 0

           Voice Management: No

     EAX(tm) 2.0 Listen/Src: No, No

       I3DL2(tm) Listen/Src: No, No

    Sensaura(tm) ZoomFX(tm): No


                Description: Realtek Digital Output (Realtek High Definition Audio)

     Default Sound Playback: No

     Default Voice Playback: Yes

                Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS_104383C0&REV_1000

            Manufacturer ID: 1

                 Product ID: 100

                       Type: WDM

                Driver Name: RTKVHD64.sys

             Driver Version: 6.00.0001.6037 (English)

          Driver Attributes: Final Retail

                WHQL Logo'd: Yes

              Date and Size: 1/29/2010 14:48:44, 2260256 bytes

                Other Files: 

            Driver Provider: Realtek Semiconductor Corp.

             HW Accel Level: Basic

                  Cap Flags: 0xF1F

        Min/Max Sample Rate: 100, 200000

    Static/Strm HW Mix Bufs: 1, 0

     Static/Strm HW 3D Bufs: 0, 0

                  HW Memory: 0

           Voice Management: No

     EAX(tm) 2.0 Listen/Src: No, No

       I3DL2(tm) Listen/Src: No, No

    Sensaura(tm) ZoomFX(tm): No


    ---------------------

    Sound Capture Devices

    ---------------------

    -------------------

    DirectInput Devices

    -------------------

          Device Name: Mouse

             Attached: 1

        Controller ID: n/a

    Vendor/Product ID: n/a

            FF Driver: n/a


          Device Name: Keyboard

             Attached: 1

        Controller ID: n/a

    Vendor/Product ID: n/a

            FF Driver: n/a


          Device Name: Microsoft Hardware USB Mouse

             Attached: 1

        Controller ID: 0x0

    Vendor/Product ID: 0x045E, 0x009D

            FF Driver: n/a


          Device Name: Microsoft Hardware USB Mouse

             Attached: 1

        Controller ID: 0x0

    Vendor/Product ID: 0x045E, 0x009D

            FF Driver: n/a


          Device Name: Microsoft Hardware USB Mouse

             Attached: 1

        Controller ID: 0x0

    Vendor/Product ID: 0x045E, 0x009D

            FF Driver: n/a


    Poll w/ Interrupt: No


    -----------

    USB Devices

    -----------

    + USB Root Hub

    | Vendor/Product ID: 0x8086, 0x3A36

    | Matching Device ID: usb\root_hub

    | Service: usbhub

    | Driver: usbhub.sys, 7/14/2009 08:07:09, 343040 bytes

    | Driver: usbd.sys, 7/14/2009 08:06:23, 7936 bytes


    ----------------

    Gameport Devices

    ----------------


    ------------

    PS/2 Devices

    ------------

    + Microsoft USB Dual Receiver Wireless Keyboard (IntelliType Pro)

    | Vendor/Product ID: 0x045E, 0x009D

    | Matching Device ID: hid\vid_045e&pid_009d&mi_00

    | Service: kbdhid

    | Driver: kbdhid.sys, 7/14/2009 08:00:20, 33280 bytes

    | Driver: kbdclass.sys, 7/14/2009 09:48:04, 50768 bytes

    + Terminal Server Keyboard Driver

    | Matching Device ID: root\rdp_kbd

    | Upper Filters: kbdclass

    | Service: TermDD

    | Driver: i8042prt.sys, 7/14/2009 07:19:57, 105472 bytes

    | Driver: kbdclass.sys, 7/14/2009 09:48:04, 50768 bytes

    |

     

    Wednesday, March 2, 2011 4:03 PM
  • i have same problem help me too .please

     

    • Proposed as answer by Kap_be Thursday, December 29, 2011 2:02 PM
    • Unproposed as answer by Kap_be Thursday, December 29, 2011 2:03 PM
    Monday, December 26, 2011 11:29 PM
  • As said before first by Craig -> check "Disable Front Panel Selection"

    For those who needs a spoon

    Control Panel » Hardware and Sound » Realtek HD Audio Manager

    In the Realtek HD Audio Manager

    Look at the right top corner, underneath device advanced settings, there is a little yellow folder icon,  click it

    Check the  "Disable Front Panel Selection", you might want to lower the volume first.

    Kudos to Craig

    • Proposed as answer by DMZone Monday, April 30, 2012 9:13 AM
    Thursday, December 29, 2011 2:11 PM
  • didnt work for me

    Monday, June 4, 2012 4:04 AM
  • Me either :)
    Friday, June 15, 2012 10:19 PM
  • What if you don't have a RealTek Audio manager? I have a Dell Studio XPS.

    John Marvin

    Wednesday, November 14, 2012 8:09 PM
  • Almost 5 years later..and this just worked perfect for me after fidgeting with it for 2 hours.

    Thank you 2009!
    Tuesday, April 22, 2014 4:22 AM