locked
SharePoint Proxy loads for all users in terminal services environment RRS feed

  • Question

  • I have sequenced Office 2010 32 bit and I am running it on a Windows 2003 R2 x64 terminal server with Appv 4.6 client for TS with Office 2003 installed locally. I added all proxies and all components of Office. The deployment went well and users in the "Office 2010" group get access to the Office 2010 applications.

    After some use we discovered that users who do not have Office 2010 published and go to our internal SharePoint 2007 site and try to export a list to excel get an error when the .iqv file automatically tries to load in Excel 2010. When they load an .iqv file from the file system it loads in Excel 2003.

    Is there a way to disable/enable the SharePoint Proxy per user?

    Thursday, September 16, 2010 7:54 PM

Answers

  • I was in contact with MS on this before we discovered this issue and they didn't mention anything about not supporting this configuration.

    The good news is that I was able to make this work. By default domain users have permissions to the DLLs in C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler I removed domain users and added permissions for the group which control access to Office 2010. Now users in the group open the SharePoint exports in Office 2010 and members not in the group open in Excel 2003.

    My TAM has arranged for a time with a MS App-V expert on Tuesday.

    • Proposed as answer by znack Sunday, January 2, 2011 7:54 AM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 10:00 PM
    Monday, September 20, 2010 1:10 AM

All replies

  • I've done some more digging into this issue. The SharePoint proxy OWSUPPServer install some IE add-ons and removes some existing add-ons.

    Here are the add-ons for a regular Office 2003 with SharePoint integration services:

     

    Name

    File

    Folder

    SharePoint Export Database Launcher

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office12

    SharePoint  OpenDocuments Class

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office12

    SharePoint OpenDocuments Class

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office12

    SharePoint OpenDocuments Class

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office11

    SharePoint Spreadsheet Launcher

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office11

    SharePoint Spreadsheet Launcher

    OWSCLT.DLL

    C:\PROGRA.’2\MICROS’-’2\Office11

    SharePoint Stssync Handler

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office12

    SharePoint Stssync Handler

    OWSSUPP.Dll

    C:\PROGRA.’2\MICROS’-’2\Office12

     

    Here are the add-ons once the Office deployment toolkit with the OWSUPPServer switch:

     

    Name

    File

    Folder

    ExportDB Class

    OWSSuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

    openDocuments Class

    OWssuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

    SharePoint OpenDocuments

    OWSSuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

    SharePoint Stssync Handler

    OwSSuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

    SpreadsheetLauncher Class

    OWSSuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

    StssyncHandler Class

    OW5SuppFactory.dll

    C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler

     

    I have tried to disable the add-ons and re-install the Office 2003 add-ons but non-AppV users onthe terminal server still get the error:

     

    Application Virtualization Error

    The Application Virtualization Client could not launch Microsoft SharePoint Client Support Manager 14.0.4755.1000.

    You are not authorized to access this resource.

    Error code: 4604EE6-1690640A-20000193

     

    Friday, September 17, 2010 4:47 PM
  • I have now tested this with IE7 and IE8.

    In IE7 I disable the add-ons and the export attempts to load Excel 2010.

    In IE8 I disable the add-ons and the export loads in Excel 2003.

     

    I need to figure out how to properly disable the add-ons in IE7.

    Friday, September 17, 2010 8:56 PM
  • I think that you are in "microsoft unsupported land" when you try to run both a native install version and an app-V different version on the same machine.

     

    Sunday, September 19, 2010 9:23 PM
    Moderator
  • I was in contact with MS on this before we discovered this issue and they didn't mention anything about not supporting this configuration.

    The good news is that I was able to make this work. By default domain users have permissions to the DLLs in C:\Program Files (x86)\Common Files\Microsoft Shared\Virtualization Handler I removed domain users and added permissions for the group which control access to Office 2010. Now users in the group open the SharePoint exports in Office 2010 and members not in the group open in Excel 2003.

    My TAM has arranged for a time with a MS App-V expert on Tuesday.

    • Proposed as answer by znack Sunday, January 2, 2011 7:54 AM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 10:00 PM
    Monday, September 20, 2010 1:10 AM