microsoft virtual wifi miniport adapter code 31 error RRS feed

  • Question

  • Hi.  I have a brand new Dell XPS running 64 bit Windows 7.  Getting an exclamation point on the "microsoft virtual wifi miniport adapter" in device manager.  Details say that the computer can't load the drivers (code 31).  Can't find any newer drivers on the microsoft website.  Tried uninstalling it, per tech support at Dell.  Keeps getting reinstalled, still with exclamation point.  I can disable it, but why can't I use it??  Getting random blue screens of death when trying to install other drivers and/or search for wireless devices.  I've seen others with this exact same problem, but haven't been able to find a solution.  Anyone?  Anyone?
    Wednesday, December 30, 2009 11:56 PM

All replies

  • which Dell XPS do you have?  Do you have Dell's restore disk? If it came with Windows 7 installed, then it'll put it back to factory specs with the correct drivers that have already been tested. What did Dell tech support tell you to do if it continued to be a problem? You should continue to work with them if its a new machine. Eventually they will send out a tech if they can't walk you through to resolving it. Its up to them to fix it (at least until the warranty runs out). ;)  You also mention blue screens, but you don't say diddly as to what the error code is (did you tell dell support about it).  By the way if you don't like their phone support, use the online chat (as long as the system works if you're using that machine now).
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Proposed as answer by caarman Monday, February 14, 2011 7:35 PM
    Thursday, December 31, 2009 2:13 AM
  • I have a Studio XPS 8000, with a wireless card.  There's not much point in restoring to factory settings, as this came with factory settings, as far as I can tell, and I really don't want to start mucking around with that.  Tech didn't tell me anything; she was convinced she had fixed it (or didn't care enough either way).  The blue screens don't stay around long enough for me to read an error code; they flash up for 5 seconds or less, show a long string of letters or numbers that there's no hope of writing down before the computer shuts down on its own.  Yes, I did tell Dell about it, and yes, I did try online chat.  Waited on hold for over an hour, waited on chat for 5-10 minutes between each line typed by the tech, overall over 1.5 hours on with him, and accomplished nothing other than him downloading debugging software and other junk onto my computer which solved nothing other than to eat up my whole night.  Ultimately, he had me do a hardware test, which came up clean.  His suppositon was that if the hardware was ok, it must be software.  Pardon me, but I think it was already pretty clear it was softare.  He had no clue.  None. So, back to doing online chat AGAIN.

    BUT, this is a problem I've seen elsewhere on these boards, with different brand and configurations of computers.  So far, there has been no correction (other than the suggestion to disable it).  Somewhere out there, there must be a Microsoft techie who finds this mildly interesting enough to devote a few lines of code to..  Hoping...
    Thursday, December 31, 2009 6:52 PM
  • Hi,


    Regarding the “microsoft virtual wifi miniport adapter” issue, I would like to suggest the following:


    1.    If there is a new version of the wireless NIC driver from Dell, please update it.


    2.    Disable the wireless Hosted Network with the following command in an elevated command prompt:


    netsh wlan set hostednetwork mode=disallow


    Then, please check if it works and how about the blue screen issue.



    Nicholas Li - MSFT
    Monday, January 4, 2010 7:57 AM
  • Nicholas, there isn't a new driver.  If I disable the wireless hosted network, what are the consequences for my ability to use my wireless network?  What is your reasoning behind saying to disable it?

    Monday, January 4, 2010 11:03 PM
  • Hi,


    The “microsoft virtual wifi miniport adapter” is related to a new feature in Windows 7, Wireless Hosted Network:


    About the Wireless Hosted Network


    This device is just a virtual device and it should not affect connecting the wireless network with the physical wireless adapter .


    From the following, we can see whether this function works also depends on its driver.


    “The driver for the wireless adapter must implement the wireless LAN device driver model defined by Microsoft for use on Windows 7. To receive the Windows 7 logo, a wireless driver must implement the wireless Hosted Network feature.”


    Therefore, an updated driver which is designed for Windows 7 may fix this error. You can contact DELL for this or check it in Windows Update. If there is still no new driver available, disabling Wireless Hosted Network is a workaround.  



    Nicholas Li - MSFT
    Tuesday, January 5, 2010 5:31 AM
  • Having same problem with my brand new Sony Vaio laptop - vpccw13fx. It came with Windows 7 pre-installed. This error just pops up and a blue screen comes up. The error is as stated in the head line. First, the pop up window adviced to go to the HP website. Why? I didn't quite undertand why it tried to send me to their website. Anyway, I looked at the devices and the microsoft virtual mini port has a question mark. So, I tried to update the virtual mini port driver. It didn't work out. It is frustrating. A new laptop and this crazy problem. It just freezes and brings up a blue screen. Why do we have to find solutions? Cut it out from Windows 7 if it doesn't work. Or give us a solution! Thanks! Hope you understand our frustrations.  
    Tuesday, January 5, 2010 7:11 PM
  • I have just checked other network adapters for drivers and they are all up to date. This one just gives this message when going to the properties - 'This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)'
    Tuesday, January 5, 2010 7:18 PM
  • dmru, please start a new thread so you don't prevent megan2010 to get their answer on their problem since your needs may not be exactly the same.

    megan2010 when did you get this Dell Laptop? Can you verify what the driver version is on your machine isBroadcom BCM57780 LOM  - wired NIC
    Release Date: 9/8/2009
    Version:, A00

    Dell Wireless 365 Bluetooth Module
    Release Date: 12/2/2009
    Version:, A03-1

    Dell Wireless 1505 Draft 802.11n WLAN Mini-Card Desktops
    Release Date: 9/29/2009
    Version:, A01
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, January 5, 2010 8:22 PM
  • I got the desktop about a week ago.  Driver for the 1525 WLAN PCIe card I have installed is from Atheros Communications, Inc, 6/5/2009, version with Digital signer "Microsoft Windows Hardware Compatibility Publisher".  The update driver search function says this is the most up to date driver.  I don't have Bluetooth.  
    NOTE: I don't see anything on my device manager for a "wired NIC".  Is there another term for it?  I do have "Broadcom NetLink (TM) Gigabit Ethernet" with driver version (6/20/2009).  Again, the driver search said it was up to date...

    NOTE: I tried to install the 1505 driver (9/29/2009), even though I have the 1525, and got the error message "no compatible hardware found.  The software you are attempting to install is not supported on this system.  The software will not be installed.  Setup will now exit."

    So, what should I do?

    Tuesday, January 5, 2010 11:40 PM
  • Hi,


    Thank you for your update.


    Based on the current situation, since the driver for the wireless NIC failed to install with the message “no compatible hardware found”, I suspect this should be a hardware problem. Therefore, please try the following methods:


    1.    Ensure that the wireless NIC is enabled. If there is a physical switch for it on the computer, please also ensure it is on.


    2.    If the issue persists, it is still recommended that you contact DELL to check the device and ensure it is OK.



    Nicholas Li - MSFT
    Wednesday, January 6, 2010 5:04 AM
  • megan2010, I agree with Nicholas, if this machine is a week old, then by all means get Dell involved as it could very well be a motherboard issue as I had to get them to replace 2 of 10 new machines that failed to work properly out of the box (before I deployed it to an end user), next day they were fixed and I could proceed with migration. Sometimes it just happens. Let us know how it turns out.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, January 6, 2010 5:12 AM
  • They did already replace the motherboard in a throw the baby out with the bathwater attempt to get rid of whatever might be wrong.  I have never seen anything on this computer related to NIC, though, so I will follow up with them on that.  Could you tell me where I would locate it software-wise?
    Wednesday, January 6, 2010 8:19 PM
  • NIC is just for Network Interface Card (sorry if I confused you - its the Broadcom I had associated it with as the wired nic if you use it)

    Windows 7 64bit drivers for your unit is here
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, January 6, 2010 9:00 PM
  • hello my name is mike if you are still having this problem email me at i will reply asap i like to help people with there problems and think i have an easy way around yours
    Sunday, January 10, 2010 5:52 AM
  • Hi megan2010,

    I think I have the same problem you have or had! I have a new Studio XPS 8100 desktop. It also has a problem with the Microsoft virtual wifi miniport adapter driver ( code 31) error. Did you find any resolution to your problem?

    Monday, May 3, 2010 12:04 PM
  •  I recently purchased  a new Studio XPS 8100 desktop and it also has a problem with the Microsoft virtual wifi miniport adapter driver ( code 31) error.
    Monday, May 31, 2010 3:41 AM
  • I'm hoping to clarify some of the posts I've read linking the virtual adaptor to the internet.  From what I've found, this adaptor has nothing to do with getting on the internet.  What it does have to do with is being able to use wifi devices such as a printer.  I have the same problem with this error code 31 saying windows cannot load the driver because there is a problem with the windows virtual wifi miniport adaptor.  I don't even have a clue if this adaptor is software or hardware.  I'm going to have my turn with Dell tomorrow and hopefully I can get this resolved.  Seems like when you do the chat with them, they always tell you it's a software problem and the foreigner you chat with tells you that software isn't covered by the warranty, only hardware.  He then goes on to giving you a support number at Dell that is fee based.  To me, that is BS.  My computer isn't even six months old and I'm expected to pay to have the problem resolved. 
    Sunday, July 11, 2010 10:20 PM
  • Firsly, my english aren't good, the pragrapy may include grammar errors or more.

    i belive it can be solved by doing these ways:

    If you installed the miniport driver without referance other driver it will not find the IRQL that the device need... If you install the driver directly sometimes windows don't find the IRQL and Unknown device still stay here and driver cannot comminucate the device without set any register to irql number before call bios int.(functions).

    I always get this error when i install a driver without updating Unknown Device driver (the driver which has ? icon)

    Uninstall the driver after restart your computer(you may don't need that).. right Click and select update driver on "Unknown Device" or "Network Device" which has ? icon. Click update driver and select "select driver manually", after select network adapters and select microsoft virtual wifi miniport adapter then install it. The problem is should (i belive %100) solved now!.

    Best Regards,
    Burak TAMTÜRK

    • Proposed as answer by BurakTAMTURK Monday, July 12, 2010 12:40 PM
    Monday, July 12, 2010 12:40 PM
  • Please do the following to see if your issue persists. Open Device Manager, under Network Adapters right click on the Microsoft Vitural WiFi Miniport Adapter, and choose Disable.
    • Proposed as answer by Peter Mcain Thursday, July 15, 2010 11:12 AM
    Wednesday, July 14, 2010 10:03 PM
  • I have exactly the same problem as megan except i have gateway NV52 series notebook.   I have tried to update the driver and it responds stating it is already updated!  It still shows an exclamation point in the device manager,  I guess I will ttry deleting driver all together and then reload. I will get back to yopu!
    Thursday, October 7, 2010 5:12 AM
  • I went into windows and deleted the wi-fi driver (vwifimp.sys) \windows\system32\drivers and replaced it with a new copy !  I have no exclamation point any longer.  Fortunated I had a good copy of the driver in a different location, so if you do not I am not sure but possible extracting it off your original windows 7 disk.

    Thursday, October 7, 2010 5:49 AM
  • What should I download on this site.  Sorry I am wish I knew more without having to ask such a question.  I have the same problem as above conversation.
    Tuesday, January 25, 2011 7:25 PM
  • I have spoke to Sony regarding this adapter and they have suggested either:-

    1) Recover the whole system back to factory settings by typing in the search box on start button the word 'RECOVERY' and then click on the VAIO Recovery Center. This will give you the option to back up any files you want to keep before then clicking on Recover Complete System.

    This resolved the issue for me.


    2) Other than the above you can download the driver again at and type in your serial number from the bottom of the lap top which is generally the one near the barcode which is in 2 parts.

    Then choose the last driver in the list under drivers.

    Goodluck Kev

    Thursday, February 3, 2011 4:42 PM