Please set registry key - HKLM\Software\Microsoft\.NETFramework\InstallRoot to point to the .NET Framework install location


  • As topic above. 

    Everytime I try to run Microsoft Fix It. This error message appear.

    Actually, what is the root of this problem emerged ?  

    And how to solve this problem ?
    Friday, November 1, 2013 1:35 AM

All replies

  • Actually I dont really understand the step.

    Is there any other choice of step may I take ?

    Friday, November 1, 2013 4:15 AM
  • Dont know if this is a common issue, but some guy with a SQL Server solved it and if you enter the error, you end up here quite fast.

    The install root path needs to be created at another subfolder. You can do this by just creating a new .reg file.

    1.Create an empty .txt file (for example on the desktop)

    2.Paste the following code:

    Windows Registry Editor Version 5.00

    3.Rename the file to "fix.reg"

    4.Run the file and restart the pc. Done.

    • Edited by Cort Andrus Wednesday, September 21, 2016 9:39 AM
    Wednesday, September 21, 2016 9:38 AM
  • Cort Andrus,     Thank you so much for this solution.   You see,  I use .NET Framework to run something very important on my PC, and it's called Blue Stacks version 2, and this weekend I received a bad error that needed this special fix to fix the registry problem.   Thank you so much for helping with this special registry command.  I appreciate it.  

    Adam E. 


    Saturday, May 6, 2017 10:12 PM
  • That page no longer exists, please update.


    Monday, June 4, 2018 8:47 PM
  • Hello, I would like to know how I do this if you could be more specific because I have the same problem and I know almost nothing
    • Edited by lanzetti Thursday, June 21, 2018 2:27 PM
    Thursday, June 21, 2018 2:27 PM
  • I have this same issue.

    .Net Install?  
    I have many! One of each.  One for all.

    I get the "Please set registry key HKLM\Software\Microsoft\>netFramework\InstallRoot to point to the .NET Framework install location." error whenever I try and run software on the CD's that hospitals send to each other with DICOM (Radio-graphic) studies on them. Doesn't matter the program- its a .NET program.

    The Registry key referenced, its correct

    ALSO, the one NOT mentioned- is also correct: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\InstallRoot = C:\Windows\Microsoft.NET\Framework\

    HKLM\Software\Microsoft\>netFramework\InstallRoot= C:\Windows\Microsoft.NET\Framework64\

    I see many people with this problem.  No one with solutions.  

    I have the following .NET assemblies: v1, v2.0.50727, v3.0 v4.0.30319 v3.5, v4.5, v4.5.25000, v4.7.2 and others.  I have Visual Studio, and the Windows SDK installed which come with some too, including the SDK versions (and may be  a source of the problem, since people without Visual Studio in my office --aka everyone else- have no issues"

    • Edited by A Timmons MD Thursday, September 20, 2018 12:36 AM
    • Proposed as answer by Cristi Sava Wednesday, February 27, 2019 7:11 AM
    • Unproposed as answer by Cristi Sava Wednesday, February 27, 2019 7:11 AM
    Thursday, September 20, 2018 12:35 AM
  • I'm having the same problem with a CD from Kaiser Hospital and unable to open view.exe  tks rob 

    Please set registry key HKLM\Software\Microsoft\>netFramework\InstallRoot to point to the .NET Framework install location

    Monday, October 22, 2018 8:00 PM
  • Hello, the fastest solution that worked for me (I din't have the time nor the knowledge to look for more permanent or difficult solutions) was to download the DICOM viewer from here: and then copy the files on the CD in my PC and extract in the respective folder the .exe file that I had previously downloaded. I was able to see the files. I transferred them on a USB stick and hope the doctor could see them too.
    • Proposed as answer by larella.cas Sunday, March 10, 2019 12:29 AM
    Wednesday, February 27, 2019 7:14 AM
  • Good answer , however I found that the page today is  with SP13 instead of SP3

    • Edited by larella.cas Sunday, March 10, 2019 12:32 AM
    Sunday, March 10, 2019 12:31 AM