none
MDT 2010 Update 1, Windows 7 SP1 Enterprise, language pack error

    Question

  • I just added Windows 7 SP1 Enterprise x64 to MDT, I'm starting fresh. The OS, Office 2010 installs as it should, but errors out with:

    <![LOG[Add package "{199aa6a2-3080-4204-bee2-25b3b3183665}"]LOG]!><time="12:12:29.000+000" date="02-17-2011" component="ZTIPatches" context="" type="1" thread="" file="ZTIPatches">
    <![LOG[ The package (patch) GUID "{199aa6a2-3080-4204-bee2-25b3b3183665}" does not exist.]LOG]!><time="12:12:29.000+000" date="02-17-2011" component="ZTIPatches" context="" type="3" thread="" file="ZTIPatches">

    I have the package under packages with that exact GUID and it's also added to CustomSettings.ini as LanguagePacks001="{199aa6a2-3080-4204-bee2-25b3b3183665}"

    Am I forgetting something (should I add it somewhere else as well), why am I getting this error?

    Please let me know if additional information, logs are required.

    Thursday, February 17, 2011 12:42 PM

Answers

  • Apparently, my method doesn't work but you can try by changing line 1101 to :

            LPQuery = "PackageType = 'LanguagePack' and (ProductName = 'Microsoft-Windows-Client-LanguagePack-Package'  or ProductName = 'Microsoft-Windows-Client-Refresh-LanguagePack-Package') and  substring(ProductVersion,1,7) = '" & left(ImgBuild,7) & "' and substring(ProductVersion,5,4) >= '" & mid(ImgBuild,5,4) & "'"

    Friday, February 18, 2011 5:16 PM

All replies

  • The quotation marks in CustomSettings.ini were the problem, I removed them and all is well (not sure why this previously wasn't an issue).
    • Marked as answer by CypherMike Thursday, February 17, 2011 2:46 PM
    • Unmarked as answer by CypherMike Friday, February 18, 2011 9:08 AM
    Thursday, February 17, 2011 2:45 PM
  • I spoke too soon. I don't get any errors if I remove the quotation marks, but the language pack doesn't install. Any assistance is appreciated.
    Friday, February 18, 2011 9:10 AM
  • Hello,

     

    I think there is an issue with MDT and SP1 Language pack.

    When you impot the LP in MDT, the ProductName is Microsoft-Windows-Client-Refresh- LanguagePack-Package instead of Microsoft-Windows-Client-LanguagePack-Package in RTM. So when the wizard (or mdt) try to display the LP it finds nothing because there is no Microsoft-Windows-Client-LanguagePack-Package.

     

    One quirk way to make it work is to manually modify the Packages.xml file to modify the productname of your LP to Microsoft-Windows-Client-LanguagePack-Package (remove the Refresh-). Thus they correctly appear in the wizard.

    You can also modify the MDT scripts to search LP with Refresh-.

    I think we need to wait an update of MDT.

    Have fun ! :)

    Friday, February 18, 2011 2:42 PM
  • Apparently, my method doesn't work but you can try by changing line 1101 to :

            LPQuery = "PackageType = 'LanguagePack' and (ProductName = 'Microsoft-Windows-Client-LanguagePack-Package'  or ProductName = 'Microsoft-Windows-Client-Refresh-LanguagePack-Package') and  substring(ProductVersion,1,7) = '" & left(ImgBuild,7) & "' and substring(ProductVersion,5,4) >= '" & mid(ImgBuild,5,4) & "'"

    Friday, February 18, 2011 5:16 PM
  • I sucessfully deployed SP1 LP with that trick ;)
    Friday, February 18, 2011 6:20 PM
  • I just noticed I'm using the pre-SP1 language pack, which apparently isn't supported. VLSC doesn't offer the language pack I want to install, only the major ones (English, French, German, Japanese, Spanish) so I guess I'll have to wait, although I'm not sure for how long.
    Friday, February 18, 2011 7:51 PM
  • Hello,

    Can you tell me wich file you changed ? we have the problem too.

    Thanks

    Marc.

     

    Tuesday, February 22, 2011 7:49 AM
  • SombreSire,

    The ...\DeploymentShare\Control\Packages.xml file. The "ProductName" field is needed to be changed for appropriate package as I have understood.

    Tuesday, February 22, 2011 10:54 AM
  • Olegrik,
    Yes I know, but now with the change, I can select the language but during the installation, it fails with a message 'Windows could not apply unattend settings during pass [offlineServicing]'.

    If I launch again the installation of Win 7 SP1 but with no additional languages it works.

    Marc.

     

    Tuesday, February 22, 2011 1:47 PM
  • This worked great.   As a side note,   I do not know if it was mentioend,  but the line of code needs to be changed in DeployWiz_Initialization.vbs

    I really appreciate this one.  
    Thanks

    Tuesday, February 22, 2011 8:57 PM
  • Thank you very much! Correcting DeployWiz_Initialization.vbs file has helped me! Without editing Packages.xml file.
    Wednesday, February 23, 2011 6:48 AM
  • Oups you're right :D I missed the file name to edit.

     

    The script is looking for Microsoft-Windows-Client-LanguagePack-Package and not Microsoft-Windows-Client-Refresh-LanguagePack-Package

    I was thinking that just edit the package name was sufficient but I forgot it was used in the unattend update process to deploy the language pack as a package during setup.

     

    So I ended up editing the xpaph query looking for the LP instead of modifying the package name and it's correctly working.

     

    I'm deploying x86 and x64 LP on Win 7 SP1 :)

    Saturday, February 26, 2011 6:06 PM
  • That looks like the fix.

    FYI: We are working with the Windows Product Group team to come up with long term solution. 

     


    Keith Garner (KeithGa.com) - Deployment Consultant - http://deployment.XtremeConsulting.com
    Tuesday, March 1, 2011 6:56 AM
    Moderator
  • I am a bit confused as to which line needs to be modified.

    Can someone please upload the correcrted  DeployWiz_Initialization.vbs file with the corrected lines to fix this.

    Thanks in advance.

    Sunday, March 6, 2011 8:19 AM
  • Hello Gandalf50,

    You have to go in the Scripts folder in your Deployment share and look for the file called DployWiz_Initialization.vbs

    Open this file and go to the line 1101.
    This line is :

    LPQuery = "PackageType = 'LanguagePack' and ProductName = 'Microsoft-Windows-Client-LanguagePack-Package' and substring(ProductVersion,1,7) = '" & left(ImgBuild,7) & "' and substring(ProductVersion,5,4) >= '" & mid(ImgBuild,5,4) & "'"

     

     You have to replace it with : 

    LPQuery = "PackageType = 'LanguagePack' and (ProductName = 'Microsoft-Windows-Client-LanguagePack-Package' or ProductName = 'Microsoft-Windows-Client-Refresh-LanguagePack-Package') and substring(ProductVersion,1,7) = '" & left(ImgBuild,7) & "' and substring(ProductVersion,5,4) >= '" & mid(ImgBuild,5,4) & "'"

    I hope this will help you.

    Marc.

    Monday, March 7, 2011 5:51 AM
  • Hallo

    I have the Problem also, but replacing that LPQuery Line doesn´t do anything for me. I still get a VBScript RunTime Error in the Wizard where the Language Selection usually appears. Can anybody help me here ?

    Thursday, March 10, 2011 3:37 PM
  • Hi,

     

    Okey the change in the DployWiz_Initialization.vbs works in the way that you can install LP SP1. But the MDT deployment ends with other strange DB/CS.ini error, and works fine with Windows 7 RTM.

    /SaiTech

     

    Sunday, March 13, 2011 7:33 PM
  • This seems to have fixed the problem for me, as I did not get a choice of available language packs to install when running the wizard and now I do. Now I'm awaiting if the installation succeeds :)
    Wednesday, April 6, 2011 7:21 AM
  • For anyone else who reaches this post from a search engine (like I did,) Microsoft published an official KB article on this that shows the exact script changes you need to make:

    "SP1 Language Packs do not show up or get installed in Microsoft Deployment Toolkit 2010 Update 1 Task Sequence": http://support.microsoft.com/kb/2547191

    They just add an additional term to the search expression to allow for the new language pack names.

    • Proposed as answer by EricTorbenson Wednesday, October 19, 2011 7:44 PM
    Wednesday, October 19, 2011 7:39 PM