locked
Getting error when I try to use the Scan Button RRS feed

  • Question

  •  

    I keep getting the following error when I click on the Scan Now button:

     

    "Could not start the scan for all managed computers. Retrieving the COM class factory for remote component with CLSID xxxxxxx from machine <servername> failed due to the following error: 80040154"

     

    Please help.

     

    Thank you,

     

    Stuart Clark

    Systems Analyst

    CA Integrated Waste Management Board

    sclark@ciwmb.ca.gov 

    Wednesday, October 3, 2007 10:37 PM

All replies

  •  

    Hello Stuart,

     

     

    Error 0x80040154 is "Class not registered".  Architecturally, the FCS console calls into the MOM API to invoke the OnDemand scan of client machines.  These MOM APIs are implemented as COM components.

     

    Can you open the MOM Administration and Operators console on that Management server?

    Do you have the registry key: HKEY_CLASSES_ROOT\CLSID\{8FB7B313-C81A-11D2-8D40-0090270D2552} ?

     

     

    Thanks,

    Craig

    Thursday, October 4, 2007 4:21 PM
  • No, I do not see that key in my registry.

     

    Please help.

     

    Thank you.

     

    Stuart Clark

    Systems Analyst

    CA Integrated Waste Management Board

    916.341.6159

    sclark@ciwmb.ca.gov

     

     

     

    Tuesday, October 9, 2007 2:29 PM
  • Also, yes; I am able to access the MOM Administrator and Operator consoles...

     

    Thanks again,

     

    Stuart

     

    Tuesday, October 9, 2007 3:49 PM
  • Do I need to add that in my registry?

     

    If so, how do I do that? What do I add it as?

     

    Please help,

     

    Stuart

     

    Thursday, October 11, 2007 3:13 PM
  • I too am having the same issue.

    I can open the ops mgr console fine

    I also have the reg file in the registry

    Thanks

    Norm
    Wednesday, October 22, 2008 2:35 PM
  • Hi,

    Are there any errors in the eventlog?

    can you post back with the errors it might be helpful.

    /johan
    Forefront MVP, MCSE | www.msforefront.com
    Wednesday, October 22, 2008 6:44 PM
  • I had the exact same error:

    Microsoft.EnterpriseManagement.Mom.MomSdkException: Execution against the runtime failed. See inner exception for more details. ---> System.Runtime.InteropServices.COMException (0x80080005): Retrieving the COM class factory for remote component with CLSID {8FB7B313-C81A-11D2-8D40-0090270D2552} from machine PARFCS01 failed due to the following error: 80080005.

    The setup bombs out.

    I got it to work by doing the following:

    Ensuring that the Service accounts that I use for the install meet the requirements of the software (2 server install), so they needed to be a local admin on the server that I ran the install on and a domain user.  I also had them in a service account group which denied them local logon rights.  I had to remove that restriction and it all worked fine.

    Unfortunately the install didn't clean up and would bomb out again at step 1 unless you clean it yourself.

    So keep the setup window open, make the account settings above. 
    Uninstall MOM
    Uninstall Forefront Security
    Manually delete the DB installed (OnePoint) from inside SQL

    Then go back one step on the install and try it again.  It completed successfully.

    Good Luck

    Brandon
    Friday, October 24, 2008 5:24 PM