locked
Chrome browser appending the underscore and dash to the actual filename while downloading pictures form sharepoint RRS feed

  • Question

  • We are not really sure why it is that Chrome appending the underscore and dash to the actual filename when we are downloading pictures from sharepoint site.It appears to be a browser related issue..any suggestions?
    • Edited by Mike Walsh FIN Wednesday, February 16, 2011 8:01 PM Do not try to attract people to your post with unnecessary trailing ... in the Title. And do NOT post messages in blue.
    Wednesday, February 16, 2011 5:02 PM

Answers

  • Hi,

    Thanks to share your post.

    For the issue, it should be the Chrome browser’s problem. You should write a function using Code Igniter:

    function force_download_picture($filename, $data) {

    header("Cache-Control: public");
    header("Content-Description: File Transfer");
    header('Expires: 0');
    header('Pragma: no-cache');
    header("Content-Disposition: attachment; filename=$filename");
    header("Content-Type: picture");
    header("Content-Transfer-Encoding: binary");

    echo $data;

    exit();

    }

    If this doesn’t work, you may install the Chrome patch: http://code.google.com/p/chromium/issues/detail?id=1503.

    Or you can go to the Chrome support center for help:

    http://www.chromeboard.com/newthread.php?do=newthread&f=4.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Friday, February 25, 2011 1:40 AM
    Tuesday, February 22, 2011 9:53 AM