none
Cannot use png packages in MRO 3.3.2 RRS feed

  • Question

  • Actually, my question is exactly the same as the question

    https://social.technet.microsoft.com/Forums/lync/en-US/8021f4de-8a2d-427b-a463-778a495c00d3/microsoft-r-open-332-on-centos7package-png-not-working-unable-to-initialize-libpng?forum=ropen

    I installed MRO 3.3.2 under CentOS7 with the command './install.sh' and installed libpng using yum.

    I tried to use png package, but it is not working with the message


    > library(png)
    > readPNG(system.file("img", "Rlogo.png", package="png"))
    Error in readPNG(system.file("img", "Rlogo.png", package = "png")) :
      unable to initialize libpng
    In addition: Warning message:
    In readPNG(system.file("img", "Rlogo.png", package = "png")) :
      libpng warning: Application built with libpng-1.5.13 but running with 1.6.23

    Is there any way to fix the problem?

    Thanx




    • Edited by vicent88 Wednesday, February 13, 2019 1:41 AM
    Wednesday, February 13, 2019 12:19 AM

All replies

  • What if you install that specific version of libpng (1.5.13)?
    Wednesday, February 13, 2019 6:55 PM
    Owner
  • I installed libpng via yum command. The version was 1.5.13.

    I installed 1.6 version of libpng but it didn't work and showed the same error message

    Thursday, February 21, 2019 12:38 AM
  • What specific version of CentOS 7 are you running, e.g. what does '%cat /etc/redhat-release' return? 


    Thursday, February 21, 2019 4:47 PM
  • The specific version is 7.5.1804

    The command returns `CentOS Linux release 7.5.1804 (Core)`

    Monday, February 25, 2019 12:08 AM