locked
How to remove"document" from library New menu? RRS feed

  • Question

  • I created a new Content Type based on the Document Content Type for use in a library.  I have a template that is the default template for this content type.  How do I remove the "document" choice from the "new" library menu, so that only my template displays as an option?
    There are no mistakes; every result tells you something of value about what you're are trying to accomplish.
    Tuesday, May 3, 2011 9:52 PM

Answers

  • If you want to show your custom document content type as default in new menu, then simply delete unwanted default "Document" content type from document library settings and keep your custom type there.
    w: http://www.worldofsharepoint.com | t: @sharesandip
    • Marked as answer by run4it Monday, May 9, 2011 7:30 PM
    Friday, May 6, 2011 6:35 AM

All replies

  • Hi run4it,

    From your description, you just want to display your own template by default instead of the “Document”. If it was, you can try the follow these steps:

    1. Navigate to the library which  you want to change the “Document” to your own template, click Settings>Document Library Settings.
    2. Click “Advanced settings” in General Settings, then enable the “Allow management of content types” option in the  Content Types section, then click OK.
    3. Click the link “Document” In the  “Content Type” section, then click “Advanced settings” in the setting for the Document content type, you can upload your own template, click OK.

    At last, return to your library, and you will find your own template should be displayed by default in “New” menu.

    Regards,
    Daniel


    Thursday, May 5, 2011 3:17 AM
    Moderator
  • If you want to show your custom document content type as default in new menu, then simply delete unwanted default "Document" content type from document library settings and keep your custom type there.
    w: http://www.worldofsharepoint.com | t: @sharesandip
    • Marked as answer by run4it Monday, May 9, 2011 7:30 PM
    Friday, May 6, 2011 6:35 AM