none
How to move User account with Exchange mailbox to different Organizational Unit RRS feed

  • Question

  • Hello everybody, 

    I need to move a User account with an Exchange mailbox between Organizationl Units. In the past, when I've done this on Active Directory, just by dragging the User object between OUs, an issue occurs later in Exchange where the user cannot be found because the User object is no longer in the OU it was in before. So my question is, how do I move a User account to another OU without running into this issue in Exchange. As a little background info, I'm running Exchange 2007 SP3. 

    Thanks for any help you can provide!

    Tuesday, June 18, 2013 3:31 PM

Answers

All replies

  • Hi,

    You can still move the account in Active Directory Users and Computers to the desired OU


    Regards from ExchangeOnline | Windows Administrator's Area

    Tuesday, June 18, 2013 4:30 PM

  • Thanks for your reply, but the last time I moved an account to another OU in Active Directory, I ran into the aforementioned issue in Exchange. When I tried to open the mailbox properties for that user on the Exchange Management Console, an error message popped up saying the User object could not be found. Behind the error message, I could see on the Properties window that the mailbox was still pointing to the OU that the user was previously on. I want to know what is the proper way of moving a user with an Exchange mailbox to another OU so I don't run into this issue.  

    Tuesday, June 18, 2013 4:39 PM
  • Hi,

    I assume the error shows as a replication issue. Check for the related errors in event viewer also. Moving the user between OU can be handled through ADUC and is a proper way.


    Regards from ExchangeOnline | Windows Administrator's Area

    Tuesday, June 18, 2013 4:50 PM
  • Thanks for pointing that out. I will create a test account and mailbox and look for any errors in Event Viewer. In the case, that it is not an actual replication issue, just a late replication of Active Directory to Exchange, would it be ok to assume that if I wait a certain amount of time, for the AD changes to get replicated to Exchange, the error message I was getting before would go away?
    Tuesday, June 18, 2013 4:55 PM
  • Latency is not a big issue but check for any real issues in replicating

    Regards from ExchangeOnline | Windows Administrator's Area

    Tuesday, June 18, 2013 5:08 PM
  • Well, it seems weird that there would be replication issues as I can add new users to Exchange as soon as I've created a user on ADUC. But I will let you know what I find out once I have tested moving an account on ADUC. 
    Tuesday, June 18, 2013 5:23 PM
  • This powershell command is all you need.

    get-mailboxdatabase |clean-mailboxdatabase

    Wednesday, June 26, 2019 9:40 AM