none
Access is denied. Check that the Default Content Access Account has access to this content, or add a crawl rule to crawl this content. (0x80041205) RRS feed

  • Question

  • Hey guys,

    The search feature on my site was working fine until a few days ago I noticed the search was not returning any results.

    There are some entries in the event log, which actually match the crawl log in sharepoint:

    The start address <http://viops.net> cannot be crawled.

    Context: Application 'SharedServicesVIOPS', Catalog 'Portal_Content'

    Details:
        Access is denied. Check that the Default Content Access Account has access to this content, or add a crawl rule to crawl this content.   (0x80041205)



    This is what I have done so far:

    I stopped and restarted the "Office SharePoint Server Search" service,

    I changed the account under which this service runs to the built-in administrator account using the "Edit Shared Services Provider" page.

    Since the service is using the built in administrator account, it has access to the SQL Server DB, even the old account had access to the db.

    Finally I changed the default content access account to the administrator account.

    I saw I related post saying that this type of error can be caused when using Basic Authentication and it suggested to change the authentication in the page: Application Management -> Authentication Providers -> Edit Authentication. However I'm using Integrated Windows Authentication, which is the setting that is being used.


    Does anybody have an idea of what could be causing this problem?

    Thanks











    IT Engineer
    Friday, October 10, 2008 3:01 PM

Answers

  • Hey guys,

    I fixed it, this is what I did:

    1.- Since I was using custom host headers for the web sites, I disabled the loopback check (security feature that is designed to help prevent reflection attacks on your computer, included in the Microsoft Windows XP Service Pack 2 or Microsoft Windows Server 2003 Service Pack 1) by following this article (method 1 worked for me):

    You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or IIS 6
    http://support.microsoft.com/kb/896861

    Method 1: Disable the loopback check

    1.    Click Start, click Run, type regedit, and then click OK.
    2.    In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3.    Right-click Lsa, point to New, and then click DWORD Value.
    4.    Type DisableLoopbackCheck, and then press ENTER.
    5.    Right-click DisableLoopbackCheck, and then click Modify.
    6.    In the Value data box, type 1, and then click OK.
    7.    Quit Registry Editor, and then restart your computer.

    2.- After I restarted the server I went to the Sharepoint Admin site and started a full crawl. Some seconds later I went to the crawl log and found a warning this time with the following entry:
    Content for this URL is excluded by the server because a no-index attribute.

    So I "Reset All Crawled Content" and tried the full crawl again. This time it worked.

    I hope this helps some one else.



    IT Engineer
    • Marked as answer by ureyes84 Tuesday, October 14, 2008 4:08 PM
    • Edited by ureyes84 Tuesday, October 14, 2008 4:10 PM
    Tuesday, October 14, 2008 4:08 PM

All replies

  • An easy way to tell if your account has the correct permissions etc is to log into the box that actually does the crawling and start IE, but use the runas command, then use the account and password that you have setup as your content access account, then you will be able to see what would be returned to the crawler.
    I guess you've made sure that the account hasn't expired or anything simple like that?

    .NET Developer, Brisbane, Australia, http://httpcode.com
    Friday, October 10, 2008 11:20 PM
  • Hey Daniel, Thanks for your post

    I tested the account and I was able to log in, use Internet explorer and navigate through all the site.

    Any ideas?

    Thanks !

    IT Engineer
    Tuesday, October 14, 2008 2:55 PM
  • Hey guys,

    I fixed it, this is what I did:

    1.- Since I was using custom host headers for the web sites, I disabled the loopback check (security feature that is designed to help prevent reflection attacks on your computer, included in the Microsoft Windows XP Service Pack 2 or Microsoft Windows Server 2003 Service Pack 1) by following this article (method 1 worked for me):

    You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or IIS 6
    http://support.microsoft.com/kb/896861

    Method 1: Disable the loopback check

    1.    Click Start, click Run, type regedit, and then click OK.
    2.    In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3.    Right-click Lsa, point to New, and then click DWORD Value.
    4.    Type DisableLoopbackCheck, and then press ENTER.
    5.    Right-click DisableLoopbackCheck, and then click Modify.
    6.    In the Value data box, type 1, and then click OK.
    7.    Quit Registry Editor, and then restart your computer.

    2.- After I restarted the server I went to the Sharepoint Admin site and started a full crawl. Some seconds later I went to the crawl log and found a warning this time with the following entry:
    Content for this URL is excluded by the server because a no-index attribute.

    So I "Reset All Crawled Content" and tried the full crawl again. This time it worked.

    I hope this helps some one else.



    IT Engineer
    • Marked as answer by ureyes84 Tuesday, October 14, 2008 4:08 PM
    • Edited by ureyes84 Tuesday, October 14, 2008 4:10 PM
    Tuesday, October 14, 2008 4:08 PM
  • ureyes84, thanks a lot!! It also worked for me and made my day easier!! :-)
    Friday, May 15, 2009 12:53 PM