none
DPM 2019 Remote Agent Install Error RRS feed

  • Question

  • Hello, I've just upgraded DPM from 1807 to 2019 on Windows Server 2016 and all remote agents were updated successfully except on two Hyper-V hosts on a cluster with other hosts that were updated OK. 

    Getting this message error:

    Protection agent version: 5.1.378.0
    Error: Data Protection Manager Error ID: 296
    The protection agent is incompatible with the version of DPM that is installed on this computer. All subsequent protection and recovery tasks will fail on this computer until you update the protection agent.
    Recommended action: Update the protection agent to a version compatible with the DPM server. From the DPM Administrator Console, open the Agents tab in the Management task area. Select the computer on which the protection agent is installed. Click Update from the Actions pane.

    I am able to install the remote agent manually with no issues and run -setdpmserver command OK, Also rebooted those two hosts multiple times and still no luck. Both them will not update. Version 1807 was working just fine with no issues. Also checked all pre-requests on those two servers and all good.

    Any ideas or suggestions will be much appreciated.

    Thannks

    Friday, February 7, 2020 5:37 PM

All replies

  • Hi,

    Does it not work if you use the DPMAgentInstaller_KB4533416_AMD64.exe (DPM 2019 RTM) agent located under "%SystemDrive%\Program Files\Microsoft System Center\DPM\DPM\agents\RA\10.19.260.0\amd64\1033" and install it manually on the Hyper-V hosts, and then perform a refresh in the DPM console? (Might even need to close the console).

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, February 7, 2020 7:06 PM
  • Hi Leon, 

    First thanks for replying The problem is, that I don't have agents folder under DPM. I have only ProtectionAgents

    As you see in the picture

    Friday, February 7, 2020 7:28 PM
  • Yes that’s the one, I didn’t remember the whole exact path from my mind :-)

    Do you see any agent installation files?


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, February 7, 2020 7:34 PM
  • Nope, all what I see is that ProtectionAgents folder and under only the one I used to install it manually.

    Friday, February 7, 2020 8:06 PM
  • That should be the agent install file (mine was UR1 of DPM 2019 actually), if it didn’t work you can try running the Update-DPMProductionServer PowerShell cmdlet on the DPM server.

    If that doesn’t work, you’ll have to remove the agent from the DPM console, if it fails use the Remove-ProductionServer.ps1 script located in the bin folder of the DPM installation folder.

    The syntax is:

    Remove-ProductionServer.ps1 <DPM Server Name> <Protected Server Name>
    Once you have removed it ”forcefully” or not, reinstall it via the console, or manually and attach it.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, February 7, 2020 8:24 PM
  • I've tried and still no luck. The odd thing is that even when I run Attach-ProductionServer.ps1 they will attach successfully. Maybe, the next step to open a ticket with MS support...
    Friday, February 7, 2020 11:13 PM
  • And you tried completely uninstalling the DPM agent from the Hyper-V cluster nodes, reboot -> clean install the DPM agent?

    If that doesn't work, then a support case is your best shot.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, February 7, 2020 11:18 PM
  • Yep, tried almost everything I can think of. Thanks again for your help, much appreciated.
    Saturday, February 8, 2020 12:09 AM
  • Let us know how everything goes!

    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, February 12, 2020 9:57 PM