locked
Word Document Taking 25% of CPU RRS feed

  • Question

  • Hi,

    I have a situation where a user will open a Word 2000 document and even if they aren't doing anything Word will take up a steady 25% of the CPU.  If I save the document as an RTF and have them use it in that format, the CPU load is light.  However if I open the RTF and save the file back as a DOC, it will be fine until I add some text and then save it out, then the next time I open it the file goes back to a high CPU load.  Something I also noticed is that the DOC file will take longer than the RTF to fully load up (30secs as opposed to 10).

     

    This is a Citrix environment and this one particular file is 289 pages in length and is mostly text (some formatted).

     

    Office 2000 is patched up to SP3.

     

    *UPDATE*

    After further troubleshooting I found that this is somehow tied to the spelling and grammar check with documents that have a large page count as follows:

    When I open the suspect document which is 289 pages long, it will begin to do a spelling and grammar check during which time the CPU for that process will hover around 7-10%.  Once the check has completed, the cpu usage jumps to 25% and stays there.  This also occurred with a 548 page document.  When I take that same 289 page doc and cut it down to 97 pages (arbitrary) it goes through the spelling and grammar check but this time when it's finished, it doesn't jump up to 25% but rather goes back down to 0%.

    I also determined that this happens with .rtf and files as well.

     

    Any thoughts (besides "can't believe you are still running 2000" :8o)?

     

    Thanks in advance.....


    Scott S., Bathgate, Wegener & Wolf P.C.
    Monday, April 11, 2011 7:16 PM

All replies

  • Hi,

     

    Does the issue only occur with a specific Word file, or with all the Word files?

     

    Try to open Word with /a switch and check the results again.

     

    You can use the /a switch to start Word by using only the default settings in Word 2010. When you use the /a switch, Word does not load any add-ins. Additionally, Word 2010 does not use your existing Normal.dotm template. Restart Word by using the /a switch.

    In Windows Vista and Windows 7

    1.       Exit Word

    2.       Click Start

    3.       In the Start Search box, type the following text, and then press ENTER:
    "%programfiles%\microsoft office\office9\winword.exe" /a

     

    In Windows XP

    1.       Exit Word

    2.       Click Start, and then click Run.

    3.       In the Open box, type the following text, and then press ENTER:
    "%programfiles%\microsoft office\office9\winword.exe" /a

     

     

    After this, in Word, click File > Open to open the file, and check the results again.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

     

     

    Tuesday, April 12, 2011 7:18 AM
  • Sally,

     

    This happens randomly, not with all docs.

     

    I did what you suggested and it didn't make a difference.

     

    Word (with or without the /a switch) took a steady 25% of the CPU when opening and working with the .doc file and less than 1% when opening and working with the .rtf.

     

    Thanks,


    Scott S., Bathgate, Wegener & Wolf P.C.
    Tuesday, April 12, 2011 4:27 PM
  • Hi,

     

    What’s the result in clean boot mode? It might be related to some third-party software’s conflicts.

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/92913

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

     

     

     

    Thursday, April 14, 2011 8:44 AM
  • This is a Citrix environment with 6 servers in the farm running Server 2003.  There's nothing non-essential running in the background and it happens on every server under any user session.

     

    Thanks,


    Scott S., Bathgate, Wegener & Wolf P.C.
    Thursday, April 14, 2011 5:04 PM