none
SBS 2011: https://xxx.mydomain.com/exchange gives a Runtime Error

    Question

  • I have loaded a test SBS2011 as a VM under Hyper-V. The SBS is running OK, so far other than for this error. Out of habit, I typed https://xxx.mydomain.com/exchange to get to OWA. (old habits die hard) and the response is: Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

     

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
     <system.web>
    
      <customErrors mode="Off"/>
    
     </system.web>
    
    </configuration>

     


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

     

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
     <system.web>
    
      <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    
     </system.web>
    
    </configuration>

     

    Server Error in '/' Application.

    Runtime Error

    If I use the correct URL https://xxx.mydomain.com/owa I get a sign on screen.

    If I use https://xxx.mydomain.com/junk I get a 404 screen.

    How do I prevent the runtime error as a response to the "exchange" URL.

    Thanks!

    Charles.

     

     

    Wednesday, February 23, 2011 11:43 PM

All replies

  • That's not a runtime error, that's an asp error page.
    Do the same thing inside your network on the server itself...what does
    it come back with and did you run the domain name wizard yet?
     
    Thursday, February 24, 2011 4:04 AM
    Moderator
  • Hi,

    I tried this at my own SBS 2011 server and also on the server itself I got this error. I took a look in IIS and on the /exchange virtual directory is a http redirect configured to /owa. I compared this with another exchange 2010 SP1 standard server (there it works fine) but I don't saw any difference at first look.

    Susan,

    I have ran the connect to the internet and setup your internet address wizards, only thing different

    Another thing at the moment this occurred there was a event log written in the application log:

    Log Name:      Application
    Source:        ASP.NET 4.0.30319.0
    Date:          2/23/2011 8:29:59 AM
    Event ID:      1310
    Task Category: Web Event
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      SBS2011SRV01.sbs2011lab01.local
    Description:
    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 2/23/2011 8:29:59 AM
    Event time (UTC): 2/23/2011 7:29:59 AM
    Event ID: 77199d7207b94c7fb8b8d20e1bd9b8cd
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0

    Application information:
       Application domain: /LM/W3SVC/1/ROOT-1-129429197987539743
       Trust level: Full
       Application Virtual Path: /
       Application Path: C:\inetpub\wwwroot\
       Machine name: SBS2011SRV01

    Process information:
       Process ID: 4240
       Process name: w3wp.exe
       Account name: NT AUTHORITY\NETWORK SERVICE

    Exception information:
       Exception type: ConfigurationErrorsException
       Exception message: It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level.  This
    error can be caused by a virtual directory not being configured as an
    application in IIS. (C:\Program Files\Microsoft\Exchange
    Server\V14\ClientAccess\owa\web.config line 37)
      at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean
    ignoreLocal)
      at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String
    configKey, Boolean getLkg, Boolean checkPermission, Boolean
    getRuntimeObject, Boolean requestIsHere, Object& result, Object&
    resultRuntimeObject)
      at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
      at System.Web.Configuration.RuntimeConfig.GetSectionObject(String
    sectionName)
      at System.Web.Configuration.RuntimeConfig.GetSection(String
    sectionName, Type type, ResultsIndex index)
      at System.Web.Configuration.RuntimeConfig.get_Identity()
      at System.Web.HttpContext.SetImpersonationEnabled()
      at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest
    wr, HttpContext context)

     

    Request information:
       Request URL: http://remote.ronnypot.nl/exchange
       Request path: /exchange
       User host address: 192.168.2.210
       User:
       Is authenticated: False
       Authentication Type:
       Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:
       Thread ID: 6
       Thread account name: NT AUTHORITY\NETWORK SERVICE
       Is impersonating: False
       Stack trace:    at
    System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean
    ignoreLocal)
      at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String
    configKey, Boolean getLkg, Boolean checkPermission, Boolean
    getRuntimeObject, Boolean requestIsHere, Object& result, Object&
    resultRuntimeObject)
      at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
      at System.Web.Configuration.RuntimeConfig.GetSectionObject(String
    sectionName)
      at System.Web.Configuration.RuntimeConfig.GetSection(String
    sectionName, Type type, ResultsIndex index)
      at System.Web.Configuration.RuntimeConfig.get_Identity()
      at System.Web.HttpContext.SetImpersonationEnabled()
      at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest
    wr, HttpContext context)


    Custom event details:

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
       <Provider Name="ASP.NET 4.0.30319.0" />
       <EventID Qualifiers="32768">1310</EventID>
       <Level>3</Level>
       <Task>3</Task>
       <Keywords>0x80000000000000</Keywords>
       <TimeCreated SystemTime="2011-02-23T07:29:59.000000000Z" />
       <EventRecordID>30295</EventRecordID>
       <Channel>Application</Channel>
       <Computer>SBS2011SRV01.sbs2011lab01.local</Computer>
       <Security />
     </System>
     <EventData>
       <Data>3008</Data>
       <Data>A configuration error has occurred.</Data>
       <Data>2/23/2011 8:29:59 AM</Data>
       <Data>2/23/2011 7:29:59 AM</Data>
       <Data>77199d7207b94c7fb8b8d20e1bd9b8cd</Data>
       <Data>2</Data>
       <Data>1</Data>
       <Data>0</Data>
       <Data>/LM/W3SVC/1/ROOT-1-129429197987539743</Data>
       <Data>Full</Data>
       <Data>/</Data>
       <Data>C:\inetpub\wwwroot\</Data>
       <Data>SBS2011SRV01</Data>
       <Data>
       </Data>
       <Data>4240</Data>
       <Data>w3wp.exe</Data>
       <Data>NT AUTHORITY\NETWORK SERVICE</Data>
       <Data>ConfigurationErrorsException</Data>
       <Data>It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level.  This
    error can be caused by a virtual directory not being configured as an
    application in IIS. (C:\Program Files\Microsoft\Exchange
    Server\V14\ClientAccess\owa\web.config line 37)
      at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean
    ignoreLocal)
      at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String
    configKey, Boolean getLkg, Boolean checkPermission, Boolean
    getRuntimeObject, Boolean requestIsHere, Object&amp; result,
    Object&amp; resultRuntimeObject)
      at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
      at System.Web.Configuration.RuntimeConfig.GetSectionObject(String
    sectionName)
      at System.Web.Configuration.RuntimeConfig.GetSection(String
    sectionName, Type type, ResultsIndex index)
      at System.Web.Configuration.RuntimeConfig.get_Identity()
      at System.Web.HttpContext.SetImpersonationEnabled()
      at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest
    wr, HttpContext context)

    </Data>
       <Data>http://remote.ronnypot.nl/exchange</Data>
       <Data>/exchange</Data>
       <Data>192.168.2.210</Data>
       <Data>
       </Data>
       <Data>False</Data>
       <Data>
       </Data>
       <Data>NT AUTHORITY\NETWORK SERVICE</Data>
       <Data>6</Data>
       <Data>NT AUTHORITY\NETWORK SERVICE</Data>
       <Data>False</Data>
       <Data>   at
    System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean
    ignoreLocal)
      at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String
    configKey, Boolean getLkg, Boolean checkPermission, Boolean
    getRuntimeObject, Boolean requestIsHere, Object&amp; result,
    Object&amp; resultRuntimeObject)
      at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
      at System.Web.Configuration.RuntimeConfig.GetSectionObject(String
    sectionName)
      at System.Web.Configuration.RuntimeConfig.GetSection(String
    sectionName, Type type, ResultsIndex index)
      at System.Web.Configuration.RuntimeConfig.get_Identity()
      at System.Web.HttpContext.SetImpersonationEnabled()
      at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest
    wr, HttpContext context)
    </Data>
     </EventData>
    </Event>


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    Thursday, February 24, 2011 8:20 AM
  • Hello Susan!

    To answer your questions:

    1) Running on the server itself in IE, the same error occurs.

    2) Yes, I ran the wizard and have rerun it. Other than for the warings to open router ports which are open and correctly directed, there is a green check mark.

    My application log has the same error as posted by Ronnypot.

    Also, having checked all of the items on the "Remote Web Access: Remote Workspace for Charles", in the section "Organization Links", at the bottom left, the "using remote web access" and "using outlook web access", I see "Internet Explorer cannot display the web page". There are the URLs

    https://sites/webhelpwebhelp.html#ELEAC 

    https://sites/webhelp/webhelp.html#EKF 

    They work on the server but nowhere else.

    Charles.

    Thursday, February 24, 2011 5:55 PM
  • Ronny:

    I found some more errors in the Remote Web Access: Remote Workspace. Please see my reply to Susan and check to see if you have the same problem too.

    Thanks!

    Charles.

    Thursday, February 24, 2011 5:57 PM
  • 1. run the fix my network wizard
    2.  inside the IIS console, browse to the web sites inside there.
     
    Thursday, February 24, 2011 6:40 PM
    Moderator
  • Ronny:

    I found some more errors in the Remote Web Access: Remote Workspace. Please see my reply to Susan and check to see if you have the same problem too.

    Thanks!

    Charles.


    Charles,

    I can explain this one, because it points to https://sites you have to use the dns of the sbs server because there is an A record that points to the internal server ip address. If you don't use the dns from your sbs server it cannot resolve sites.


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    Thursday, February 24, 2011 6:54 PM
  • 1. run the fix my network wizard
    2.  inside the IIS console, browse to the web sites inside there.
     


    Susan,

    this doesn't solve the problem.

    It looks like everything works fine, except the redirection of https://mydomain/exchange to /owa

     


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    Thursday, February 24, 2011 7:04 PM
  • Ronny:

    I understand what you are saying but I cannot use the SBS 2011 DNS if I am coming in through the RWW.

    If I replace "sites" with the missing URL xxx.mydomain.com then it works from anaywhere.

    Charles.

    • Edited by CDDM Thursday, February 24, 2011 7:55 PM
    Thursday, February 24, 2011 7:35 PM
  • Susan:

    I had already run the fix my network wizard. It changed nothing.

    Your line #2... did you finish? If so, I don't understand what you want to know.

    :-)

    Charles.

     

    Thursday, February 24, 2011 7:53 PM
  • Charles,

    I understand. I found that when you go to the SBS console, Shared Folders and Web Sites the choose the tab Web Sites select Remote Web Access, click View site properties in the tasks panel. Goto Home page links choose Manage links... and then choose Organization links you can add or remove those links.

    You can remove the 2 links with https://sites/... and add 2 new links with https://remote.yourdomain.com/...


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    Thursday, February 24, 2011 7:54 PM
  • It normally says sites when you haven't run the domain wizard yet.
     
    Thursday, February 24, 2011 7:56 PM
    Moderator
  • Launch the IIS console.  Inside there drill down to the IIS web sites. 
    What shows up inside the IIS management console when you browse the
    websites from inside?
     
    Thursday, February 24, 2011 7:57 PM
    Moderator
  • There are three web sites, Remote Web Access which display fine and has the correct URL. Also, Outlook Web Access and Comanyweb. They have the correct URLs and display just fine. There isn't one for Exchange.

    I haven't changed anything per Ronny's tip.

    :-)

    Thursday, February 24, 2011 8:57 PM
  • I apologize, I was looking at a SBS 2008, not a SBS 2011.
     
    OWA is the site now, you don't get there via Exchange anymore.
     
    What you are seeing is normal (at least as I understand it)
     
    Thursday, February 24, 2011 9:10 PM
    Moderator
  • Right, so in SBS2011 you get an error when you use "remote". From the looks of IIS it is supposed to redirect to OWA. Thousands of people are going to use "remote" and get the script error. Again, it looks as if it is supposed to work.

     

    Thursday, February 24, 2011 9:27 PM
  • Exchange or remote?
     
    Remote works fine.
     
     
    Thursday, February 24, 2011 9:29 PM
    Moderator
  • "Exchange" fails.

    Please try this link: https://remote.charlesprooth.net/exchange 

    Then try https://remote.charlesprooth.net/owa .

    This will show you what works and what doesn't.

     

    :-)

    Thursday, February 24, 2011 9:58 PM
  • Right.  That's normal.
     
    Thursday, February 24, 2011 10:02 PM
    Moderator
  • Thanks Ronny! That works like a charm.

    Charles.

    Thursday, February 24, 2011 10:02 PM
  • Susan:

    Please explain why such behavior from SBS 2011 can be considered to be normal. If this were at a client sight and I offered such an explanation I would expect to have one less client before the end of the day.

    Thanks!

    Charles.

    Friday, February 25, 2011 12:14 AM
  • It's normal because everything I've read from Exchange 2010 is referring
    to \OWA as the new normal, I see it on my clean servers, Most people go
    to email via the remote landing page or via their phones.
     
    So \exchange is not a url that is a high priority item for me.
     
    That said if you look in the redirect properties, it's supposed to
    redirect to \owa
     
    I'll edit the web.config file to see what the error message is saying. 
    For me it's "normal" because that's how I see it on all the SBS boxes
    I've used during the beta and never considered it broken.  Just
    considered it Exchange 2010-ness kicking in.
     
    Friday, February 25, 2011 12:30 AM
    Moderator
  • The issue as I see it is on SBS 2008 that Exchange folder was an application type, and not a folder and therefore it allowed the redirect. 

    I still say this is the new normal as Exchange 2010 now wants you to use OWA, but I'm double checking.

     

    The Internet Address Management Wizard changes the OWA URL from https://<YourNetworkDomainName>/exchange to https://<YourNetworkDomainName>/owa, and the Source Server can no longer serve requests to https://<YourNetworkDomainName>/exchange. We recommend that you notify your users before this change occurs and that you finish the steps in Move Exchange Server mailboxes and settings for Windows SBS 2011 Standard migration as soon as possible.

    Friday, February 25, 2011 5:29 AM
    Moderator
  • It's normal because everything I've read from Exchange 2010 is referring
    to \OWA as the new normal, I see it on my clean servers, Most people go
    to email via the remote landing page or via their phones.
     
    So \exchange is not a url that is a high priority item for me.
     
    That said if you look in the redirect properties, it's supposed to
    redirect to \owa
     
    I'll edit the web.config file to see what the error message is saying. 
    For me it's "normal" because that's how I see it on all the SBS boxes
    I've used during the beta and never considered it broken.  Just
    considered it Exchange 2010-ness kicking in.
     

    Susan,

    I agree it is not a high priority issue, but it is not normal, I have several Exchange 2010 standard / enterprise servers and tried to connect to the /exchange and it redirects to /owa fine.

    only on my sbs 2011 server it doesn't. Only difference I see at the moment is the sbs is useing a self signed certificate and the other servers are using a trusted third party certificate. Maybe this is a clue.

     


    Regards Ronny
    -------------
    Visit my Blog or follow me on Twitter
    Friday, February 25, 2011 6:26 AM
  • Thanks for your efforts. I agree with Ronny that this is not a high priority issue but it is, nevertheless significant.

    It's the impact on the end user that is going to be the real issue because OWA is an end user application. Sure, people will eventually get the message but how many phone calls will it take? All someone had to do was put in a graceful way of letting the end user know that he/she has used the wrong URL. This is a significat loose end that needs to be tidied up.

    Charles.

    Friday, February 25, 2011 4:49 PM
  • Charles,

    I got the same problem with https://xx.mydomain.com/exchange redirection generating an error.

    In fact it seems that the default configuration is broken.

    /exchange virtual folder point the same physical folder thna /owa but the web.config in this folder could not contain the redirection configuration.

    I created in c:\programs\microsoft\exchange server\v14\clientaccess a folder call exchange with the same right than the owa folder.

    I made the virtual folder \exchange point to this new physical folder and validate the http redirection to /owa (this create a new web.config in my exchange folder).

    Now the old link https://xx.mydomain.com/exchange works and redirect my users to https://xx.mydomain.com/owa

    Stephane

    • Proposed as answer by MJLongman Friday, August 19, 2011 7:44 PM
    Tuesday, March 15, 2011 8:44 PM
  • Thank you Stephane!

    Charles.

    Thursday, March 17, 2011 4:47 PM
  • I get the same result as OP.  Thinking I did something wrong, I format the disk and re-installed SBS 2011 all over again and got the same outcome.

    https://bach.mydomain.net/owa works fine.  But https://bach.mydomain.net/Exchange gives the error that OP reports.

    Lots of old users automatically go for the Exchange folder in the url.

    Saturday, March 19, 2011 3:24 AM
  • Bugged.  Won't fix.  :-(
    Tuesday, May 17, 2011 7:46 AM
    Moderator
  • In the same boat.  I've installed 3 SBS 2011 servers in the past several weeks and none work properly with the /public, /exchange or /exchweb virtual directories.  All of those same directories work fine with a stand-alone Exchange 2010 and 2010 SP1 server.  This seems to be related to some of the other added web sites that SBS builds in to the install (which we don't use), but I can't locate the culprit.  I've reinstalled .net 4 and re-registered it.  It's too hard to compare with 2010 standalone since the web.config file is totally different.  Anyone making any progress on this, or is it just a matter of telling the clients to stop going to /exchange any more?
    Friday, June 17, 2011 5:17 PM
  • See the post from above where someone did a workaround.

    See my post where I indicated I bugged it and it's a 'won't fix' because it's seen that Exchange 2010 even though standalone puts in that redirect, that /exchange is a deprecated url.

     

    "

    I created in c:\programs\microsoft\exchange server\v14\clientaccess a folder call exchange with the same right than the owa folder.

    I made the virtual folder \exchange point to this new physical folder and validate the http redirection to /owa (this create a new web.config in my exchange folder).

    Now the old link https://xx.mydomain.com/exchange works and redirect my users tohttps://xx.mydomain.com/owa

    Stephane"

    Friday, June 17, 2011 5:21 PM
    Moderator
  • Thanks Stephane, that was right on the money.  Fixed my problem with /exchange redirection not working.

     

    Thanks again.

     


    Mike Kollmorgan
    Tuesday, July 12, 2011 1:52 PM
  • To elaborate on Steph45’s excellent post, create a new folder called "exchange" under C:\Program Files\Microsoft\Exchange Server\v14\ClientAccess and give the Authenticated Users group Read access.  Not Read and Execute mind you, just the Read NTFS permission. 

    Next, go to IIS and click on the Exchange virtual directory.  Select the Basic Settings link on the right-hand side under Actions.  When that dialog box opens, remove "owa" at the end of the Physical Path field and type "exchange".  The path should look something like this:  C:\Program Files\Microsoft\Exchange Server\v14\ClientAccess\exchange.  Click OK. 

    Now, double-click the HTTP Redirect section of the Exchange virtual directory and enable redirection by clicking the checkbox "Redirect requests to this destination".  Type "/owa" in the text field below, without the quotes.  Click Apply on the right-hand side.  This will create a new web.config file under the Exchange folder you created. 

    This appears to work great for me and I will probably do the same for the /Public and /ExchWeb virtual directories since they also had redirection to /owa enable on them before I simplified the OWA URL. 

    Thanks Stephane! 

    • Proposed as answer by CDDM2 Thursday, May 24, 2012 3:33 PM
    Friday, August 19, 2011 7:57 PM
  • I fixed this on a server that we have at a client location.  Thanks to this thread, I was set on the right track. 

    The problem was in the Application Pools.  ASP .NET v4.0, v4.0 Classic, SBS Client Deployment AppPool, SBS Web Applications application pool, and SBS Web Workplace AppPool should all be set to .net 4.0 when you right click and go into the "basic Setting" menu.  3 of the 5 were set to 2.0 in our case.  Switched them and fixed.

    • Proposed as answer by Michael Hicks Thursday, May 24, 2012 1:34 PM
    Friday, November 4, 2011 2:45 AM
  • Genius!  This works for any of the built in web pages (remote, owa, and, um, that other one).

    Thanx

    Thursday, May 24, 2012 1:35 PM
  • Thought I would add some additional detail. In my setup I had taken advice to remove the HttpToHttpRedir module from the default web site to allow hosting my static page business site.

    (Please refrain from comments about how I "shouldn't do that", don't want that to come off as abrasive, just tired of being told what I shouldn't do instead of telling me how to do something. I have detailed steps for that process too.)

    Anyway, mjlongman and steph45 have it right, however, as you may have realized, since the exchange and exchweb virtual directory point to the same directory as owa, I found that I was thwarting myself messing wiht it so thought maybe a step by step process might be a decent addition. Here are my steps...

    1 - ensure that the HttpToHttpRedir module exists on the owa application. In IIS manager click OWA in the left pane. In the middle pane double click "modules". Select "module type" from the "group by" drop down list in the top middle of the page. Scroll down to managed modules and hopefully you'll see the "HttpToHttpsRedir" module.

    2 - Create a new text file on your desktop(this is just to save the string you will be copying in a moment and you can save this text file anywhere you like).

    3 - Double click the module (or click on it and then click "edit" in the top right corner. I copied and pasted both the name and type into my text file to save time. Make sure you get the entire string copied, mine looks something like this: (don't copy this string for use on your machine, it won't work)  Microsoft.WindowsServerSolutions.IWorker.IIS.Modules.HttpToHttpsRedir,HttpToHttpsRedir,Version=6.1.0.0,Culture=neutral,PublicKeyToken=31bf3856ad364e35

    4 - Close the "edit managed module" box, but leave IIS manager open

    5 - Open an explorer window and navigate to the "C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess" folder. Create a new folder named "exchange". Assign read permissions for the authenticated user account. Leave the expolrer window open so you can look at your web.config file when you finish.

    6 - Go back to IIS manager, click on "exchange" in the left pane, then click "basic settings in the actions panel (top right). In the "physical path" field ( C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa ) change "owa" to "exchange", should look like this: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\exchange. Click "test settings" then "ok". Don't worry if you get a message that says "cannot verify access to path" (so long as you did set permissions on the exchange folder you created). Then click apply in the action pane.

    7 - In IIS manager, click "exchange" again in the left pane. In the middle pane double click "modules". Select "module type" from the "group by" drop down list in the top middle of the page. Scroll down to managed modules and hopefully you'll see the "HttpToHttpsRedir" module. Here was my second problem. Since I had removed my HttpToHttpsRedir module from the default web site (this was per MS support) it was no longer being inherited at the lower levels and I had to manually add it back.

    8 - If you dont see the HttpToHttpsRedir module, go back and click on "owa" in the left pane. In the middle pane double click "modules". Select "module type" from the "group by" drop down list in the top middle of the page.

    9 - Scroll down to managed modules and delete the "HttpToHttpsRedir" module (only after insuring that you have saved the string in your text file, step 1 above.

    10 - Select "owa" in the left pane again (for some reason IIS was acting funky so Ive established this as a habit) then double click "modules".

    11 - Click "add managed module".

    12 - type HttpToHttpsRedir in the name field or copy and paste it from your text file.

    13 - copy and paste your string in the type field and save. It may give you a message about adding managed modules, don't worry about it.

    14 - In IIS manager, click on "owa" in the left pane, then click on "http redirect" in the middle pane. i had to check, apply, uncheck and apply, to make sure that on the owa app, there is NO http redirect.

    15 - In IIS manager, click "exchange" and you should see no subfoilders. Still on "exchange" double click "http redirect" and check the redirect box, enter "/owa". I deselected both check boxes under "redirect behavior".

    EDIT: shortly after posting this I found that my iphones would no longer sync. When attempting to check the modules on the activesync app, found an error (unfortunately I didn't write it down but it was something about having duplicate entries in web.config so I went to my previous versions (from activesync app in IIS manager click "explore", right click the web.config and copy it to a good location, don't overwrite other web.config files and rename the existing web.config to web.config.bak) of the folder and pulled one from a day ago and all is working.

    After many painful hours of working with SBS 2011 it is finally working but there have so many gotcha's it's been unbelievable. Ill post my other findings in the appropriate forums.

    Also, many thanks to both mjlongman and steph45, without your instructions I would have spent many more frustrating hours than I have and my post is just a little further elaboration of both of yours.

    Ciao....



    • Edited by Mike CV Sunday, October 14, 2012 9:32 PM
    Sunday, October 14, 2012 7:24 PM