locked
ADFS 4.0 and unique identifiers for relying trust RRS feed

  • Question

  • Howdi,

    When applying a new 'Relying Party Trust' we are receiving error MSIS7612 as the 3rd party has multiple environment, DEV/Prod, endpoints.

    In ADFS 2.0 there was Security Roll Up 3, https://support.microsoft.com/en-us/help/2790338/description-of-update-rollup-3-for-active-directory-federation-services-ad-fs-2.0, that 'fixed' the issue.  Is the same limitation meant to be in place in ADFS 4.0 or is there a similar patch that needs applying?

    Any information welcome.

    Regards

    Paul



    • Edited by PS_Saviola Friday, May 19, 2017 2:52 AM
    Friday, May 19, 2017 2:50 AM

All replies

  • Hi,

    Could you provide the details for the error found in the event log?


    Kind Regards Don

    Friday, May 19, 2017 9:28 AM
  • Hi,

    There are no errors in logs, just the on screen error:

    "MSIS7612: Each identifier for a relying party trust must be unique across all relaying party trusts in AD FS configuration."

    Which is the same error that occurred in ADFS prior to installing Security Roll-up 3 as mentioned above

    Cheers

    Monday, May 22, 2017 6:01 AM
  • Hi,

    Can you confirm that the destinations / URL's used in the relying party trusts are not duplicated within some of the trusts?


    Kind Regards Don

    Monday, May 22, 2017 6:32 AM
  • Hi ,

    I am facing a similar issue of "MSIS7612: Each identifier for a relying party trust must be unique across all relying party trusts in AD FS configuration" while trying to add a RPT.

    I have checked and found that the identifier and Endpoints and Signature certificate of the RPT (which i am trying to add) is similar to an existing RPT in my FARM.

    I am using ADFS 4.0 and i have also tried to change the display name but there was no luck.

    Do i need to follow the process provided here for ADFS 2.0 - https://blog.msresource.net/2013/03/05/msis7613-the-signing-certificate-of-the-relying-party-trust-is-not-unique-across-all-relying-party-trusts-in-ad-fs-2-0-configuration/

    Is there any process defined for 4.0.

    Wednesday, July 11, 2018 6:12 AM
  • Were you able to fix this issue? If yes, what was the resolution?
    Tuesday, November 6, 2018 7:39 PM
  • Have you ever found any resolution for this issue?
    Tuesday, January 15, 2019 9:06 PM