Visual C++ Runtime Library error when opening documents in Powerpoint 2010 from Sharepoint link RRS feed

  • Question

  • Hello,

    I posted this question on the Office Powerpoint forum and did not get much response so thought I would try here.   Here is the link to that post  http://social.answers.microsoft.com/Forums/en-US/pptshare/thread/36a58d07-b1ad-4935-a14e-086dae8cb786

    I'm running Windows 7 with Office 2010.  We have a Sharepoint 2007 server.  Whenever I click a link from our Intranet site I get the error "this application has requested the Runtime to terminate it in an unusual way.  Please contact the applications's support team for more information."  It asks if I want to open in safe mode and I say yes and it never opens. 

    During testing I also find that if I have a blank powerpoint .ppt file that I try to save to the same document library on the same site it works fine, but if I try to save a blank .pptx file to the site I get the same runtime error. 

    This does not happen on all powerpoint or office documents being opened from the Intranet.  If I boot to safe mode it works fine.    If I copy the files local they work fine.  Any ideas on how to fix it?

    Thanks so much!!!

    Friday, October 1, 2010 4:49 PM

All replies

  • Hmmm... I'm going to guess you're using x64 versions of Office?

    There are issues with 64 bit Office being used with SharePoint.  Microsoft recommends that you use 32 bit Office.  Try testing from 32 bit Office and see if the problem is resolved.



    I trust that answers your question...


    • Marked as answer by Leoyi Sun Thursday, October 7, 2010 7:25 AM
    • Unmarked as answer by Laureljp Friday, October 8, 2010 9:09 PM
    Tuesday, October 5, 2010 12:02 PM
  • Nice try but no....I'm already using 32 Bit Office!
    Friday, October 8, 2010 9:09 PM
  • Hi,


    What is the link which you click about? Does it link to a document of the intranet or a document from the internet?


    What about having tried this: documents-> settings-> advanced settings-> open in the client application.


    Is there anything wrong with your local net firewall setting? Or is there something wrong with your antivirus software?

    Please have a check, make sure there are no related settings which would lead to this issue.


    Best Regards!





    • Marked as answer by Leoyi Sun Monday, October 18, 2010 8:19 AM
    • Unmarked as answer by Laureljp Monday, October 18, 2010 4:30 PM
    Friday, October 15, 2010 11:08 AM
  • Open in client application is already checked for that document library.

    This is powerpoint documents on our intranet that live in a Sharepoint document library.  It is not firewall or virus related because other documents open without problems.  For some reason it's only powerpoint documents.

    Monday, October 18, 2010 4:32 PM
  • Hi,


    Would you please have a try this: Internet Explorer-> Tools-> Internet Options-> Advanced tab-> Restore default-> Ok?


    Or did you have a update your office :




    The other way is that try to reboot the SharePoint Server and clean out the user profile,

    if there is still this issue, I’m afraid the worst way is to reinstall the Office 2010.


    And the following two references may also give you a hand:




    Best Regards!



    • Marked as answer by Leoyi Sun Monday, November 8, 2010 2:20 AM
    • Unmarked as answer by Laureljp Monday, December 6, 2010 4:58 PM
    Thursday, October 21, 2010 6:24 AM
  • I have tried restore default.  Does not help.

    I have applied all office updates, I have uninstalled and reinstalled and am still having the problem.

    I have deleted my sharepoint profile, and rebooted the server and STILL having the problem.  

    I have upgraded the Sharepoint server to R2.  Yup still having the problem.

    It is not a security issue.  I'm the Sharepoint administrator with full control of the whole site.  The powerpoint documents can be open locally so its not something set in their permission. 

    Would love to try any other suggestions.


    Monday, December 6, 2010 5:01 PM
  • I know this thread is pretty old, but were you ever able to resolve this issue and, if so, how?  I am having this issue for one particular user. 

    • Edited by shellie1 Tuesday, July 10, 2012 7:09 PM
    Tuesday, July 10, 2012 7:09 PM
  • I know it may sound odd but try changing the default printer. Had a similar issue occur for a customer I was supporting with Office 2010 and Windows XP SP3 clients. Same exact error. They had one roaming user that had the issue for all machines they logged into but worked for all other users on the same machines. It wound up being the default printer, in this case it was an HP Color Laserjet 4550. I had them close all PowerPoint windows deleted the printer object in the Printers and Faxes folder (Windows XP SP3), they could have also changed the default printer to something generic like Send to OneNote.

    Thursday, August 2, 2012 4:59 PM