locked
VISTA won't load drivers for my Plextor DVD-R/RW drives. RRS feed

  • Question

  • Hi....

     

    I recently installed VISTA RC1 on a desktop pc that has an asus p4 motherboard and an intel 3.06 cpu, 2 gb ram.  My dvd-r/rw drives don't show up in file explorer and in device manger it shows that the drivers were unable to load for both of the drives.  The 2 drives in question are a plextor 708 and a 716 eide drives.  Can anyone give me any ideas as to why the drivers won't load.  Both drives worked fine in xp pro service pack 2 and I was able to install vista just fine from one of these 2 drives.

    Thanks for any and all help.

    rb

    Sunday, September 24, 2006 8:49 PM

All replies

  • HI

    I can't offer any help except I have the same problem with a PX716A

    its works great under XP  but in vista RC2 it is not detected or given a drive letter although my bios see's it fine.



    Jim

    Thursday, October 12, 2006 2:03 PM
  • Really?

    I got PX716SA and it works fine.

    Dont know the problem for urs.

    Friday, October 13, 2006 6:39 AM
  • I myself own a Plextor DVDR PX-712A and having the same problem.

    Well, more or less I assume. My knowledge about computers is fairly limitted compared to most people here.
    Anyway, the problem is: The DVDR doesn't show up in any of my menu's. I can insert a CD and take it out, so at least I know it's connected, but it won't read any CD's. So I tried to go to "Help" etc. And looked into it's properties. Now I could find it, it's been installed, but there's still a problem with the driver and I still can't see it showing up in "This Computer" (literally translated from dutch as that's what I am). So I tried Driver Update. This sais I already haev the best version installed and there are no  problems, so why doesn't it work? So I uninstalled it completely, re-installed and still the exact same problem. So I looked into it's properties again and could only find 1 thing (with my limitted knowledge that is) that didn't seem correct. One of the drivers needed wasn't digitally signed by Microsoft. The directory was: C:/WINDOWS/system32/drivers/pfc.sys

    I'd really appreciate it if any of u could help with this problem. A friend recommended reformatting, but as I can't write any CD's I can't make any backups, as far as I know at least. And I'm not even sure if reformatting will help so my best shot is actually asking here.

    Edit: I found this post by looking in the Microsoft search. So I didn't actually notice what forum I was in. I'm using XP-Pro and I see this is something with Vista (which I'm not familiar with). Yet I have the same problem a sthe above posters.

    Tuesday, November 28, 2006 4:25 PM
  • Mr Hanky:

     

    I had the same problem...and finally found an article on technet.  I believe that your problem will require a registry manipulation.

     

    Please save your registry before attempting this, do a backup of it.

     

    Then follow the instructions as given in the article..

     

    http://support.microsoft.com/kb/320553

     

    This article will help you, I believe.

     

    Good luck Sir.

     

    I have another friend in Holland who raises Chows.  Splendid Man and a great human being.

     

    Lyal

    Tuesday, May 29, 2007 8:39 PM