locked
Multiple mailboxes with an X in red circle RRS feed

  • Question

  • Dear Members, 
    i've the following problem, in the ESM -> ... -> Mailbox store -> Mailboxes i've some mailboxes with an X in red circle. The problem is that there is a mailbox name for example user5 that appears 3 times and has 3 different Full Mailbox Directory Name. 
    I tried to purge, reconnect, running clean up wizard, defragmenting, integrity checking the store, but every time I get the following error code: 0x8004010f 
    In the eventvwr there are a lot of messages like: 
    - Failed to delete the mailbox of /O=XXX/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=XXX with error 0x8004010f. 
    - The folder with folder ID 1-1D43E8E could not be deleted. Additional information: 0x8004010f. 
    Can you please suggest me howto clean up this mailboxes? 
    Best Regards, 
    Zoltan
    Thursday, September 29, 2011 8:33 AM

All replies

  • Hi Zoltan,

    Can you please attach the error image?

     

    Thanks

    Amit Rawat

    Thursday, September 29, 2011 10:18 AM
  • Thursday, September 29, 2011 1:31 PM
  • Thursday, September 29, 2011 1:31 PM
  • You already tried doing an offline defrag and isinteg? You might be not have any options short of moving all mailboxes to another store and deleting the DB (need enterprise edition) ran into similar with not being able to delete stubb mailboxes. Is it causing an issue; ie are you trying to re-use the DN but can't because it's already being used by this mailbox?
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Thursday, September 29, 2011 3:04 PM
  • Hey Zoltan,

    Thanks to share error image, i have some question and suggestion please follow the same and let me know the status:-

    1) have those mailboxes ever being used if not then please log in on those mailboxes and then try to clean it up.

    2) if you deleted respective mailboxes users then create some test users and then connect them and then try to remove from Exchange.

    3) Did you right click and select "Run cleanup agent" . Once you run this command ,  it may take upto a day .

    4) if all above option is not related to you then seems your .edb is need to be repaired and you'll have to run this command : ""eseutil /g /v /x /ispriv " to fix the data integrity.

     

    Thanks

    Amit Rawat

    Thursday, September 29, 2011 4:40 PM
  • Unfortunately this is an Exchange 2003 SBS so I can't make a new mil store :(
    Thursday, September 29, 2011 10:00 PM
  • 1) with username fac1 ... or with the name which appears in the mailbox full directory name?

    2) this one I tried but I can't delete that test user.

    3) I tried this cleanup agent, but it stops very early and in the eventvwr I see the same error code: 0x8004010f

    4) there is no /v /x and /ispriv parameter for this version of eseutil:

    E:\Program Files\Exchsrvr\bin>eseutil.exe /?

     

    Microsoft(R) Exchange Server Database Utilities

    Version 6.5

    Copyright (C) Microsoft Corporation. All Rights Reserved.

     

    DESCRIPTION:  Maintenance utilities for Microsoft(R) Exchange Server databases.

     

    MODES OF OPERATION:

          Defragmentation:  ESEUTIL.EXE /d <database name> [options]

                 Recovery:  ESEUTIL.EXE /r <logfile base name> [options]

                Integrity:  ESEUTIL.EXE /g <database name> [options]

                 Checksum:  ESEUTIL.EXE /k <file name> [options]

                   Repair:  ESEUTIL.EXE /p <database name> [options]

                File Dump:  ESEUTIL.EXE /m[mode-modifier] <filename>

                Copy File:  ESEUTIL.EXE /y <source file> [options]

                  Restore:  ESEUTIL.EXE /c[mode-modifier] <path name> [options]

     

    <<<<<  Press a key for more help  >>>>>

    D=Defragmentation, R=Recovery, G=inteGrity, K=checKsum,

    P=rePair, M=file duMp, Y=copY file, C=restore

    =>

    Thursday, September 29, 2011 10:14 PM
  • Unfortunately this is an Exchange 2003 SBS so I can't make a new mil store :(

    Based on my experience, you might need to rebuild the Exchange 2003 server fro this issue. I would suggest you poste this problem in the SBS forum here http://social.technet.microsoft.com/Forums/da-DK/smallbusinessserver/threads. Doing so can be better to use the integrated tool in SBS. Your understanding would be appreciated.
    Fiona
    Wednesday, October 5, 2011 7:03 AM
    Moderator
  • I had similar problems soon in a small organization - Exchange 2003 and 10 mailboxes

    In the beginning, in the Event viewer there were disk errors (the same disk with Exchange database). So, I added a new disk and started to move the mailboxes to a new Mailbox Store located on the new disk.

    - 6 mailboxes were moved correct
    - 1 mailbox totally refused to be moved. Isinteg and eseutil didn't help - the server stopped to respond and crashed. So I manually copied the available content in this mailbox in a .pst and then deleted it and then manually recreated it in the new store from .pst
    - other 3 were moved, but after this process they were duplicated in the old store with the same name with X in red circle. It was not possible to "Purge" and "Reconect" this duplicas. And also, EMS showed they were empty - 0 messages, but some small size (20-50KB)

    I tried the following for one of these three users (and it helped):
    1. Deleted the mailbox for this user (Active Directory Users And Computers  ... Exchange Tasks/Delete Mailbox)
    2. Then "Run Clean Up Agent" on old and new Mailbox store - in the new Mailbox store, the corresponding mailbox became with red X circle
    3. Then "Purge" the duplica in the old store - "Purge" didn't fail this time
    4. Then "Reconect" the corresponding Mailbox (with X red circle in the new store) to the user
    5. And then fixed some user attributes (e-mail address)

    This helped me to purge this duplicated mailbox with red X, so I did it for the last two mailboxes with X red circle.



    Thursday, October 6, 2011 8:16 PM
  • The defragmentation process failed:
    E:\Program Files\Exchsrvr\bin>eseutil.exe /d ..\MDBDATA\priv1.edb
    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.
    Initiating DEFRAGMENTATION mode...
                Database: ..\MDBDATA\priv1.edb
          Streaming File: ..\MDBDATA\priv1.STM
          Temp. Database: TEMPDFRG4024.EDB
    Temp. Streaming File: TEMPDFRG4024.STM
                      Defragmentation Status (% complete)
              0    10   20   30   40   50   60   70   80   90  100
              |----|----|----|----|----|----|----|----|----|----|
              .............................
    Operation terminated with error -1014 (JET_errOutOfBuffers, Out of database page
     buffers) after 12219.922 seconds.
    Thursday, October 6, 2011 9:26 PM
  • I have seen this before and sometime running the cleanup agent failed. What I did as followed.

    1. create a dummy user account

    2. reconnect the disconnect mailbox to dummy account

    3. logon and send test emails to itself

    4. go into AD and run the delete mailbox wizard

    5. run the cleanup agent again on the db

    I hope that work. Please let us know.

    Thursday, October 6, 2011 11:46 PM
  • But in SBS edition you are not allowed to create more then one message store, am I right?
    Friday, October 7, 2011 7:39 AM
  • 1. create user "clean" without exchange options/mailbox.
    2. reconnect one of the duplicated entries to this "clean" user.
    3. then I tried to login to OWA with this "clean" user, but the login failed.
    4. in the AD - Users and Computers I run the mailbox delete wizard.
    5. after I run the Clean Up Agent job, in the event viewer I see the following:
    - The user account for 'Clean' does not exist in the directory or is not enabled for Exchange mail. This mailbox will be removed from mailbox store 'First Storage Group/Mailbox Store (SRV01)' in 0 days 
    - Cleanup of deleted mailboxes that are past the retention date is finished on database "First Storage Group\Mailbox Store (SRV01)".
      0 deleted mailboxes (0 KB) have been removed.
      1 deleted mailboxes (78 KB) have been retained. 
    6. now I checked again the mailbox list, and there is a new user with the X in red circle, named "clean" :(
    Friday, October 7, 2011 10:38 AM
  • ... 6. now I checked again the mailbox list, and there is a new user with the X in red circle, named "clean" :(

    7. Right click on it and "Purge"

    • Edited by DimiterS Saturday, October 8, 2011 11:37 AM
    Saturday, October 8, 2011 11:26 AM
  • yes, I did, but did not helped :(
    Saturday, October 8, 2011 8:14 PM
  • You run it and it didn't help, or you were not able to run it because it was disabled ?

    If you run it, than did you count the mailboxes with red X ?
    May be, their total number is decreased now with one.


    • Edited by DimiterS Sunday, October 9, 2011 8:30 PM
    Sunday, October 9, 2011 8:29 PM
  • 1) Try with fac1 and then see what happen...

     

     

    Thanks

    Amit Rawat

    Monday, October 10, 2011 2:51 PM