locked
JNLP file not launching on Windows 10 1803 when using JRE 1.8.181 in App-V RRS feed

  • Question

  • I'm trying to sequence Java 1.8.181 under App-V 5.2 using JREBLOCK to provide the ability to launch a JNLP file. This all works as it should on Windows 10 1703 and 1709 but doesn't work on Windows 10 1803. Has anyone experienced this under 1803?

    Thanks!

    Tuesday, September 25, 2018 3:08 PM

Answers

  • I figured out the problem and wanted to report back what the fix was.

    Sequencing Java using PVAD instead of VFS fixed the issue I was having on Windows 10 1803.

    Jim

    • Marked as answer by Jim.Webb Tuesday, October 2, 2018 4:26 PM
    Tuesday, October 2, 2018 4:26 PM

All replies

  • Have not seen the issue yet on specific built... there was an issue in the past, but was fixed by Oracle.
    Try adding the property: deployment.security.use.insecure.launcher=true  in deplyment.properties.

    Have a look here

    Roy Essers

    Wednesday, September 26, 2018 8:16 AM
  • Thanks for  the reply.

    I ran into the problem you mentioned as well. Upgrading to Java 1.8.181 fixed that issue on 1709 and below. Also, I have deployment.security.use.insecure.launcher=true in my deployment.properties file.

    Here is what is in my deployment.properties file:

    deployment.javaws.autodownload=never
    deployment.javaws.autodownload.locked
    deployment.expiration.check.enabled=false
    deployment.expiration.check.enabled.locked
    deployment.expiration.check.enabled.locked
    deployment.expiration.decision=never
    deployment.expiration.decision.locked
    deployment.expiration.decision.suppression=true
    deployment.expiration.decision.suppression.locked
    install.disable.sponsor.offers=true
    install.disable.sponsor.offers.locked
    deployment.system.tray.icon=false
    deployment.system.tray.icon.locked
    deployment.console.startup.mode=hide
    deployment.console.startup.mode.locked
    deployment.user.security.exception.sites=C:/Windows/Sun/Java/Deployment/exception.sites
    deployment.security.use.insecure.launcher=true

    I tried sequencing on both 1703 and 1803 using the 1803 ADK to install the sequencer.  

    In the App-V package I have the following checked.
    "Allow all named objects to interact with the local system"
    "Allow all COM objects to interact with the local system"

    Next I'm going to try JRE 10.0.2 to see if that makes a difference.

    Jim

    Wednesday, September 26, 2018 1:29 PM
  • I figured out the problem and wanted to report back what the fix was.

    Sequencing Java using PVAD instead of VFS fixed the issue I was having on Windows 10 1803.

    Jim

    • Marked as answer by Jim.Webb Tuesday, October 2, 2018 4:26 PM
    Tuesday, October 2, 2018 4:26 PM