locked
Local session manager is unable to connect to the Windows video subsystem RRS feed

  • Question

  • Hi.

    Suddenly all my windows froze. I locked the computer (Windows-L) and went for a cup of coffee hoping it'd "blow over". When I got back, trying to unlock gives me a black screen before the monitor turns into power saving mode. After a while, the monitor turns back on, greeting me with the logon screen.

    Logging on another user in a parallel session works.
    All the processes in the "locked" session seem to be running; music is playing, tasklist from another computer gives the impression that everything's good.

    While browsing through the eventlog, I saw the following event in Microsoft -> Windows -> TerminalServices-LocalSessionManager/Operational:
    Error, Event ID 20: Attempt to send connect message to Windows video subsystem failed. The relevant status code was 0x80070102.

    The message gives 0 hits on google and repeats for every connection attempt, be from the console or via remote desktop from another computer.

    OS: Windows 7 Enterprise x64, fully patched

    Is there any hope for the locked session?
    Are there tools, logs, etc. that can assist in solving the problem?

    Magnus
    Friday, October 30, 2009 10:45 AM

All replies

  • I'm having the same issue sporadically when trying to connect remotely to my Windows 7 Ultimate x64 machine.  Every time, I'm able to get to the login screen remotely, and after logging in, the screen changes to the "Welcome" screen with a wait cursor.  A few seconds into that screen, the cursor freezes and about a minute later, I get this error:
    "This computer can't connect to the remote computer.  The two computers couldn't connect in the amount of time allotted.  Try connecting again.  If the problem continues, contact your network administrator or technical support."

    I've had to reboot the computer to get the error to go away.  Poking through the event log yielded the same error reported by Magnus Holm above. 

    Please advise.

    Román
    Wednesday, December 30, 2009 1:15 AM
  • Here we go again.
    Same issue, same data in the event log.

    When locking the console, trying to get back in, I got:
    "The task you are trying to do can't be completed because Remote Desktop Services is currently busy.
    Please try again in a few minutes. Other users should still be able to log on."

    Pressing OK and retrying gives a black screen after l/p is entered, it stays black for a while, then returns to the "Press CTRL + ALT + DELETE to log on" screen.

    Magnus
    Tuesday, January 26, 2010 10:09 AM
  • Same issue here- it happened to me today on a fully patched Win7 x64 system.  I was working away, and while using Aero flip3d to cycle thru some windows, the animation "froze" but the mouse was still moving, music was playing etc.  I was able to even CTRL+ALT+DELETE and "switch user" and log in under another account, same as the original poster, but I could not recover into my original session.  Just a perpetual black screen, and no RDP access either.  I had a lot of unsaved work in that session unfortunately. :-(

    Would love to know the cause and more importantly, if there is some sort of solution the next time it happens.  I was messing around with SysInternals "PSTools" suite thinking I could execute some kind of kill signal with pskill from my other machine, but all attempts to connect to the main computer even as an Admin were rejected with things like "could not access $ADMIN share" or "remote registry service not running", etc.

    Anyone got some more info on this or ideas?  I do have a tendency to install hotfixes beyond what is available in Windows Update- maybe I got trigger happy and installed a hotfix that I shouldn't have but seeing as how this issue dates back to Oct '09 that seems unlikely.

     

    Monday, April 19, 2010 6:37 AM
  • Hi All!

     

    http://technet.microsoft.com/en-us/library/ee891238(WS.10).aspx

    I think it's a problem with users try running video over RDP.

    Check your configuration, Open Remote Desktop Session host Configuration, right click on "RDP-Tcp" "Properties" , verify TAB "Client Settings".

    On "Redirection" check if "Audio and video playback" is select for disable the following (probably set i on).

    If you wish all user play video/audio over RDP uncheck that.

     

    Regards,

     

    Murilo Vitorino.


    Friday, May 27, 2011 2:57 PM
  • My users (myself included) are also experiencing the problem. I haven't been able to determine what the status code (0x80080102) means, maybe it has a clue into why it's failing.

    Is there a hot fix for this, or at least something in the works? If we understood what was happening and/or why it would help but at the moment we're in the dark and I'm unable to answer questions as to why. Anyone? 

    Ok, just found out that the code means WAIT_TIMEOUT (from here: http://blogs.msdn.com/b/joshpoley/archive/2008/01/04/errors-007-facility-win32.aspx), now the reason is why is it timing out? What is hanging that is causing the connect call to time out, more importantly _why_ is it hanging?


    Sunday, July 10, 2011 5:05 PM
  • The problem is still occuring on server 2008R2 sp1 with all updates. Can someone from Microsoft respond in this thread?
    Saturday, May 19, 2012 6:05 PM
  • I am also having that same issue with Remote Desktop on a Server 2008 system. 

    Attempt to send disconnect message to Window video subsystem failed.  The relevant status code was 0x80070102

    Event ID 20

    Did anyone ever find a solution?

    Monday, August 27, 2012 5:51 PM
  • Hi guys,

    i have same problem with few different code (Attempt to send connect message to Windows video subsystem failed. The relevant status code was 0xd0000001.). Anyone have kown resolution?

    Friday, September 20, 2013 7:23 AM
  • Hello everybody!

    I have the same problem. Is there any resolution ?

    Monday, February 10, 2014 7:52 AM
  • Same here as well affecting people connecting to a RDS server running 2008 R2. This is anything but stable. Server is in a physical environment running on a Dell PowerEdge 2950.

    B

    Friday, February 21, 2014 4:13 PM
  • I get the same error on virtual machine with Windows Server 2012 R2:

    Event ID 20: Attempt to send connect message to Windows video subsystem failed. The relevant status code was 0x80070102


    Сазонов Илья http://isazonov.wordpress.com/

    Friday, May 23, 2014 11:48 AM
  • So is there a solution for this problem or not?
    Saturday, July 4, 2015 8:23 PM