locked
Remote desktop jump list crashes explorer RRS feed

  • Question

  • Recently the behaviour of the jump list for remote desktop connections has changed. It previously worked without problems. Now whenever I use a jump list item to establish a remote desktop the explorer stops working (this includes my taskbar) and needs to restart. If I circumvent the jump list and start a remote desktop it works fine. Other jump list like excel for example are still working fine.

    Does anyone know how to fix this because this problem is getting annoying.

     

    Thursday, January 27, 2011 12:17 PM

Answers

  • Hi all,

    Sorry that I haven't replyd in a while but I didn't have any time to look at the problem. I now have good news and bad news.

    The good news: the problem is gone.

    The bad news: I didn't do anything to accomplish it, the problem just disappeared.

    Everybody thanks for all the help and let us hope the problem stays gone.

    • Marked as answer by kleeven Friday, March 4, 2011 10:42 AM
    Friday, March 4, 2011 10:38 AM

All replies

  • Perhaps your jump list for Remote Desktop Connections is corrupt?

    You could try deleting or renaming the file associated with that jump list, which would be:

    • 1bc392b8e104a00e.automaticDestinations-ms , located in the following folder: %AppData%\Microsoft\Windows\Recent\AutomaticDestinations

    If that doesn't work, you can try resetting all jump lists by backing up and then deleting the contents of:

    • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
    • %AppData%\Microsoft\Windows\Recent\CustomDestinations


    FYI: To identify the file associated with a particular program's jump list, see my post here: Jump List History Location?

    Thursday, January 27, 2011 10:57 PM
  • Hi Joeboxer,

     

    Thanks for the reply. I tried looking for those folders with the associations but I don't seem to have them. Before you ask I have turned on the option to show hidden and system files. I also forgot to mention that I'm working with windows 7 professional edition 32-bit. That might narrow down the possible culprits.

    Friday, January 28, 2011 7:11 AM
  • I tried looking for those folders with the associations but I don't seem to have them.
    Ah, those folders are funky in that you can't really browse to them. You need to type/paste the entire folder path directly into the Windows Explorer address bar (or if you prefer, the start menu search field).

    Can you find the folders now? They should exist on every Windows 7 system.
    Friday, January 28, 2011 8:22 AM
  • I can find them now. I tried deleting the associated files, but to no avail. The explorer crashes as soon as I try to use a jump list item for remote desktop.
    Friday, January 28, 2011 10:03 AM
  • Just to make sure, after you cleared the contents of both the AutomaticDestinations and CustomDestinations directories mentioned above, did the remote desktop jump list reset? In other words, did the recent and/or pinned items actually get cleared? If not, you may need to unpin and re-pin remote desktop to get the change reflected. A restart shouldn't be necessary, but I suppose it couldn't hurt... seems to fix the oddest things.
    Friday, January 28, 2011 5:15 PM
  • The jump list did reset. It was cleared. After making some new connections the list filled up again, but the crash of explorer persisted. I have rebooted a couple of times since then but that didn't help much, that was actually one of the first things I tried.
    Monday, January 31, 2011 6:22 AM
  • Hi,

     

    Based on your description, it can caused by a corrupted user profile. I suggest performing a System Restore first.

     

    If this issue persists, please create a new user account to check the result.

     

    http://windows.microsoft.com/en-us/Windows7/Create-a-user-account

     

    Hope it helps.

     

    Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, January 31, 2011 10:31 AM
  • Hi Niki,

    Great suggestion, however all my restore points are from when I already had the problem and I'm using a domain user account so just making a new account isn't really an option. I guess I'll just have to live with it.

    Wednesday, February 2, 2011 6:42 AM
  • Hi,

     

    Since you are in domain environment, you can use another domain user account logon this computer to check if the issue persists. If so, the issue is caused by jump list feature on this computer. If the issue disappears, it is to say your user profile related to jump list corrupted. Please check if the following link is helpful.

     

    http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 3, 2011 9:19 AM
  • Hi Niki,

    Thanks for the tip, I was already giving up hope. I tried to logon using a different domain user account and the problem persisted. So it seems that the jump list feature on this computer is some how broken. Still strange that it only happens for remote desktop connections. At least I am closer to identifying the problem and hopefully a solution.

    Friday, February 4, 2011 1:28 PM
  • Hi,

     

    First, right click the taskbar -> properties -> Start Menu Tab -> uncheck two options under Privacy.

     

    After that, Please go to C:\Users\your username\Documents and delete Default.rdp to check the result. It is a invisible file. If you don't see it, go to Organize -> Folder and search options -> View Tab -> Show hidden files, folders, and drivers.

     

    After deleting the file and the next time you connect the Remote Desktop, it will reset the Remote Desktop Connection settings.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 8, 2011 1:46 AM
  • I removed all Default.rdp files I could find under users. But to no avail. The problem still persists. Even after a reboot after I removed the default.rdp files. Some how it seems to still remember my previouse connections because the remote desktop program still remembers all the previouse sites and usernames.
    Tuesday, February 8, 2011 10:43 AM
  • Some how it seems to still remember my previouse connections because the remote desktop program still remembers all the previouse sites and usernames.
    Just FYI, that's probably coming from the registry:
    • Under HKEY_CURRENT_USER\software\Microsoft\Terminal Server Client\Default , you'll probably see values like "MRU0" with data like "192.168.0.101".
    • Under HKEY_CURRENT_USER\software\Microsoft\Terminal Server Client\Servers\192.168.0.101 , you'll probably see values like "UsernameHint" with data like "MachineName\\UserName".

    Remote Desktop stores .bmc cache files under %LocalAppData%\Microsoft\Terminal Server Client\Cache\ - I seriously doubt that clearing those will help, but it probably can't hurt...
    • Marked as answer by Vivian Xing Tuesday, February 15, 2011 1:40 AM
    • Unmarked as answer by kleeven Friday, March 4, 2011 10:39 AM
    Tuesday, February 8, 2011 2:13 PM
  • Hi all,

    Sorry that I haven't replyd in a while but I didn't have any time to look at the problem. I now have good news and bad news.

    The good news: the problem is gone.

    The bad news: I didn't do anything to accomplish it, the problem just disappeared.

    Everybody thanks for all the help and let us hope the problem stays gone.

    • Marked as answer by kleeven Friday, March 4, 2011 10:42 AM
    Friday, March 4, 2011 10:38 AM
  • On my Windows 7 64 bit system I was able to clear this by following the suggestions to remove 

    • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
    • %AppData%\Microsoft\Windows\Recent\CustomDestinations
    • All  *.rdp files I could locate

    Hint: Use search to locate the AutomaticDestinations, CustomDestinations folders and the *.rdp files 

     
    Monday, May 21, 2012 5:39 PM
  • On my Windows 7 64 bit system I was able to clear this by following the suggestions to remove 

    • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
    • %AppData%\Microsoft\Windows\Recent\CustomDestinations
    • All  *.rdp files I could locate

    Hint: Use search to locate the AutomaticDestinations, CustomDestinations folders and the *.rdp files 

     
    This problem re-occurred and removing the .RDP files again and it cleared, It appears  that it's trashing the .rdp file in some way
    Monday, May 21, 2012 6:18 PM