none
Trouble registering Office Online Server RRS feed

  • Question

  • SharePoint 2016 server name:   ISshare16 (FQDN ISshare16.sub.domain.com)

    Office Online Server name: ISshareOOS (FQQN ISShareOOS.sub.domain.com)

    Internal URL for SP:  http://ISshare16.domain.com  External:  https://shareoos.domain.com (Sectigo issued certificate)

    On the OOS I ran:

    New-OfficeWebAppsFarm -InternalUrl "http://ISshareOOS.sub.domain.com" -ExternalUrl "https://shareoos.domain.com" -CertificateName "ShareOOS" -EditingEnabled -AllowHTTP

    Hitting the http://...hosting/discovery works for both URL's specified.

    One SharePonit if I try this:

    New-SPWOPIBinding -ServerName "ISshareOOS.sub.domain.com" -Application "Excel" 

    I get 

    WARNING: The server did not respond. Trying again (attempt 1 of 5).
    WARNING: The server did not respond. Trying again (attempt 2 of 5).
    WARNING: The server did not respond. Trying again (attempt 3 of 5).
    WARNING: The server did not respond. Trying again (attempt 4 of 5).
    WARNING: The server did not respond. Trying again (attempt 5 of 5).
    New-SPWOPIBinding : Sorry, we have encountered an error and New-SPWOPIBinding has failed. If you are using a server configured with HTTP, you must include the 
    -AllowHTTP parameter.
    At line:2 char:1
    + New-SPWOPIBinding -ServerName ....

    If I add the -AllowHTTP the commands works, BUT....

    PROBLEM:  I start getting Event ID 8311 in the event view:

    Log Name:      Application
    Source:        Microsoft-SharePoint Products-SharePoint Foundation
    Date:          9/11/2019 8:26:32 AM
    Event ID:      8311
    Task Category: Topology
    Level:         Error
    Keywords:      
    User:          domain\admin
    Computer:      ISshare16.sub.domain.com
    Description:
    An operation failed because the following certificate has validation errors:

    Subject Name: CN=shareoos.burke.com, OU=EssentialSSL, OU=Domain Control Validated
    Issuer Name: CN=Sectigo RSA Domain Validation Secure Server CA, O=Sectigo Limited, L=Salford, S=Greater Manchester, C=GB
    Thumbprint: xxxxx

    I tried adding the shareoos.domain.com cert by New-SPTrustedRootAuthority.  But I still get the 8311 errors.  Any ideas on cleaning up these 8311 errors?

    Thank you.

    Wednesday, September 11, 2019 8:56 PM

Answers

  • Hi,

    Besides what Trevor suggests, you can manually export the “shareoos.domain.com” certificate from server and then add the certificate to server's trust via Central Administration > Security > Manage Trust > New. 

    Perform an IISRESET afterwards.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by JFgriff Friday, September 13, 2019 9:08 AM
    Thursday, September 12, 2019 2:22 AM
  • Your ServerName parameter is wrong in that case. It should be 'shareoos.domain.com'.

    Trevor Seward

    Office Apps and Services MVP



    Author, Deploying SharePoint 2019

    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by JFgriff Friday, September 13, 2019 9:09 AM
    Thursday, September 12, 2019 4:51 PM
    Moderator
  • Never use HTTP for environments. What I would do is drop the -InternalUrl, then create an A record that points to the 'ExternalUrl' value within internal DNS to the internal IP of the load balance/OOS server.

    Trevor Seward

    Office Apps and Services MVP



    Author, Deploying SharePoint 2019

    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, September 11, 2019 11:30 PM
    Moderator

All replies

  • Never use HTTP for environments. What I would do is drop the -InternalUrl, then create an A record that points to the 'ExternalUrl' value within internal DNS to the internal IP of the load balance/OOS server.

    Trevor Seward

    Office Apps and Services MVP



    Author, Deploying SharePoint 2019

    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, September 11, 2019 11:30 PM
    Moderator
  • Hi,

    Besides what Trevor suggests, you can manually export the “shareoos.domain.com” certificate from server and then add the certificate to server's trust via Central Administration > Security > Manage Trust > New. 

    Perform an IISRESET afterwards.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by JFgriff Friday, September 13, 2019 9:08 AM
    Thursday, September 12, 2019 2:22 AM
  • Thank you Chelsa -- That is what the New-SPTrustedRootAuthority command did for me, but I didn't IISReset. I can try that.  

    Thanks for the suggestion.

    Thursday, September 12, 2019 3:46 PM
  • Thank you for responding Trevor.

    Remove-OfficeWebAppsMachine

    Reboot

    New-OfficeWebAppsFarm  -ExternalUrl "https://shareoos.domain.com" -CertificateName "ShareOOS" -EditingEnabled

    ping shareoos.domain.com resolves to the IP of isshareoos.sub.domain.com

    New-SPWOPIBinding -ServerName "isshareoos.sub.domain.com" -Application "Word" 

    WARNING: The server did not respond. Trying again (attempt 1 of 5).
    WARNING: The server did not respond. Trying again (attempt 2 of 5).
    WARNING: The server did not respond. Trying again (attempt 3 of 5).
    WARNING: The server did not respond. Trying again (attempt 4 of 5).
    WARNING: The server did not respond. Trying again (attempt 5 of 5).
    New-SPWOPIBinding : Sorry, we have encountered an error and New-SPWOPIBinding has failed. If you are using a server configured with HTTP, you must include the 
    -AllowHTTP parameter.
    At line:1 char:1
    + New-SPWOPIBinding -ServerName "isshareoos.sub.domain.com" -Applic ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (Microsoft.Share...tNewWOPIBinding:SPCmdletNewWOPIBinding) [New-SPWOPIBinding], SPCmdletException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewWOPIBinding

    I am need to wait until off hours, but I will try the IISRESET after I added the certificate to the SP trust.

    Thursday, September 12, 2019 4:19 PM
  • Your ServerName parameter is wrong in that case. It should be 'shareoos.domain.com'.

    Trevor Seward

    Office Apps and Services MVP



    Author, Deploying SharePoint 2019

    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by JFgriff Friday, September 13, 2019 9:09 AM
    Thursday, September 12, 2019 4:51 PM
    Moderator
  • Thank you!  That worked.

    It paused for a minute creating the binding and this showed in the event viewer:

    A certificate validation operation took 44998.0241 milliseconds and has exceeded the execution time threshold.  If this continues to occur, it may represent a configuration issue.  Please see http://go.microsoft.com/fwlink/?LinkId=246987 for more details.

    But the binding was made and it seems to be working.

    Friday, September 13, 2019 9:09 AM