(Win 7 Pro x64) Apply Operating System: 0x80070002


  • Hi guys,

    I'm fairly new to MSSC and SCCM 2012, but I've setup and used it for a little time now. Applicationdeployment works fine, as do the WSUS bit.

    What I'm having problems with is the OS deployment. I get to booting, so my boot 64/86 .wims works fine, but the problem happens when I'm done partitioning and formatting and proceed to the "Apply Operating System" part. Here it stops, leaving me with the error code 0x80070002.

    I have a network access account. The files are mapped from a share with access, even tried other shares on our servers. Distributed and refreshed installers/images etc. many times. 

    Any ideas as to what can be wrong here?


    Monday, October 21, 2013 8:12 AM

All replies

  • This is the only error message from the smsts.log:

    (__hrMethodRetVal == ((HRESULT)0L)) || (bFailIfMissing == false), HRESULT=80070002 (e:\NTS_SCCM_RELEASE\sms\common\inc\ccmxml.h,582) TSManager 10/21/2013 10:35:42 AM 1088 (0x0440)

    Followed by: "No condition is associated with the step. TSManager 10/21/2013 10:35:42 AM 1088 (0x0440)"

    Monday, October 21, 2013 8:39 AM
  • How do you have it set to apply the image?  Next available partition?  I prefer to set the variable in my partitioning step to "C" and then specify that drive letter in the Apply Operating System step.  This lowers the risk of failure.

    Mike Leach |

    Monday, October 21, 2013 7:05 PM
  • Hi Mike, thanks for your reply.

    I have set it to apply at specific logical drive letter destination, being letter C:

    When setting up the TS, I only get the option to use "Apply operating system from a captured image", but when I choose to edit the TS, I can change it to "Apply operating system from an original installation source". Both have been tried, and both have tried. I have also set it to "Access content directly from the distribution point".

    As far as I can see I dont get any big error messages in my smsts.log. What should I look for?

    Tuesday, October 22, 2013 9:42 AM
  • You aren't using R2, right? Did you also check the smsts.log files in these folders during Win PE?

    - X:\Windows\Temp\SMSTSLog\
    - C:\SMSTSLog 
    - C:\_SMSTaskSequence

    You should be able to find more information in the smsts.log.

    Tuesday, October 22, 2013 11:30 AM
  • Hi Michael.

    I dont get a folder called "_SMSTaskSequence", but I was able to extract the log from "Windows\Temp\SMSTSLog", and it showed some more errors than the other:


    (__hrMethodRetVal == ((HRESULT)0L)) || (bFailIfMissing == false), HRESULT=80070002 (e:\NTS_SCCM_RELEASE\sms\common\inc\ccmxml.h,582) TSManager 10/22/2013 1:45:15 PM 1084 (0x043C)

    Empty location for package: _SMSTSAWL00042 ApplyOperatingSystem 10/22/2013 1:45:25 PM 1456 (0x05B0)

    Failed to run the action: Apply Operating System.
    The system cannot find the file specified. (Error: 80070002; Source: Windows) TSManager 10/22/2013 1:45:25 PM 1084 (0x043C)

    The execution of the group (Build the Reference Machine) has failed and the execution has been aborted. An action failed.
    Operation aborted (Error: 80004004; Source: Windows) TSManager 10/22/2013 1:45:25 PM 1084 (0x043C)

    Failed to run the last action: Apply Operating System. Execution of task sequence failed.
    The system cannot find the file specified. (Error: 80070002; Source: Windows) TSManager 10/22/2013 1:45:25 PM 1084 (0x043C)


    Tuesday, October 22, 2013 11:52 AM