Atheros AR5005G and "This device cannot start. (Code 10)" error


  • Hi,

    I have an Acer Aspire 5102wlmi and I'm currently using Windows XP Home with SP3 and automatic updates. My wireless networking card is an Atheros AR5005G as stated.

    My current problem is that a week ago it suddenly stopped working an reported a "This device cannot start. (Code 10)" error on device manager. Since then I've trying uninstalling the driver and re-scanning for new devices with no luck. I have also tested all the avaiable (old and new) drivers, both from Acer and Atheros websites. I even started to think that it might be actually a hardware fault and to verify it I tried to setup networking on a Linux livecd and got a big surprise when I found that the card is working flawlessly on it.

    I was indeed surprised when I saw that device manager is sometimes naming the card it founds as "Atheros AR5005G Wireless Network Adapter #2" while I only have one adapter, so this leads me to suspect that the cause may be software related.

    I have not tried reinstalling Widonws since a problem with my USB ports (will post it on another thread on this forum) is preventing me from running the Windows setup CD.

    I would appreciate any ideas on how to overcome this problem without reinstalling or any help on cleaning the registry to try to get all the devices and drivers reinstalled.

    Saturday, July 18, 2009 8:19 PM