none
VMM / Orchestrator : Deploy VM from template

    Question

  • Hi Everyone,

    I’m currently building a runbook in Orchestrator 2012 RTM to automatically deploy VM via SCVMM2012 IP.
    I’m using the Create VM From Template activity with the following parameters :
    Destination Type : Host
    Destination : myhostname
    Path : c:\virtualinfra\vms
    VmName : TestFromOrchestrator
    Source Template Name : [Bronze]Template001
    Cloud Capability Profile : Hyper-V
    Virtual Network : Internal Only
    Computer Name : TestFromOrchestrator
    Each time that I try to deploy a VM from that Runbooks, I’ve got the following error
    Error (12700)
    VMM cannot complete the host operation on the GDCGMSO901.vnextlab.local server because of the error: 'TestFromOrchestrator' failed to modify device 'Microsoft Emulated Ethernet Port'. (Virtual machine ID 48035B33-94DD-4EB7-AA67-6750B5C5E4CD)
    'TestFromOrchestrator' Static MAC address 000000000000 for Legacy Network Adapter () is invalid.
    Unknown error (0x8005)
    Recommended Action

    Resolve the host issue and then try the operation again.

    My Hyper-V infrastructure is a single host and a Virtual Network configured as Internal Only (My VMs could only communicate with the Host and the others VMs, it’s what I want). If from VMM2012, I use the same template to deploy the vm it works perfectly, without any error, my VM gets well an IP from my ippool.

    After 3 min, In the Orchestrator Logs, I've got the error below :

    The following errors occurred when invoking PowerShell script:Processing data for a remote command failed with the following error message: The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
     

    Exception: InvalidOperationException
    Target site: PSRunspaceInvoker.HandleInvokeErrors

    Stack trace:
       at Microsoft.SystemCenter.Orchestrator.Integration.PowerShellConnector.PSRunspaceInvoker.HandleInvokeErrors(IList invokeErrors)
       at Microsoft.SystemCenter.Orchestrator.Integration.PowerShellConnector.PSRunspaceInvoker.Invoke(RunspaceInvoke runspace, String script, ILogger logger)
       at Microsoft.SystemCenter.Orchestrator.Integration.PowerShellConnector.PSScriptRunner.Execute(String script)
       at Microsoft.SystemCenter.Orchestrator.Integration.VMM2012Domain.VM.CloneFromTemplate(String vmmServer, ParameterList inputParameters)
       at Microsoft.SystemCenter.Orchestrator.Integration.VMM2012QIK.VM.CloneFromTemplate.DoExecute(IActivityRequest request, ILogger logger)
       at Microsoft.SystemCenter.Orchestrator.Integration.VMM2012QIK.ActivityBase`2.Execute(IActivityRequest request, IActivityResponse response)

    Thank you for you help

    Christopher


    Christopher Keyaert - MVP - My SCUG.be blog : http://scug.be/blogs/christopher

    Tuesday, June 12, 2012 2:47 PM
    Moderator

All replies

  • I tried to deploy the same template from PowerShell, and It failed, exactly same error that I've got with the IP.
    If I deploy it from VMM, with the same template, it worked perfectly. :s

    PS C:\Windows\system32> New-SCVirtualMachine -Name test014 -Path C:\VirtualInfra
    \VMs  -VMHost gdcgmso901.vnextlab.local -VMTemplate '[Custom]Template001'
    New-SCVirtualMachine : VMM cannot complete the host operation on the GDCGMSO901
    .vnextlab.local server because of the error: 'test014' failed to modify device
    'Microsoft Emulated Ethernet Port'. (Virtual machine ID F448144B-F857-4F3F-932E
    -F0EEBB603381)
    'test014' Static MAC address 000000000000 for Legacy Network Adapter () is inva
    lid. (Error ID: 12700, Detailed Error: Unknown error (0x8005))

    Resolve the host issue and then try the operation again.

    To restart the job, run the following command:
    PS> Restart-Job -Job (Get-VMMServer localhost | Get-Job | where { $_.ID -eq "{0
    3cba360-b9e5-4ccd-a5f7-ff2001208412}"})
    At line:1 char:21
    + New-SCVirtualMachine <<<<  -Name test014 -Path C:\VirtualInfra\VMs  -VMHost g
    dcgmso901.vnextlab.local -VMTemplate '[Custom]Template001'
        + CategoryInfo          : ReadError: (:) [New-SCVirtualMachine], CarmineEx
       ception
        + FullyQualifiedErrorId : 12700,Microsoft.SystemCenter.VirtualMachineManag
       er.Cmdlets.NewVmCmdlet


    Christopher Keyaert - MVP - My SCUG.be blog : http://scug.be/blogs/christopher

    Wednesday, June 13, 2012 12:37 PM
    Moderator
  • I am not sure what is wrong.

    have you tested with other templates?

    I looks like an error in SCVMM Powershell module, or maybe something is corrupt in your SCVMM.

    I have tested the Create VM from Template on 20+ environments without problems.

    maybne it would be a good idea to ask in SCVMM forum too (if you haven't already)


    Best Regards
    Jakob Gottlieb Svendsen
    Trainer/Consultant - Coretech A/S - Blog
    MCT - MCTS - VB.NET - C#.NET - Powershell - VBScript Mastering System Center Orchestrator 2012 - 3 day workshop - worldwide training click here

    Friday, July 06, 2012 9:25 AM
  • In SCVMM, try to Add a Legacy Network Adapter in the template with appropriate settings.

    And Save As A new Hardware profile and use the same to create VM.




    Vijesh Ollithodi

    Friday, October 19, 2012 9:37 PM