none
GPO: enable win32 long paths

    Question

  • I tried asking this question in the normal Microsoft Answers Community, but since it is a local policy, they said to come over here...

    I saw that the Windows 10 Anniversary Update was supposed to address the limitation of long file paths and names.  According to what I found, the new GPO entry of "enable NTFS long paths" was supposed to be added, but I didn't see it.  Upon further research, I did find the "enable win32 long paths" option one level up in the Local Policy Editor.

    Question:  Was this setting supposed to address the problem?  After I enabled it, rebooted the computer and confirmed that the setting was still enabled, I tried to copy a directory (via File Explorer) from a local hard drive (G:\*.*) to a server share (\\SERVER\SHARE), but it failed for the same old reason that the pathname was too long.  Does this only work locally, or does it only work with specific capabilities, like PowerShell?

    Thursday, August 11, 2016 5:16 PM

Answers

All replies

  • Hi,

    Thanks for your post.

    You can compare the two GPOs and it looks like they have the same setting and effect.

    Enable NTFS long paths

    Enable Win32 long paths

    According to my research, you could enable NTFS Long Paths using Group Policy Editor or by using a Registry tweak.

    How to enable NTFS Long Paths in Windows 10 using Group Policy

    1. Press Win + R keys together on your keyboard and type: gpedit.msc

    2. Press Enter and Group Policy Editor will open. Go to Local Computer Policy -> Computer Configuration -> Administrative Templates -> System -> Filesystem -> NTFS.

    3. There, double click and enable the option Enable NTFS long paths.

    4. Restart Windows 10.

    How to enable NTFS Long Paths in Windows 10 using a Registry tweak

    1. Open Registry Editor.

    2. Go to the following Registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Policies

    If you don't have such a key, then just create it.

    3. On the right side, create a new 32-bit DWORD value named LongPathsEnabled. Set its value data to 1.

    Note: Even if you are running 64-bit Windows, you still need to create a 32-bit DWORD value.

    4. Restart Windows 10.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 12, 2016 3:12 AM
    Moderator
  • Hi,

    Please try to run GPupdate at your computer and using the registry method to have a test, the  report back.

    Thanks for your cooperation.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 15, 2016 2:03 AM
    Moderator
  • Hello Infinity,

    Did you find a solution? I've also enabled the long path policy but Windows Explorer is still refusing to create nested folders with cumulative path length greater than the old path limit.

    Thanks,

    Amine.

    Friday, August 19, 2016 8:47 PM
  • Hi,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 22, 2016 2:25 AM
    Moderator
  • The path you entered, is too long. Enter a shorter path
    File Name could not be found. Check the spelling of the filename, 
    and verify that the file location is correct.
    Wednesday, August 24, 2016 6:55 AM
  • The path you entered, is too long. Enter a shorter path
    File Name could not be found. Check the spelling of the filename, 
    and verify that the file location is correct.
    Wednesday, August 24, 2016 6:57 AM
  • I used to have similar problems too, but after using
    "long path tool" You can use to solve this problem.
    Saturday, September 3, 2016 2:14 PM

  • Long path tool is the very good program for error, unlock solution. 
    Try it and solve your problem.
    I used long path tool and I solve my error, unlock problem solution.
    • Proposed as answer by aiden carter Thursday, October 13, 2016 11:01 AM
    • Unproposed as answer by aiden carter Thursday, October 13, 2016 11:01 AM
    Thursday, October 13, 2016 11:00 AM
  • Hi,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    I have the same problem and IMHO the OP's question has not been answered. "Use shorter paths" or "use a 3rd party tool" are no answers. We need this "Enable Win32 long paths" GPO to work as the name and description suggests.

    In my case it is not a network share but I sometimes receive zip archives with deep folder trees and very long file names. If I expand them into my own folder structure I hit that limit. I know from other people in legal and financial business areas that are confronted with this limitation.

    Sunday, November 20, 2016 3:14 PM
  • Hi,

    I have the same problem.
    The File Explorer crashes ....
    The biggest problems are with PDF files. Maximum characters 230.

    Thanks and Greetings
    Michael




    • Edited by Much_r Friday, January 13, 2017 1:00 PM
    Friday, January 13, 2017 10:25 AM
  • This is completely wrong in regards to windows 10 and does not answer the question. Please remove this as the answer.
    Monday, January 16, 2017 4:52 PM
  • Kannst du mir bitte dann die Lösung geben?
    Wenn ich auf eine zu langen Pfad zugreife, stürtzt der Explorer ab...

    Dein Komentar ist auch nicht hilfreich...

    Friday, February 17, 2017 3:06 PM
  • Windows Explorer (File Explorer) does not support filenames longer than 260 characters, and does not support paths to folder longer than 248 characters.

    This seems to be by design, and locked in due to some API contractual requirement related to the "MAX_PATH" variable.  That group policy setting or registry setting does not change this,  there are only workarounds.

      1. Use Powershell
      2. Use the Command Prompt
      3. "Choke up" on the local file path
        1. If this is a local windows path you can use the "subst" command to mount a virtual network drive
        2. Open a command prompt
          1. Run the command: "subst x: C:\*really long path*
          2. Next use File Explorer to browse to the X:\ drive. (by choking up on the long path, you can access the files)
          3. Delete, move or rename them as needed
        3. Run "subst x: /D" to delete the shortcut substitution!
      4. "Choke up" on the network path
        1. If the file is on a remote server you can mount a directory into the path to get around the limitation
        2. Open a command prompt
        3. Run the command:  "net use x: \\SERVER\SHARE\*long path*
        4. Next use File Explorer to browse to the X:\ drive. (by choking up on the long path, you can access the files)
        5. Delete, move or rename them as needed
        6. Run "net use x: /delete" to delete the network drive once you're done!


    Dan Metzger

    • Edited by Dan Metzger Wednesday, March 8, 2017 9:58 PM
    Wednesday, March 8, 2017 9:57 PM