locked
Question about making internal extension call from Lync to Cisco Phone RRS feed

  • Question

  • We have Lync 2010 enterprise setup with mediation server and we are trying to integrate Lync to Cisco CUCM 7.1.3.32900-4. We setup a SIP-Trunk from CUCM/Lync Trunk configuration/CUCM mobility and we are using default settings for Dial Plan/Voice Policy/Route/PSTN Usage. We do not have DID setup and users are dialing xxx for internal extensions from Cisco desk phone.

    Here is what we got so far:

    -          Users can use Lync client to IM and make Lync calls within the company

    -          Users can use Lync client dial pad to dial external calls without any problem (Lync client to 1(xxx)xxx-xxxx)

    -          Users can dial 787xxx(internal extensions) to make call from Cisco desk phone to Lync Client. (SIP-Trunk and route pattern is working)

    -          Users ended call (Lync to external number) from Lync client, it will put the phone on hold for few second and users can pick up the Cisco desk phone and continue the calls. (I think part of the CUCM mobility is working so far)

    However, Users can not dial from Lync Client to Cisco desk phone with xxx (internal extensions) or with 787xxx. They also cannot receive calls from outside (external phone calls) to Lync Client. I did extensive research and do know about the following solutions (Lync with CUCI-Lync and Lync Remote Call Control with CUPC). However, we are trying to avoid those two solutions. I also know that dual forking is not supported by MS/Lync and that’s why we are trying to setup Cisco CUCM mobility feature for simultaneous ring.

    Here are the problem or thing needs to accomplish:

    1.       Users can answer call from outside/external calls by using Lync client

    2.       Users can use Lync client to call Cisco desk phone by dialing the internal extensions (xxx)

    3.       Users can choose to use either the Lync client or the Cisco desk phone when they are trying to call either external calls (1(xxx)xxx-xxxx) or internal calls (xxx)

    Can the above be done without CUCI-Lync and CUPC/RCC? I think it is doable since we got part of it working.  (Lync client can makes call to external and Lync client and receives call from Cisco desk phone by dialing 787xxx)


    Thank You all in advance!! =)
    Thursday, August 25, 2011 4:07 PM

All replies

  • Hi,Ar Kai,

    If the inbound call fails on Lync client there might be the normalization rule or port issue in most case.Did you normalize incomming phone numbers to E.164?Have you used the right port for the mediation server(5067 for TLS and 5068 for TCP)?

    Regarding Lync client call to Cisco externsion,I suspect it's voice route problem.Would you please check your configuration of Lync to CUCM routing?You can read through Mark A King's for more information.

    http://blog.unplugthepbx.com/2011/03/16/integrating-microsoft-lync-and-cisco-unified-communication-manager-part-3-configuring-cucm-to-route-calls-to-lync/

    And here is a good article posted by Lasse Lync integrate with CUCM,hope it can help you figure out more questions.

    http://tech.rundtomrundt.com/2011/03/lync-in-coexistence-with-cucm-part-1.html

    http://tech.rundtomrundt.com/2011/03/lync-in-coexistence-with-cucm-part-2.html

    http://tech.rundtomrundt.com/2011/03/lync-in-coexistence-with-cucm-part-3.html

    Another more information just for your reference.

    http://blogs.technet.com/b/drrez/archive/2010/10/12/direct-sip-cisco-unified-communications-manager-7-1.aspx

    Hope these useful!

    Regards,

    Sharon

    Monday, August 29, 2011 7:47 AM
  • Sharon, Thank you for your links and reply.

    Can you tell me where can I setup the normalize for incoming phone numbers? The Voice Routing within the Lync Control Panel is for outgoing only right? Yes, we are using TLS 5067 and TCP 5068 for our mediation server.

    Thanks again!

    Monday, August 29, 2011 4:54 PM
  • Ar Kai,the incoming phone number should be normarlized to E.164 by the global normalization rule by default but if the incoming phone number coming from the PSTN is prepended with a plus sign (a properly formatted E.164 phone number) Lync will assume the number is properly formatted and does not apply any translation rules.
    There are several things to check:

    1. If you are using a Direct SIP provider, they may be able to not send the + to your Lync server. Call your provider and ask if this is an option.
    2. If you are using a PSTN gateway or IP-PBX that is sending a +, you should be able to easily modify the incoming rule to drop the + sign (as your rule is most likely explicitly adding a +)
    3. If neither of these apply to you, then you will have to change your internal numbers to use a different number than the main office number as a base.

    Regarding the Voice Routing,yes,it's only for Lync dialing out.If you have both PSTN call and integreted devices they need different voice routing to route call from Lync to both.

    Here is an old simliar post talking about Lync call CUCM failed for your reference.

    http://social.technet.microsoft.com/Forums/en-AU/ocsvoice/thread/d799de65-6f3c-4dc1-8fb5-072e3418b7eb

    And a simliar post talking about inbound call failed

    http://social.technet.microsoft.com/Forums/en-AU/ocsvoice/thread/4d478089-b99f-4af8-a532-2638593d6332

    Hope this useful!

    Regards,

    Sharon

    Tuesday, August 30, 2011 9:54 AM
  • Thanks again for your reply Sharon!

    I'm still trying to figure out how to make internal extention phone calls from Lync client to Cisco deskphone. I did read through all the useful information from Mark A King's and Lasse's blog. Can anyone check out the following log?

     

    -- user1@domain.com is trying to make phone call from Lync client to Cisco deskphone with extention x235

    -- extention x235 is just a regular extention within the company

    -- we do not have DID and all extention are in xxx

    -- 10.2.2.2 is our Cisco CUCM Gateway (example)

    -- medsvr.domain.com = Mediation Server

    -------------------------------------------------------------------------------------------------------------------------------------

    StartLine SIP/2.0 404 Not Found

    Trace-Correlation-Id

    : 43146422 

    Instance-Id

    : 0004932A 

    Direction

    : incoming 

    Peer

    : medsvr.domain.com:5070 

    Message-Type

    : response

    Start-Line

    : SIP/2.0 404 Not Found

    From

    : "user1"<sip:user1@.domain.com>;tag=591f50a828;epid=f6ae6b8836

    To

    : <sip:+235@domain;user=phone>;tag=bd43764461;epid=0D3E4A6F66

    CSeq

    : 1 INVITE

    Call-ID

    : dfb337e4da0f496e94d1df12bdfa2c62

    VIA

    : SIP/2.0/TLS 10.2.1.36:61341;branch=z9hG4bKBF08706B.FA3CD753B63B4836;branched=FALSE,SIP/2.0/TLS 10.3.64.179:62788;ms-received-port=62788;ms-received-cid=FAD00

    CONTENT-LENGTH

    : 0

    P-ASSERTED-IDENTITY

    : <sip:+235@domain.com;user=phone>

    SERVER

    : RTCC/4.0.0.0 MediationServer

    ms-diagnostics

    : 10404;source="medsvr.domain.com";reason="Gateway responded with 404 Not Found (User Not Found)";component="MediationServer";SipResponseCode="404";SipResponseText="Not Found";sip-reason="Q.850;cause=1";GatewayFqdn="10.2.2.2"

    ms-diagnostics-public

    : 10404;reason="Gateway responded with 404 Not Found (User Not Found)";component="MediationServer";SipResponseCode="404";SipResponseText="Not Found";sip-reason="Q.850;cause=1"

    Reason

    : Q.850;cause=1

    ms-trunking-peer

    : 10.2.2.2

    ms-endpoint-location-data

    : NetworkScope;ms-media-location-type=intranet

    --------------------------------------------------------------------------------------------------------------------------------------------


    • Edited by Ar Kai Tuesday, September 6, 2011 2:58 PM
    Wednesday, August 31, 2011 5:02 PM
  • Ar Kai,this error indicated that can't find gateway on mediation server or the normalization rule is not correct,have you add the CUCM as a PSTN gateway and configured Dial plans for 2 sets?

    Regards,

    Sharon

    Thursday, September 1, 2011 10:30 AM
  • Sharon,

    Yes!! 10.2.2.2 CUCM is under PSTN Gateways with the following settings.

    Listening Port for IP/PSTN Gateway: 5070

    Sip Transport Protocol: TCP

    Alternate Media IP Address: 10.2.2.1 (Lync FE Server)

     

    For Dial Plan I only have 1 global dial plan with the following Normalization Rules

    Prefix All Committed ^(\d{11})$ +$1

    Without 1 All Committed ^(\d{10})$ +1$1

     

    I can dialed to outside 1(xxx)xxx-xxx from Lync client without any probelm.

    Thanks again!!

     

    Thursday, September 1, 2011 5:36 PM
  • Hi Ar,

     

    Are you sure port 5070 is used on CUCM? A standard sip/TCP is 5060. the same is true for MEdiation server - please be dsure you CUCM uses a proper port on Mediation servers - our Cisco guys were not too happy with a port by default and I set it to 5060 in configuration of our Mediation server.

    What is GatewayFqdn="10.2.3.1" btw?

    In you trunk configuration double check the '+' sign removal rule is present.

    HTH

     

     


    Alex Ignatenko | MCITP:Lync 2010, Messaging, Server 2008 | MCTS:UC Voice, Virtualisation, SCCM, SCOM, OCS | MCSE: Security
    Sunday, September 4, 2011 6:12 AM
  • Hi,

    If you are calling from Lync to CUCM, make sure the trunc (on cucm) has a CSS which can see the partition containg the extensions you are trying to reach. 

    Also, verify what number is actually reaching the CUCM. 

    You have the option to:

    1 - Transform the digits either on the Lync Trunk configuration page (Where you can verify the digits sendt to CUCM is without the +). Or

    2 - You can create a translation pattern in CUCM, and remove the + there.

    Try reading the logfiles in the cucm to verify which digits it receive (But from the looks of you Lync trace, it seems you are sending the + to CUCM). 


    Lasse Wedø,
    Blog:Tech@work, Twitter: @lawedo

    Please take a second to hit the green arrow on the left if the post was helpful, or mark it as an answer if it resolved your issue.
    Sunday, September 4, 2011 7:20 AM