locked
Client doesn’t retrieve DP List - "Received empty location update for CTM Job" RRS feed

  • Question

  • I’ve been bashing my head on this issue for some time now, and trawled through many, many posts on the Internet without being able to resolve my issue.

    Background

    We have a working SCCM setup on Domain1. Recently I pushed out Domain1’s agent to all Domain2 computers and servers via a Powershell script with explicit install parameters; this is all fine.

    Patching and Software deployments are working are on all the test desktops I’ve deployed on, so this is a checkpoint for me as I know that MP/DP/BITs (firewall ports) connectivity is all working fine. On the server I’m testing on with Software Updates I get the following:



    UpdatesStore.log – Recognises software update deployments and missing updates are returning the correct Status = Missing entry in the log.

    UpdatesDeployment.log – Acknowledges the above with “EnumerateUpdates for action (UpdateActionInstall) - Total actionable updates = 1”

    Further down the log, I get this error being flagged. I cannot determine if this is a red herring or not, but this post references the exact error and MS has dismissed it as not having any functional impact to SCCM.

    Failed to get SDM CI for update (Site_E0302A3C-FCA2-434A-8822-A1806E8739D3/SUM_96d2119c-c85d-4490-b58c-927d2ebe297c) from type store, error = 0x80070002

    https://social.technet.microsoft.com/Forums/windows/en-US/e5a3a864-2d0c-40be-b7c7-d27b48bee17c/failed-to-get-sdm-ci-for-update-from-type-store-error-0x80070002?forum=ConfigMgrCompliance

    I never see any entries for the “CIStateDownloadingPercent” at all though, so it never even attempts to download, which leads me onto ContentTransferManager.log.

    ContentTransferManager.log

    CCTMJob::UpdateLocations - Received empty location update for CTM Job {D6A97A39-6FE4-4524-BFAD-7AE24F2A1019}

    WUAHandler.log – Correct SCCM server set as WSUS source. “Existing WUA Managed server was already set”.

    LocationServices.log - Correct SCCM server set as WSUS Path.

    Boundaries and Boundary Groups

    I’ve configured IP Range Boundaries which covers the IP of the server in question. Additionally I have subsequently added Active Directory Site Boundaries as well, with no difference.

    Need some guidance on what else to check or look out for please. How does one go about checking that the Boundaries/Groups have actually kicked in and taken effect? I’ve wait up to an hour and then restarted the SMS Service and initiated the Machine Policy action cycle on the server in question.

    Tuesday, January 16, 2018 4:14 PM

All replies

  • I’ve configured IP Range Boundaries which covers the IP of the server in question. Additionally I have subsequently added Active Directory Site Boundaries as well, with no difference.


    You did not mention anything about boundary Groups. Have you created one, added the boundary and associated a DP?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, January 17, 2018 7:11 AM
  • I’ve configured IP Range Boundaries which covers the IP of the server in question. Additionally I have subsequently added Active Directory Site Boundaries as well, with no difference.


    You did not mention anything about boundary Groups. Have you created one, added the boundary and associated a DP?

    Torsten Meringer | http://www.mssccmfaq.de

    Yes I have, the IP Range and AD Site Boundaries are members of the Boundary Group which is referencing our MPs and DPs on Domain1.
    Wednesday, January 17, 2018 10:22 AM
  • Have you also checked if the content was successfully transferred to that DP?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, January 17, 2018 10:54 AM
  • Have you also checked if the content was successfully transferred to that DP?

    Torsten Meringer | http://www.mssccmfaq.de

    It's quite a few DPs, but yes, I always check that Content Distribution Compliance is at 100% before I initiate any action cycles on the end client.

    Also, the problem at the moment is that the end client doesn't even retrieve a list of DPs to check against; we'd see a different error if the DP in question is missing content.

    EDIT: ALSO just tested a application deployment to the server in question; application file was downloaded into CCMCACHE fine! Going to recheck logs and retry the Software Deployment action.

    CTM job {C9FB2E28-2CD3-44CA-8D60-47BDB85818FB} (corresponding DTS job {48489E9F-CA22-447F-A045-059D9E4544F2}) started download from 'http://sccm_dp123/SMS_DP_SMSPKG$/Content_04911a9d-1666-432c-9381-6f90b4f65e5b.1' for full content download.

    • Edited by Charsiu Wednesday, January 17, 2018 1:47 PM More info
    Wednesday, January 17, 2018 11:41 AM
  • Have you also checked if the content was successfully transferred to that DP?


    Torsten Meringer | http://www.mssccmfaq.de

    EDIT: ALSO just tested a application deployment to the server in question; application file was downloaded into CCMCACHE fine! Going to recheck logs and retry the Software Deployment action.

    CTM job {C9FB2E28-2CD3-44CA-8D60-47BDB85818FB} (corresponding DTS job {48489E9F-CA22-447F-A045-059D9E4544F2}) started download from 'http://sccm_dp123/SMS_DP_SMSPKG$/Content_04911a9d-1666-432c-9381-6f90b4f65e5b.1' for full content download.

    So considering my Update above where an application deployment succeeded, does that mean there is literally no associated DPs linked with the CTM Job below; which I presume are the updates?

    CCTMJob::UpdateLocations - Received empty location update for CTM Job {D6A97A39-6FE4-4524-BFAD-7AE24F2A1019}

    Content status is reporting as 100% compliant across the DPs, I'll redistribute once more and reattempt.

    Wednesday, January 17, 2018 1:50 PM
  • Hi, so did you find a solution? 

    what did you di to fix your problem? thanks a lot.


    Thursday, February 21, 2019 3:52 PM