locked
Defrag Detects RAID-0 HDD as SSD RRS feed

  • Question

  • I originally posted this on the Microsoft Community Windows 8.1 forum.  A Microsoft Support Engineer responded by telling me it would be better suited in Microsoft TechNet forum.  So here I am.  Any help would be appreciated.

    Anyway, I have Windows 8.1 Update 1 installed on a SSD drive.  I have a second SSD drive that is used for programs that benefit from high read rates.  Finally, I have four HDDs that are setup up as two RAID-0 arrays.  One is used for programs while the other is used for storage.  Defrag detects the SSDs as SSDs, and the first RAID-0 array is detected as a HDD.  However, the second RAID-0 array is detected as a SSD.  As a result, I can't defrag the drive using the GUI utility.  (UPDATE:  Running Defrag from the CMD line seems to work) 

    The problematic array is identified as an HDD using Intel's SSD Toolbox and RST driver utility.  So I'm not sure why Windows thinks it is a SSD.  Rerunning WINSAT did not resolve the issue.  Is there a way to overide the Windows drive detection?

    Tuesday, October 21, 2014 7:44 PM

Answers

  • Hi DarWun,

    Since there is a suspection this issue is related to the Intel Rapid Storage Technology v13.2.4.1000 drivers, we can uninstall the driver temporarily to have a detection with the Defragment to prove this assumption.

    Best regards

    • Marked as answer by DarWun Wednesday, October 29, 2014 5:29 PM
    Wednesday, October 29, 2014 1:43 AM

All replies

  • Hi DarWun,

    Disk Defragmenter uses the Windows System Assessment Tool (WinSAT) to evaluate the performance of the device by getting the “random read disc score” of the device. The performance threshold was determined by some I/O heuristics through WinSAT to best distinguish SSD from rotating hard disks. 

    Here is a blog for reference:

    Windows 7 Disk Defragmenter User Interface Overview

    http://blogs.technet.com/b/filecab/archive/2009/11/25/windows-7-disk-defragmenter-user-interface-overview.aspx

    There is a key in the registry, the Defragmenter will recognize the device as SSD when the value is above a specific valus.I recommend you check the values of “randomreaddiskscore”.Here is the path:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinSAT

    Here is a similar discussion(Pay attention to Tim`s response ):

    Why Windows 8 and 8.1 defragment your SSD and how you can avoid this

    http://www.outsidethebox.ms/why-windows-8-defragments-your-ssd-and-how-you-can-avoid-this/#sel=77:7,77:9

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Best regards   


    Wednesday, October 22, 2014 11:06 AM
  • Thanks Meipo.  I reviewed the information you linked to and checked the WinSAT registry value.  I think I understood everything I read.  But I'm still not clear on how Windows 8.1 determines the drive type for secondary drives.  The RandomReadDiskScore registry entry is the Random Read Throughput for the primary OS drive only.  On my system it has a value of 338,872 bytes/second.

    After checking the registry, I executed the command "WinSAT formal -restart clean".  The Random Read Throughputs from the disk test for the two SSDs were estimated to be 333.28 and 250.30 MB/s.  For the two Raid-0 HDD arrays, the Random Read Throughputs were 2.57 and 3.78 MB/s.  The first article you linked to mentioned a random read threshold of 8.0 MB/s being used for SSD determination.  Both Raid-0 HDD arrays have a random read throughput that is below the threshold.  Yet one array is being incorrectly identified as being an SSD.

    One of Tim's responses in the second article you linked to did make reference to a HDD being incorrectly identified as a SSD.  But the discussion focused on the metric Windows uses to classify the drives.  All I got out of it is that there seems to be some confusion as to how secondary drives are assessed.  Further down in the responses another user (Karl) stated he was having an issue with a HDD being detected as a SSD.  Unfortunately he was told to look elsewhere for input as the discussion was focused on SSDs being defragged.

    Based on the second article, I think I can work around the issue by creating a new optimization task that forces defragmentation on the incorrectly identified HDD.  But it would be nice to figure out why it was detected incorrectly in the first place.




    • Edited by DarWun Thursday, October 23, 2014 7:34 PM
    Thursday, October 23, 2014 6:09 PM
  • Considering the command worked,you can create a schedule task to run a .bat file within the Defrag command to Defrag the incorrectly identified HDD.

    Here are two similar situations that Defra detects the RAID array as SSD.

    Can't defragment drives because Windows detects HDD as SSD

    http://www.eightforums.com/performance-maintenance/51754-can-t-defragment-drives-because-windows-detects-hdd-ssd.html

    Windows 8 wrongly detects my Raid1 HDD as Solid state disk

    http://superuser.com/questions/783481/windows-8-wrongly-detects-my-raid1-hdd-as-solid-state-disk

    Tuesday, October 28, 2014 10:06 AM
  • Thanks Jzmine.  I found both of the items you linked to when I started scouring the internet for a solution.  Unfortunately, both point towards other resources related to SSDs being detected as HDDs, and not to RAID HDDs being detected as SSDs.  Although the problems seem similar, none of the solutions to fix the SSD detection issues have been applicable when a HDD is not detected correctly (as least as far as I have been able to determine).

    Over the weekend I blew up the raid array and installed both HDDs that were part of that array as individual drives.  They were both detected as HDDs.  When I then recreated a RAID-0 array using those drives, the new array was once again detected as a SSD.  There may be a bug in the Intel Rapid Storage Technology v13.2.4.1000 drivers leading to the incorrect drive type being detected.  But it is strange that only one of the RAID-0 HDD arrays in the system is not being detected properly. 

    I was hoping there was an easy way to manually override the windows drive detection.  I'm starting to suspect that that is not the case.

    Tuesday, October 28, 2014 2:02 PM
  • Hi DarWun,

    Since there is a suspection this issue is related to the Intel Rapid Storage Technology v13.2.4.1000 drivers, we can uninstall the driver temporarily to have a detection with the Defragment to prove this assumption.

    Best regards

    • Marked as answer by DarWun Wednesday, October 29, 2014 5:29 PM
    Wednesday, October 29, 2014 1:43 AM
  • Hi MeipoXu,

    After uninstalling the RST drivers on previous versions of windows (both 7 and 8), my system either wouldn't boot or I had issues with RAID drives not being recognized.  So I have been hesitant to uninstall them from my current Windows 8.1 installation.  While looking for information on the best way to uninstall them, I stumbled across an October 4, 2014 post in the Intel User forums entitled "Intel RST installation incorrectly sets hard drive media type Windows 8.1 Pro x64".  The problem the user is asking for help on is the same as mine.  No resolution has been posted yet for the most recent WHQL RST driver.  But the Intel forum moderator responded by saying "we have received comments from other users experiencing issues with the new version of the RST. We already sent this information to the Engineering team, and they are working on it", and another user identified that reverting back to a previous version resolved the issue.

    So it looks like the RST v13.2.4.1000 drivers are the likely source of my problem.  Thanks for your help.

      

    Wednesday, October 29, 2014 5:29 PM
  • The easiest solution is probably to defragment the volume manually from the command line (as admin):

    defrag C: /u


    • Edited by Machta Wednesday, November 4, 2015 11:17 AM
    Wednesday, November 4, 2015 11:14 AM
  • After I updated my bios the raid was seen as HDD again.

    In my case it was asus x99-a motherboard, and the update was to 1901.

    Friday, December 11, 2015 7:21 PM