locked
Windows 8 Blue Screen DPC_WATCHDOG_VIOLATION Only when computer is left idle RRS feed

  • General discussion

  • Hello guys,

    I'm getting this blue screen only if I leave the computer idle! I play very tough and demanding games and watch Full-HD movies and listen to songs and do everything and the computer works like a charm with not a single problem; but if I pause the video we're watching or just leave the computer untouched for more than 5 minutes (approximately) the computer blue-screen crashes with the DPC_WATCHDOG_VIOLATION message.

    I went to action center, but nothing there helps.

    Any suggestions? Thank you.

    Saturday, July 20, 2013 10:48 AM

All replies

  • It may help to look at the minidump files from the crashes with a debugger.

     

    Can you zip up the minidump files in the C:\Windows\Minidump folder and make available (provide link) via Windows Live SkyDrive or similar site?

     

    The following link has information on using Windows Live SkyDrive:

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

     

    If you have problems zipping the minidump files copy the minidump files to another location such as a folder on the Desktop

     

    Also, you do not necessarily have to zip up the minidump files, you can upload them one at a time.

    Saturday, July 20, 2013 12:55 PM
  • Here is the minidump file on Skydrive. Thank you.

    https://skydrive.live.com/redir.aspx?cid=f6b3a042bb446350&page=self&resid=F6B3A042BB446350!108&parid=F6B3A042BB446350!107&authkey=!AgNxkbsNOMuCLl8&Bpub=SDX.SkyDrive&Bsrc=Share

    Saturday, July 20, 2013 3:47 PM
  • The dump files point to the nvstor.sys:

    BUCKET_ID:  0x133_DPC_nvstor+15649

    The nvstor.sys is the NVIDIA storage controller driver.

    You may benefit from updating the nvstor.sys to the nvstor64.sys.

    Can you do the following:

    Right-click the Action Centre icon on the Taskbar > Open Windows Update > Check for updates.

    Does an update show up for "Storage" (nForce Serial ATA Controller)?

    Also, there appears to be a BIOS update available for the 132-CK-NF79 motherboard so consider updating the BIOS.

    As a general precaution backup any critical files prior to updating the BIOS as the rare possibility of a failed BIOS update may result in the computer not being able to boot.


    • Edited by auggyMVP Saturday, July 20, 2013 5:46 PM grammar
    Saturday, July 20, 2013 5:45 PM
  • There are no updates in Windows Update. That was the first thing I did when the problem happened...

    Do you think the BIOS update could fix this? My motherboard is old, so I'm afraid a fail could happen there and then I'd lose my motherboard.

    What do you think?

    Thank you.

    Saturday, July 20, 2013 7:00 PM
  • Can you provide some more info on the computer which may help identify issues:

     Start > type msinfo32 and click on  msinfo32.exe > File > Save > then save as an .nfo file.

    Then make the resulting .nfo file available via Windows Live SkyDrive.

    Also, can you do the following:

    Start > type eventvwr click on eventvwr.exe > expand "Custom Views" and then right-click "Administrative Events" > select "Save all events in Custom View As" and save as an .evtx file

    Then make the resulting .evtx file available via Windows Live SkyDrive.




    • Edited by auggyMVP Saturday, July 20, 2013 7:19 PM accuracy
    Saturday, July 20, 2013 7:17 PM
  • The new info is available at:

    https://skydrive.live.com/redir.aspx?cid=f6b3a042bb446350&page=self&resid=F6B3A042BB446350!109&parid=F6B3A042BB446350!107&authkey=!AlYNIFhdCWIEG9o&Bpub=SDX.SkyDrive&Bsrc=Share

    I tried to update the BIOS, and that didn't work. The AWDFlash program has a problem and cannot match the bios file with the bios identity in the motherboard...

    And I think updating the SSD drive's firmware is not an option, since the operating system is installed on it (I think it's on the last version already... not sure... I had an SSD firmware update campaign like a year ago)... the weird part is that it worked before! this problem is pretty new... it just started like a month or two ago (I don't remember precisely).

    Thank you.

    Saturday, July 20, 2013 8:01 PM
  • Looking at the Event Viewer log shows the first blue screen error (DPC_WATCHDOG_VIOLATION) occurred on Feb 19, 2013.

    Do you recall any software or hardware change that would have corresponded with the appearance of this error?

    There also appears to be some random freezing.

    Also, this error for source "nvstor":

    Reset to device, \Device\RaidPort2, was issued.

    The nvstor.sys presently installed appears to be, according the System information, version 10.6.0.22 which would be the driver supplied by Windows.

    Can you try updating the storage driver by installing the motherboard chipset drivers from NVIDIA:

    http://www.nvidia.com/object/nforce-vista-win7-64bit-15.58-driver.html

    These drivers are for Windows 7 64-bit but should install in Windows 8.

    Also, I might suggest to check Volume F for errors as the Event Viewer indicates file system structure on that volume such as from source "NTFS":

    Volume F: (\Device\HarddiskVolume7) requires an Online Scan.  An Online Scan will automatically run as part of the next scheduled maintenance task.  Alternatively you may run "CHKDSK /SCAN" locally via the command line, or run "REPAIR-VOLUME <drive:> -SCAN" locally or remotely via PowerShell.

    The following link has good info on checking a drive for errors:

    http://www.eightforums.com/tutorials/6221-chkdsk-check-drive-errors-windows-8-a.html

    Sunday, July 21, 2013 1:58 AM
  • So I have done a few things, but they all didn't help, and eventually it crashed again.

    1. I scanned drive F: using the properties of the drive, and then I used command prompt and typed

        chkdsk F: /scan

    It repaired some errors, but the computer still crashed.

    2. I installed the NVidia storage controller from the link you gave me (I unchecked the network driver, so just the storage driver was installed). But the system still crashed.

    No significant change was done on the computer before the date you pointed out (Feb, 19 2013). The only significant change was the change of the graphics card (EVGA GTX 670), which I purchased at Mar, 4 2013; and installed it in the computer a few days after that. The change was done because the previous card (GTX 295) was broken and didn't work anymore. The whole computer wouldn't start back then.

    The computer freezes occasionally, I would say like once every month. Which is not a problem basically. It just happens.

    Thank you for your help. I hope you're not out of ideas yet :)

    And let me point out that I'm impressed by your skills, and would love to learn how you could analyze all those event and dump files.

    Sunday, July 21, 2013 8:09 AM
  • Can you provide the minidump file(s) since installing the NVidia storage controller to see if anything has changed?

    I use WinDbg (Windows Debugger) of the Debugging Tools for Windows.

    There is a good tutorial in the following link:

    http://www.sevenforums.com/crash-lockup-debug-how/26584-configuring-debugging-tools.html

    To install only the "Debugging Tools" see "Install Debugging Tools for Windows as a Standalone Component" in the following link:

    http://msdn.microsoft.com/en-us/windows/hardware/gg463009.aspx

    Sunday, July 21, 2013 5:00 PM
  • Thank you again for your help. I repacked the minidump files. Please find it under this link:

    https://skydrive.live.com/redir.aspx?cid=f6b3a042bb446350&page=self&resid=F6B3A042BB446350!110&parid=F6B3A042BB446350!107&authkey=!AvbJ0EZnAJ_rexc&Bpub=SDX.SkyDrive&Bsrc=Share


    Sunday, July 21, 2013 7:03 PM
  • Hi,

    Here is the latest dump analysis:

    *******************************************************************************

    *                                                                             *

    *                        Bugcheck Analysis                                    *

    *                                                                             *

    *******************************************************************************

    DPC_WATCHDOG_VIOLATION (133)

    The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL

    or above.

    Arguments:

    Arg1: 0000000000000001, The system cumulatively spent an extended period of time at

              DISPATCH_LEVEL or above. The offending component can usually be

              identified with a stack trace.

    Arg2: 0000000000001e0d, The watchdog period.

    Arg3: 0000000000000000

    Arg4: 0000000000000000

    Debugging Details:

    ------------------

    TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\modclass.ini, error 2

    TAG_NOT_DEFINED_202e: 1

    DPC_TIMEOUT_TYPE:  DPC_QUEUE_EXECUTION_TIMEOUT_EXCEEDED

    CUSTOMER_CRASH_COUNT:  1

    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

    BUGCHECK_STR:  0x133

    PROCESS_NAME:  System

    CURRENT_IRQL:  d

    LAST_CONTROL_TRANSFER:  from fffff80026e51fa3 to fffff80026cd2440

    STACK_TEXT: 

    fffff800`26b98478 fffff800`26e51fa3 : 00000000`00000133 00000000`00000001 00000000`00001e0d 00000000`00000000 : nt!KeBugCheckEx

    fffff800`26b98480 fffff800`26d16774 : 00000000`00000000 00000000`0000d75c fffff800`26b98600 fffff780`00000320 : nt! ?? ::FNODOBFM::`string'+0x14600

    fffff800`26b98500 fffff800`26c2eeca : fffff800`26b98c10 fffff800`26f70180 00000000`2ae2afc3 00000000`26b98a39 : nt!KeUpdateTime+0x2ec

    fffff800`26b986e0 fffff800`26ccb73a : 00000002`00a3901a 00000000`2ae60e9e fffff800`26c58580 00000000`00000040 : hal!HalpTimerClockInterrupt+0x86

    fffff800`26b98710 fffff800`26d2d1a3 : fffff800`26f70180 fffff800`26efe000 fffff880`02ad1180 00000000`00000000 : nt!KiInterruptDispatchNoLockNoEtw+0x1aa

    fffff800`26b988a0 fffff800`26df372b : fffff800`26f70180 00000000`00000002 00000000`00000000 fffff880`014f3298 : nt!KxWaitForLockOwnerShipWithIrql+0x44

    fffff800`26b988d0 fffff880`014c87d9 : fffffa80`041bf1a0 fffff800`26b98a39 fffff800`26b98a39 fffff800`26d9c0a0 : nt!KiAcquireQueuedSpinLockInstrumented+0x6b

    fffff800`26b98920 fffff800`26cfb1ea : 00000000`00000004 fffff800`26b98a39 00000000`00000001 fffff880`02ad1180 : storport!RaidpAdapterTimerDpcRoutine+0x59

    fffff800`26b98970 fffff800`26d91464 : fffff800`26f72f00 fffff800`26cfacff fffff800`26b98bb0 fffff800`26f74aa0 : nt!KiProcessExpiredTimerList+0x22a

    fffff800`26b98aa0 fffff800`26cfb668 : fffff800`26f70180 fffff800`26f72f80 00000000`00000040 00000000`00006fb1 : nt! ?? ::FNODOBFM::`string'+0x15112

    fffff800`26b98b40 fffff800`26cfaa06 : fffffa80`05174010 fffff800`26f70180 00000000`81c087ec fffff800`26b98c4c : nt!KiTimerExpiration+0xc8

    fffff800`26b98bf0 fffff800`26cfb9ba : fffff800`26f70180 fffff800`26f70180 00000000`00183de0 fffff800`26fca880 : nt!KiRetireDpcList+0x1f6

    fffff800`26b98d60 00000000`00000000 : fffff800`26b99000 fffff800`26b93000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a

    STACK_COMMAND:  kb

    FOLLOWUP_IP:

    storport!RaidpAdapterTimerDpcRoutine+59

    fffff880`014c87d9 488b8b18020000  mov     rcx,qword ptr [rbx+218h]

    SYMBOL_STACK_INDEX:  7

    SYMBOL_NAME:  storport!RaidpAdapterTimerDpcRoutine+59

    FOLLOWUP_NAME:  MachineOwner

    MODULE_NAME: storport

    IMAGE_NAME:  storport.sys

    DEBUG_FLR_IMAGE_TIMESTAMP:  5130358b

    BUCKET_ID_OFFSET:  59

    FAILURE_BUCKET_ID:  X64_0x133_ISR_storport!RaidpAdapterTimerDpcRoutine

    BUCKET_ID:  X64_0x133_ISR_storport!RaidpAdapterTimerDpcRoutine

    Followup: MachineOwner

    ---------

    0: kd> lmvm storport

    start             end                 module name

    fffff880`014c7000 fffff880`0151c000   storport   (private pdb symbols)  f:\temp\\storport.pdb\523A1486CF0747AF87B6BABD74F009B72\storport.pdb

        Loaded symbol image file: storport.sys

        Mapped memory image file: f:\temp\\storport.sys\5130358B55000\storport.sys

        Image path: \SystemRoot\System32\drivers\storport.sys

        Image name: storport.sys

        Timestamp:        Fri Mar 01 12:58:51 2013 (5130358B)

        CheckSum:         000567FC

        ImageSize:        00055000

        File version:     6.2.9200.16547

        Product version:  6.2.9200.16547

        File flags:       0 (Mask 3F)

        File OS:          40004 NT Win32

        File type:        3.7 Driver

        File date:        00000000.00000000

        Translations:     0000.04b0

        CompanyName:      Microsoft Corporation

        ProductName:      Microsoft® Windows® Operating System

        InternalName:     storport.sys

        OriginalFilename: storport.sys

        ProductVersion:   6.2.9200.16547

        FileVersion:      6.2.9200.16547 (win8_gdr.130228-1507)

        FileDescription:  Microsoft Storage Port Driver

        LegalCopyright:   © Microsoft Corporation. All rights reserved.

    You can check this thread for reference:

    Windows BSOD from Storport.sys 

    http://social.technet.microsoft.com/Forums/windows/en-US/2286a468-8d47-42ae-a9ba-106a95642b3c/windows-bsod-from-storportsys

    Regards,


    Vincent Wang
    TechNet Community Support

    Monday, July 22, 2013 7:04 AM
  • It appears the  NVIDIA storage controller driver did not get updated.

    Can you check here?:

    Open the Device Manager and locate the "NVIDIA nForce Serial ATA Controller".

    It should be under "Storage controllers".

    Right-click the first "NVIDIA nForce Serial ATA Controller" > Update Driver Software > Browse my computer for driver software > Let me pick from a list of device drivers on my computer

    With "Show compatible hardware" being checked what is listed under "Model".

    What versions of the NVIDIA driver are listed?

    Click "Cancel" to exit out.


    • Edited by auggyMVP Monday, July 22, 2013 12:04 PM content
    Monday, July 22, 2013 12:02 PM
  • Sorry for the late reply. My browser crashed and I lost the topic's address; wasn't easy to find it again.

    Actually from the place where you asked for the version, the version isn't listed.

    The current version installed is 11.1.0.43 issued on 09.04.2010 from NVIDIA Corporation.

    There's a standard IDE controller. Should I try that? Or is that somewhat not smart?

    Tuesday, July 23, 2013 6:02 PM
  • There's a standard IDE controller. Should I try that? Or is that somewhat not smart?

    That could be a possible fix.

    However can you provide an updated .nfo and .evtx file?

    Also, as a preparation to manually changing a SATA controller driver have a recent system restore point available.

    I would also suggest to have a recovery drive or system repair disc or Windows installation media available as you can run system restore from the recovery options.

    Wednesday, July 24, 2013 5:25 PM
  • Thank you very much, man! I changed the driver to the Standard IDE Driver and the problem disappeared so far in the initial tests.

    Thank you very much for your help and your time. I appreciate it a lot.

    Summary: The computer was crashing because the nVidia ATA controller's driver of my nForce 790 Ultra SLi isn't fully compatible with Windows 8, and that caused the crashing problem to happen. The solution was to force the default windows driver to be installed, rather than the drivers from nVidia.

    Wednesday, July 24, 2013 7:55 PM
  • That's great! Hopefully that will keep working.

    Thanks for the follow-up.

    Wednesday, July 24, 2013 10:58 PM