none
Sprel keeps dying RRS feed

  • Question

  • At a customers installation I've run into an issue where the sprel process keeps dying. I cannot find any useful information in any logs, except that it dies, and is restarted over and over.

    I also tried to delete the sprel log files, but that didn't help. If I run it from the command line as a user in the FASTAdmin group, then it works just fine, so something fishy is happening somewhere ;)

    I have double checked the permissions on the log folder, and the FAST service user has full access and is owner of the folder.

    Any input would be appreciated.

    As a last resort we're thinking about clearing all data and re-indexing to see if that helps.

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Wednesday, March 9, 2011 7:49 PM

All replies

  • Have you tried messing around with spreladmin?

    http://207.46.16.252/en-us/library/ee943519.aspx

    At least it gives you the option of enabling more verbose logging. 


    http://www.comperiosearch.com/
    Thursday, March 10, 2011 10:45 AM
  • Hi Mikael, it seems i had the same issue as yours at one of my client site. what you are experiencing is a known FS4SP bug but luckily there is a workaround for it. this is what microsoft had to say about it: as long as the hostnames of the physical server and deployment.xml used in configuration wizard are different in cases, the SPRel and WebAnalyzer will refuse to start up properly. this was their workaround: Basically you need to make hostname consistent in all config files in etc folder, in addition the “Set-FASTSearchConfiguration” cmdlet is run against the new deployment.xml. Once all the steps are done both components can start up correctly. Here’s how I fixed my SPRel (put WA aside first) problem : 1. On node01: etc/waconfig.xml – change both host entries to lowercase in “waworkers” and “walookupdbs”. 2. On node01: etc/hostconfiguration.xml – change “hostname” to lowercase. 3. On node01: etc/Node.xml – change node01 to lowercase in “hostname”. 4. On node01: etc/config_data/deployment/deployment.xml – change node01 to lowercase in “host”. 5. Stop FAST Search for SharePoint service and Start it again.
    Thursday, March 10, 2011 12:47 PM
  • Hi Mikael,

    can u post ur deployment.xml

    If you have distributed web analyzer components on more than one server, make sure that the server with <webanalyzer server="true"  property, you have max-targets set to more than 0

     

     

    Thanks

    Friday, April 1, 2011 2:30 AM
    Moderator
  • It's a one machine deployment and it was working fine up until the SP db went full due to a crawl gone bad (basically crawling the internet), and we had to shut everything down in order to clean up the database.

    Ever since, we've been getting the error, and the last resort seems to be to clean out all of the indexed data, and see if sprel will start and recrawl everything.

    -m


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Friday, April 1, 2011 7:02 AM
  • This did not help. The customer have a support ticket open as well, and I will get more information next week on the status.

    -m


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Friday, April 1, 2011 12:56 PM