none
Manage Add-Ons using GPOs

    Question

  • I need some help managing add-ons using GPOs.  I've been reading some threads but I still have not been able to figure out the problem.  The OS i'm working with is Windows Server 2008 R2.  The servers are setup with Citrix 6.5, the profiles on the servers are deleted when users log off.  Once the users log back on and launch an application two add-on pop-ups come up.  I need to be able have the user logon with out the add-on pop-ups coming up because it causes problems for the users.  I have already added the CLSIDs to a GPO but the pop-ups are still coming up.  What am i missing, or what is the best way to fix this issue?  Any help would be greatly appreciated. 

    -Hector

    Friday, July 17, 2015 2:36 AM

All replies

  • are we talking about IE notifications?

    turn off the notifications http://gpsearch.azurewebsites.net/#7065

    • Edited by AlexAdkin Friday, July 17, 2015 10:06 AM
    • Proposed as answer by AlexAdkin Monday, November 07, 2016 9:16 PM
    Friday, July 17, 2015 10:05 AM
  • The notifications come from IE version 9 but the add-ons are from a third party.  The messages starts with the following "This webpage wants to run the following add-on:" followed by the name of the third party and the option to allow.  I have a GPO set up to load the CLSIDs once the users log in but the pop ups keep coming up.  The add-ons are needed, I tried disabling them but it caused problems with the applications.  I have the CLSIDs defined in the GPO under:

    Computer Configuration

    Policies

    Administrative Templates: Policy definitions (ADMX files) retrieved from the central store.

    Windows Components

    Internet Explorer

    Security Features

    Add-on Management

    The setting is set to enabled, the value name is the CLSID, and the value is set to 2.

    Any ideas on what i'm missing.

    Thanks,

    Hector 

     

    Monday, July 20, 2015 9:23 PM
  • The only way I've found to do this is by setting the following policy in the Group Policy Management (I did it on the user side)

    Administrative Templates > Windows Components > Internet Explorer

    "Turn off ActiveX Opt-In prompt" = enable

    I really wish this was a per-zone setting but apparently it's not. You could always use the settings per zone to lock down ActiveX controls/open up ActiveX controls more per zone as well.  That's what I ended up doing.


    Tuesday, September 15, 2015 6:41 PM