locked
Join Skype Meeting does not start the client RRS feed

  • Question

  • Hi,

    We often use Skype for Business for meetings in our terminal server environment. When we create such meetings we use the "New Skype Meeting" addin from Outlook. This is working as intended and a link is being generated in the calendar invite. 

    When we start the meeting by pressing the "Join Skype Meeting" button in the calendar, Internet Explorer is opened and ask us to download the "Skype Meetings App". We don`t want to use this app, we want to use our Skype for Business client which we have installed on the desktop. How can this be achieved?

    The workaround for now is copy the URL from IE and past it to Chrome. Then we get prompted to start the Skype for Business client.

    Monday, October 1, 2018 12:17 PM

Answers

  • Hi Whobe,

    What is your IE’s version, my version is 11.0.9600.19130, it works normally, you could update your IE to the latest version

    1. Go to Microsoft’s Internet Explorer 11 download page.

    2. Scroll down to your language.

    3. Click your operating system to download.

    4. Double-click the setup file.

    5. Click Yes.

    6. Follow the on-screen instructions to install.

    7. Click Finish.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Whobe1337 Monday, October 15, 2018 12:51 PM
    Tuesday, October 9, 2018 3:19 AM

All replies

  • Hi Whobe,

    Firstly, please select “set defaults by app” like the following screenshot.

    Then select“Lync” and “skype for business”,select the “manage”,please set them like the following screenshot.

    If you have set them, but the default app is still IE when you click the “ join the skype meeting”, you could change the default browser from IE to Chrome.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, October 2, 2018 6:18 AM
  • So what you are saying that this is not possible to achieve with IE as default browser?

    Everything is set up like the screenshot you provided except the default browser as we still want to use IE. For the record, we use Windows Server 2012 R2.

    Tuesday, October 2, 2018 6:45 AM
  • Hi ,

    If you want to use IE to your default browser, please check the current default of “.ocsmeet” , if it is skype for business.

    Then you could refer to the following link(Note:Lync setting is the same as SFB 2016, you could refer to it).

    https://blogs.perficient.com/2011/03/09/how-does-the-lync-client-automatically-launch-when-opening-a-lync-online-meeting-url/


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, October 2, 2018 9:18 AM
  • Hi,

    The MeetingJoinHelper Class is enabled, and the .ocsmeet  file association is "Skype for Business". Still when opening the link from Outlook calendar IE ask me to download the meetings app.

    Tuesday, October 2, 2018 1:32 PM
  • As I mentioned this is on a terminal server. On a local computer this is not a problem. Could there be something that needs to be configured on the terminal server?
    Monday, October 8, 2018 9:55 AM
  • Hi Whobe,

    What is your IE’s version, my version is 11.0.9600.19130, it works normally, you could update your IE to the latest version

    1. Go to Microsoft’s Internet Explorer 11 download page.

    2. Scroll down to your language.

    3. Click your operating system to download.

    4. Double-click the setup file.

    5. Click Yes.

    6. Follow the on-screen instructions to install.

    7. Click Finish.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Whobe1337 Monday, October 15, 2018 12:51 PM
    Tuesday, October 9, 2018 3:19 AM
  • Hi,

     

    Are there any updates for this issue, if the reply is helpful, please try to mark it as an answer,  it will help others who have similar issue.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, October 15, 2018 9:31 AM
  • Installing Windows and Office updates solved the problem. Thanks for the assistance!
    Monday, October 15, 2018 12:51 PM